WordPress.org

Ready to get started?Download WordPress

Forums

Language error? (8 posts)

  1. Aikikai
    Member
    Posted 7 years ago #

    Hi!
    I have installed template Blix 0.9.1, and successfully installed my language swedish. The problem is that the english language doesn't change in the Blix template, but in admin it is ok. How do i fix this?

    This category problem seems to be on every template I use.

    And in Blix 0.9.1 you can't see the link categories you have created. Now all links are displayed in one and same "category". How do I display the categories?

    Thank you for any help

    PS. Sorry for posting this in the wrong forum...

  2. moshu
    Member
    Posted 7 years ago #

    1. You should always mention what version of WP is in use.
    If you upgraded to 2.1. - search the forums... there are a lot of posts about the links/blogroll getting screwed up in this version.
    2. Blix is not compatible with 2.1. but there is a new version of it that it is. Again, it was announced in the forum, so search.
    3. The localization of themes and the WP has been separated for quite a long time. You need the translation file (.mo) for every theme if you want them to work in other languages. Of course, it will only work if the theme has been prepared for localization.

    4. Moved to the right forum.

  3. Aikikai
    Member
    Posted 7 years ago #

    Thanks moshu,

    I use version 1.5.2

  4. moshu
    Member
    Posted 7 years ago #

    In that case see #3.

  5. Aikikai
    Member
    Posted 7 years ago #

    If I would like to translate the words, in which file/files are the words located?

  6. moshu
    Member
    Posted 7 years ago #

    In all of the template files:
    header.php, index.php, archive.php, sidebar.php etc... - if you meant manually translating the strings.

  7. Aikikai
    Member
    Posted 7 years ago #

    Thanks mosu!

    I searched the forum, but I didn't find anything on thos problem: I have changed some words, but the typical swedish words like Ä Å Ö is changed to ? when i view the page. Why?

  8. moshu
    Member
    Posted 7 years ago #

    Because you saved the files in an editor that doesn't have utf-8 support. Or, if it has, you didn't set it like that!

    (and I answered this question about 50 times in the forum ;)

    Even in Notepad you have the option when saving to set the encoding at the bottom of the dialog window.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.