WordPress.org

Ready to get started?Download WordPress

Forums

WP Native Dashboard
[resolved] Language doesn't change for plugins (6 posts)

  1. Inversion
    Member
    Posted 1 year ago #

    It seems the plugin displays the wrong language in the dashboard. It chooses the Webpages' default language instead for plugins.

    e.g. if de_DE is the default language, but the display language is set to en_US then it will display the German language.

    Any way to fix this? Jetpack also shows the wrong language.

    See screenshot example:
    https://dl.dropbox.com/u/1527197/duplicator-plugin-error.png

    http://wordpress.org/extend/plugins/wp-native-dashboard/

  2. Inversion
    Member
    Posted 1 year ago #

  3. lleroy
    Member
    Posted 1 year ago #

    I also have this problem. Did you ever find a fix?

  4. henscu
    Member
    Posted 1 year ago #

    I have a similar problem with my Formidable Forms plugin. It's Dashboard displays in the frontend language (German) when every other plugin Dashboard displays correctly in the backend language (English).

    I raised a support query with Formidable but they said the plugin relies on standard WordPress language switching so no real info.

    The only fix I can do is do remove Formidable's mo and po language files so that it is forced to display in English throughout.

    Is there any information on how WP Native Dashboard works with plugins that might help us find a solution to this?

  5. codestyling
    Member
    Plugin Author

    Posted 11 months ago #

    The problem is, that the plugin "Duplicator" loads the translation file during it's load phase and not during the initialization phase of WordPress. So no other plugin has the chance to change globally languages in between cause it takes the one from wp-config.php always!

    I have change the file "duplicator.php" (v0.4.6) line 226/227 and disabled the loading here:

    //HOOKS
    //load_plugin_textdomain('wpduplicator', FALSE, dirname(plugin_basename(__FILE__)) . '/lang/');

    After disabling the loading in such a unreliable way I did insert after the disabled line:

    add_action('init', 'duplicator_load_textdomain');
    function duplicator_load_textdomain() {
         load_plugin_textdomain('wpduplicator', FALSE, dirname(plugin_basename(__FILE__)) . '/lang/');
    }

    So loading will be performed during init hook of WordPress. Now all works as expected with the "Duplicator" plugin. Please inform the author of this plugin to implement a correct hook based loading of translation files to permit other plugins choosing right languages etc.

    Important: Most cases where plugins doesn't get translated well are driven be the wrong time the translation file gets loaded. The plugin authors should load them as late as possible (this also safes the ammount of memory used, if the plugin never performs an action to produce the current requested page - front or admin)

  6. Inversion
    Member
    Posted 11 months ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic