WordPress.org

Ready to get started?Download WordPress

Forums

Language change (18 posts)

  1. jea
    Member
    Posted 9 years ago #

    I'm in the progress of installing WP, and so far so good, it works beutifully. But, when trying to change to Swedish, WP clings on to English, although I have been most obediant when installing 'sv_SE' in th new folder 'languages' and made appropiate modifications in wp-config.
    How come???

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Try making 'sv_SE.mo' into just 'SE.mo' ?

  3. jea
    Member
    Posted 9 years ago #

    In the wp-config???

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Yup - like the example gives.

  5. jea
    Member
    Posted 9 years ago #

    I have downloaded this file into a newly created folder 'languages".
    sv_SE.ISO-8859-1.mo
    According to your advice I then renamed this file to SE.mo.

    In the wp-confic.php I changed 'lang' to 'sv'.

    Does it work?
    No :(

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    define ('WPLANG', 'se');
    se.mo

    or
    define ('WPLANG', 'sv');
    sv.mo

  7. jea
    Member
    Posted 9 years ago #

    Now I have define ('WPLANG', 'sv'); in wp-config
    and sv.mo in languages, and I have tried the se- as well, but i does not funktion.

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    This getting strange...... back to the beginning.
    The languages file is in wp-includes/languages ?

  9. jea
    Member
    Posted 9 years ago #

    yes, in wp-includes/languages I have sv.mo

    and then I have
    define ('WPLANG', 'sv'); in wp-config.php

  10. dotar
    Member
    Posted 9 years ago #

    I have the very same error.
    Help someone?

  11. Class
    Member
    Posted 9 years ago #

    I have define ('WPLANG', 'nb_NO'); for Norwegian in my wp-config.php and my language file is called nb_NO.mo.

  12. Camilla
    Member
    Posted 9 years ago #

    For swedish: download the sv_SE.utf-8.mo and put it in wp-includes/languages. Then change the lang setting in the wp-config file to 'sv_SE.utf-8'. That worked for me.

  13. Eivind Ødegård
    Member
    Posted 8 years ago #

    I have the same problem for Norwegian nynorsk. nn_NO.mo put in /wp-includes/languages/, nn_NO in wp-config.php, but still, everything stays English.

    My blog attempt is at tur.frilyd.tk. Would anyone care to check whether I have done a terrible mistake?

  14. moshu
    Member
    Posted 8 years ago #

    How could we check what have you done?
    If you want you can emal me with your ftp details and I can take a look.

  15. Eivind Ødegård
    Member
    Posted 8 years ago #

    Sorry, I didn't mean you to do the job for me... I just meant that those who know an .mo file from a .somethingelse file, could verify that my .mo file is usable, and thus eliminate that as the error source. But I am doing that right now, by entering the path for the .mo file, and I can't find it.

    The file should be reachable here:

    http://tur.frilyd.tk/wp-includes/languages/nn_NO.mo

    but it isn't!

    Hm. I'll try installing WordPress in my root directory, and see what happens.

    By the way: My domain is hosted at 69.72.196.172, but entering that address in a browser will just tell that no domain is registered. But pinging tur.frilyd.tk, or just frilyd.tk, returns that exact address. There are some strange goings on here. Thank you so far, I'll report back when I know more.

  16. moshu
    Member
    Posted 8 years ago #

    Now that quite simplifies the problem: you didn't upload it to the right place.

  17. Eivind Ødegård
    Member
    Posted 8 years ago #

    Not quite as simple. The default setup for an Apache server is, as I understand, not to let users watch files in directories like e.g. /wp-includes/languages ? I just tried the above link in a browser.

    I've installed WordPress again in the root directory, and plugins, themes and the lot work perfectly. It's a joy! The only thing that doesn't work, is language.

    I'm quite sure about the file location. I would have checked it, if not the world, for some reason, decided it wouldn't allow me to receive a file listing through ftp today :o/

  18. Eivind Ødegård
    Member
    Posted 8 years ago #

    Ah. Issue fixed for me. It was all a simple matter of file permissions - although it took some time to track down!

    I had put the .mo file right, but as I had to make the /wp-includes/languages directory myself, I got the wrong permissions for it (read: didn't check it).

    The /languages directory has to be world accessible, ie. drwxr-xr-x or 755. I also think everybody must be able to read your .mo-file, ie. rw-r--r-- (that may perhaps not neccessary, but I consider it a safe choice).
    Non-technical: Everybody must be able to go into the language directory and read the language file. Two short chmod ftp commands fixed it.

    Thanks for your patience, and for bearing with my stoopid questions. I'm happy now. All that remains now, is to get my favourite theme and plugin in my own language. ;-)

Topic Closed

This topic has been closed to new replies.

About this Topic