WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Landing page is wrong (7 posts)

  1. v_inglis
    Member
    Posted 1 year ago #

    when I type in http://www.impaqhealthservices.com, the browser goes to a blog page. However, if I type in http://www.impaqhealthservices.com/h-o-m-e, the correct landing page comes up. Similarly, if I type on click on H O M E in the header menu of the wrong blog page, it also goes to the correct landing page. What do I change to have users always end up on the right homepage?

  2. David Williamson
    Member
    Posted 1 year ago #

    If I understand you correctly (and correct me if I'm wrong) it looks like you want visitors to http://www.impaqhealthservices.com to see the /h-o-m-e page first and have a separate page for the blog posts.

    To do that you just need to change the settings in Settings > Reading Settings > Front page displays to use a static page. Then set your /h-o-m-e page as your Front page and whatever you would like your blog posts to show up on as your Posts page.

    Depending on how you have your menu bar configured you may also need to change the links on there once you have the static front page working.

    You can find more information about how to set this up on the Codex page Creating a Static Front Page.

  3. v_inglis
    Member
    Posted 1 year ago #

    Thanks for responding. Yes, you understood the problem. I made the change you suggested in Settings>Reading. Might it take a while for the change to populate? However, when I type http://www.impaqhealthservices.com into browser bar, it loads a page that has big rectangle with a black left and right arrow on the ends. (It almost looks like a slide portfolio.) So, it looks like it's looking at the right page now, but I have that erroneous rectangle there. Any ideas?

  4. David Williamson
    Member
    Posted 1 year ago #

    That might be something your theme automatically adds to the home page (whether it's a static page or a standard blog page). You might want to check if your theme has an options page and see if there is a setting you can change there.

    Are you using a theme from the repository here on wordpress.org? If so, which one and I can take a look and see if there is something else you could try.

  5. v_inglis
    Member
    Posted 1 year ago #

    Below is how the home page template code reads. Could the object be ""container_12 clearfix""? If yes, what if I just removed it?

    <?php
    /**
    * Template Name: Home Page
    */

    get_header(); ?>
    <?php if ( ! dynamic_sidebar( 'Before Content Area' ) ) : ?>
    <!--Widgetized 'Before Content Area' for the home page-->
    <?php endif ?>
    <div class="container_12 clearfix">
    <div class="grid_3 suffix_1 spacer-1">
    <?php if ( ! dynamic_sidebar( 'Content Area 1' ) ) : ?>
    <!--Widgetized 'Content Area 1' for the home page-->
    <?php endif ?>
    </div>
    <div class="grid_4 suffix_1 spacer-2">
    <?php if ( ! dynamic_sidebar( 'Content Area 2' ) ) : ?>
    <!--Widgetized 'Content Area 2' for the home page-->
    <?php endif ?>
    </div>
    <div class="grid_3">
    <?php if ( ! dynamic_sidebar( 'Content Area 3' ) ) : ?>
    <!--Widgetized 'Content Area 3' for the home page-->
    <?php endif ?>
    </div>
    <?php get_footer(); ?>

  6. David Williamson
    Member
    Posted 1 year ago #

    I don't think it's the container_12_clearfix. Without seeing the header code and based on what I can see in the source code for the home page it looks like the slider might be a widget that's been added to the theme.

    Check in your Appearance > Widgets page in your admin area and see if something is there that you maybe didn't set yourself.

    If that doesn't work there might be something in your header template. If you decide to post it please use pastebin.com (or a similar service).

  7. v_inglis
    Member
    Posted 1 year ago #

    I did a chat session with the template designer (I had to go through the template vendor), but she fixed the code, and the front page looks correct now. Thanks again for your prompt help. I appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic