WordPress.org

Ready to get started?Download WordPress

Forums

kwebble and get_archives (5 posts)

  1. lyonsads
    Member
    Posted 2 years ago #

    I have a site that is using wordpress to manage a blog and news section among other things

    http://www.brunswickcrossing.com/wordpress/?page_id=599

    on the right side there are links to archived blogs by month. 2 of these months (may and april of 2011) are not linking to the correct archive page, but the rest of the months link correctly. The link goes to my main archive.php page where there is an in_category switch to draw the correct page based on content (blog or news) and a catch all archive page. For some reason, these two months are linking to the catch all archive page, even though the category seems to be correct in the dashboard.

    I know the Kwebble "Archives for a category" plugin is installed, but I dont know if it is actually being used as I did not do the development on this site. Can anyone shed some light on why these particular posts are (apparently) tagged with the wrong category? Please let me know what other info may be required to solve this riddle. Thanks in advance!

  2. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. lyonsads
    Member
    Posted 2 years ago #

    Thanks for the response.
    I have tried deactivating the plugins, and the theme, with no luck. It kinda smells like some kind of database corruption as only some of the posts are acting up. But it's strange that it's all of the posts in 2 specific months.

  4. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Have you tried repairing your database?

  5. lyonsads
    Member
    Posted 2 years ago #

    I have since tried repairing the database with no luck. I have also tried deleting all posts from the offending months and recreating them, but the same thing happens. It's is very strange that this only occurs with two specific months. Could this be a bug in the plugin?

Topic Closed

This topic has been closed to new replies.

About this Topic