WordPress.org

Ready to get started?Download WordPress

Forums

125

NextGEN Gallery
[closed] Known Plugin & Theme Conflicts with NextGEN 2.0 (129 posts)

  1. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    We want to post and keep updated a list of known plugin and theme conflicts. If you have these plugins installed and are having issues, these may be the cause, so try deactivating them and see if that resolves the issue for now.

    If you are aware of a plugin conflict or have details on the ones below, please add any details.

    Note that if you are having major issues with 2.0, you can safely rollback to 1.9.13:
    http://www.nextgen-gallery.com/how-to-rollback-a-version/

    Thanks,
    Erick

    BBPRESS. Can cause site crash. Triggers error that looks like: Fatal error: Call to a member function get() on a non-object in /home/content/deletedactualpath/wordpress/wp-includes/query.php on line 27

    MAGIC FIELDS PLUGIN. Can cause site crash. Triggers error that looks like: Fatal error: Call to a member function get() on a non-object in /web/content/wp-includes/query.php on line 27

    SOLILOQUY SLIDER PLUGIN. This may cause aspects of our interface to disappear, especially when adding galleries to pages/posts via the new Attach to Post interface.

    CONTACT FORM 7. Still trying to determine the effects on this one. I think I've seen one example where it seemed to trigger major errors, and another where it just interfered with gallery displays.

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    Another one:

    EASY DIGITAL DOWNLOADS. This plus NextGEN will throw some errors in the backgroud, but doesn't seem to affect functionality.

  3. @photocrati Could you contact us and tell us what the errors are? We can get them fixed right away.

  4. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    RISE Theme. Causes Attach to Post interface to not appear.

  5. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    Pippin - Sure. Scott Wyden actually already posted this in your support forums under the title "confusing error logs".

  6. I'm aware of that ticket, though did not know it was related to NextGEN. Does it only happen if EDD and NextGEN are active?

  7. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    Pippin. Yes, just if they're both active. Sorry - I was thinking Scott updated there. I consider that to be our problem not yours, but if you can solve it, great.

  8. I will try to look into it.

  9. ranovr
    Member
    Posted 12 months ago #

    Justified Image Grid: http://justifiedgrid.com/. Keeps slider from working and is stuck on load. Still works with thumbnails mode though.

  10. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    @ranovr: what's the symptom or effect of the conflict? Or is that plugin just not working?

  11. ranovr
    Member
    Posted 12 months ago #

    @photocrati: Slider locks up and won't load images. However, if you click "show thumbnails", thumbnails load fine. Edit: NextGEN slider doesn't load properly. When I found it was JIG from disabling plugins and process of elimination.

  12. hermlam
    Member
    Posted 12 months ago #

    2.0 is not working with DBTOOLKIT.
    I'm generating pages with DBTOOLKIT with Nextgen embedded in the code. Now it's not showing the thumbnails anymore.
    See for example: http://www.lamboo.com/?page_id=414&TravelID=35

    I have to rollback to 1.9 (later after you've taken a look at the site).

  13. weigertj
    Member
    Posted 12 months ago #

    qTranslate - an extremely popular multilanguage plugin with 856,701 downloads.
    Now the quicktags - language shortcodes like [:en][:de] in "Alt & Title Text / Description" don't work anymore.

    http://wordpress.org/plugins/qtranslate/

  14. tegotha
    Member
    Posted 12 months ago #

    Photoswipe for nextgen gallery does not work anymore

    http://wordpress.org/plugins/photoswipe-for-nextgen-gallery/

  15. figure2
    Member
    Posted 12 months ago #

    The simple paypal shopping cart plugin integration stopped working with NextGen: http://tinyurl.com/872vgws

    This integration requires that you add a file, "gallery-wp-eStore.php" to the "Views" sub-folder. In v 2.0, the Views sub-folder is gone. All my wife's stores on her jewelry site disappeared, replaced by an error "[Not a valid template]." Luckily I was able to restore the previous version of NextGen from backup.

    I understand that NextGen will have its own ecommerce feature. Was this de-integration with the paypal plugin done on purpose? Some warning would have been appreciated.

    [Signature removed by moderator per forum rules.]

  16. edradour
    Member
    Posted 12 months ago #

    NextGen Custom Fields plugin stopped working in templates

    My custom fields still work in gallery management, but seem to have disappeared in my (custom) templates since upgrading NGG to v 2.00

    Specifically, $image->ngg_custom_fields[$field_name]; does not return a value for display. testing with strlen (e.g strlen($image->ngg_custom_fields["Media"]) ) returns a length of 0 (zero)

  17. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    @Everyone - thanks for posting your reports here. It's very helpful.

    Another one:

    MAPPRESS EASY GOOGLE MAPS. This one causes NextGEN short codes to stop working and causes the Attach to Post interface to be blank when trying to add galleries.

    Big thanks to user GMSPSH for finding it.

  18. NexStudio
    Member
    Posted 12 months ago #

    I ran across two problems, first was mainly because of the development environment (using a different port than 80) and NextGen Gallery is sripping the port out of the url.

    i change the following function to make it wordk with a custom port.
    (nextgen-gallery\products\photocrati_nextgen\modules\router\mixin.url_manipulation.php)

    function construct_url_from_parts($parts)
    	{
    		$retval =  $this->object->join_paths(
    			isset($parts['scheme']) && $parts['host'] ?
    				"{$parts['scheme']}://{$parts['host']}".(isset($parts['port']) ? ':'.$parts['port'] : '') : '',
    			isset($parts['path']) ? $parts['path'] : ''
    		);
    		if (isset($parts['query']) && $parts['query']) $retval .= "?{$parts['query']}";
    
    		return $retval;
    	}

    and the second problem was when no querystring was present (home page)
    the following fixed that problem for me
    (nextgen-gallery\products\photocrati_nextgen\modules\router\class.router.php )

    function get_querystring()
    	{
    		return isset($_SERVER['QUERY_STRING']) ? $_SERVER['QUERY_STRING'] : null ;
    	}
  19. mikeboxelder
    Member
    Posted 12 months ago #

    With regards to the rollback option --

    http://www.nextgen-gallery.com/how-to-rollback-a-version/

    Some of us - aka myself - are unsure of how to properly "create a full backup" of our site ... Is there a tutorial on this somewhere?

  20. MBYC
    Member
    Posted 12 months ago #

    2.0 crashed my site with the following conflict ....
    Fatal error: Call to undefined function is_user_logged_in()
    in /home/mbyc2641/public_html/wp-content/plugins/member-access/lib/MemberAccess.php on line 217

    ... looks like a conflict with the Member Access plugin which is mission-critical for me. Will rollback to previous version.

  21. terrykiwi
    Member
    Posted 12 months ago #

    NexGen Gallery Optimizer causes images to load solo (replaces the website) in the current browser window with NexGen 2.0.

    I deactivated it and the gallery started working again, without the fancy lightbox properties.

    Going back to the old version until all these issues are resolved!

  22. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    THEME CONFLICTS

    Just adding a couple more notes here.

    ELEGANT THEMES. We've seen some reports of menu drop downs having issues with some Elegant themes.

    ATTITUDE-MODIFIED. NG 2.0 seems to break the home page slider built into the themes.

    THEMES WITH SLIDERS. There is at least one other case of a theme with built in home page slider not working.

  23. wesyah234
    Member
    Posted 12 months ago #

    The users of Elegant Themes http://elegantthemes.com/ are also experiencing issues. The main front page slider stops working. (This is a prominent feature in most of the ET themes).

  24. denisechapman
    Member
    Posted 12 months ago #

    Ya, you guys need to fix that asap... it's taken down more than 1/2 my sites that use that plug in!! Never had a problem with this plug in before, ever.

  25. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    @denisechapman: can you please provide more details. What do you mean by "taken down" your site, and do you know what conflict triggered it? Thanks!

  26. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    GREAT REAL ESTATE INTERFACES. There seems to be a conflict with this plugin that triggers an error on activation: Fatal error: Call to undefined function nggshowgallery() in /home/cdanyluk/public_html/wp-content/plugins/great-real-estate/interfaces/interface-nggallery.php on line 28"

  27. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    @wesyah234: thanks for the details about Elegant Themes. I'm basically updating our issue on this to indicate that theme with Sliders, including elegant themes, are having conflicts. Thanks.

  28. denisechapman
    Member
    Posted 12 months ago #

    It's taken down the galleries.. some just display errors... some are now running vertically... and I use themes from all over.. going through a list of 40 sites right now... you should just roll it back until you fix the bugs so we can easily apply the update as this is a pain in the butt. Have always LOVED this plug in.

  29. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    MORE FIELDS. if you try to upgrade to 2.0 with this plugin installed, you'll get white pages on the both the front and backend pages. The users solve the issue by migrating to Advanced Custom Fields plugin and upgraded fine.

  30. SciFiKriss
    Member
    Posted 12 months ago #

    @edradour the reason custom fields don't work any more is because you had to change the gallery-view.php which is no longer there... :D I took mine off luckily I didn't use it that much yet.... For me using the WordPress Media options which work fine.

    Using Mantra theme and had no problems with the slider on that theme..so might want to have a look at how they do their slider...

    The only problem I came across was Albums not listing correctly so had to go in and re-add each album again...a pain but it is a quick fix for something that small compared to other problems... :D

    Kriss :)

125

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags