WordPress.org

Ready to get started?Download WordPress

Forums

knew I'd goof the upgrade (3 posts)

  1. kostuj
    Member
    Posted 6 years ago #

    With other minor blog changes being made I thought I would upgrade to version 2.22 even though I just put 2.21 in a couple months ago. The blog main page comes up just fine and the link to my affiliated site, but I get a 404 error on other internal links to full posts, archives, the about page, etc. When I take out 2.22 and put 2.21 back in, I now continue to have the same problem, so I do not know what I did. In past upgrading I got an upgrade script, this time nothing, do not know if that matters. Even though I did not back it up beforehand, my data still seems there and unaffected. Any suggestions as to where I am going wrong would be appreciated. Thank you sincerely.

  2. Chris_K
    Member
    Posted 6 years ago #

    Sounds like you blew away your .htaccess file as part of your upgrade.

    I'd suggest copying up the 2.22 files, then visiting Options -> Permalinks and re-saving whatever's currently set.

  3. kostuj
    Member
    Posted 6 years ago #

    Thank you for your reply. I am not sure if what you suggested was true, because I was playing around with all the buttons (though I did not specifically save what you suggested) or if something was possibly going on with my server, but it seems I have gotten everything back a short time ago. Thank you again.

    One reason I went ahead with the 2.22 upgrade is because of the failure in 2.21 to be able to put a mailto link in the blogroll to contact the author. Same thing with 2.22, as an http:// is always added and the @ is always taken away. Is my only option to reinstall the patch I had to in 2.21? If so, would you please point me to that patch, as I cannot seem to find it at this time. Thank you very much again.

Topic Closed

This topic has been closed to new replies.

About this Topic