WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
[resolved] Kicked out from the wp-admin (16 posts)

  1. CreativeWP
    Member
    Posted 1 year ago #

    I was restricting access to the back end for subscribers, contributors, but not for admin, but still it kicked me out. Is there a way I can re-set it so that I can get back to the admin?

    Thanks,

    http://wordpress.org/extend/plugins/theme-my-login/

  2. CreativeWP
    Member
    Posted 1 year ago #

    Never mind, I went to the database and fixed it.

    Thanks,

  3. davefezz
    Member
    Posted 1 year ago #

    Hi there - I have done the same thing - I noted when choosing to disable access that administrator was greyed out and therefore assumed it would not be one of the disabled for access to the backend.
    I do have my database access but am not sure which setting to modify in users users meta?
    Any advice on this would be appreciated?
    Thank you.

  4. CreativeWP
    Member
    Posted 1 year ago #

    In my view there is no way to get back in, without accessing the database. So find a way.

    Cheers,

  5. defenderofnight
    Member
    Posted 1 year ago #

    I have been testing out a clean wordpress install on my local host and
    when I activated TML, and was activating the theme profile module, and trying to just restrict access to my backend. I ended up getting kicked out of my backend with no way to get back in. Lucky for me, I was able to just delete my config file and redo the wordpress install. I am happy to have tested this on my localhost first before trying it on my web hosting server.

    If anyone figures out more of a solution, they should post it here. I am not sure what is going on.

  6. davefezz
    Member
    Posted 1 year ago #

    Apologies for not letting you know this solution sooner.
    Database wp_options table has the access levels as set by TML.
    Searching for restrict_admin will bring the settings - where it has "restrict_admin";b:0;}" change the 0 to a 1 for administrator (may depend on how many administrators) but 0 means no access.
    I realise your installation may have been new enough to just re do it - but not ideal for me.
    Searching the database and fixing there is better and recommended.
    Cheers and thanks for your input.

  7. Paul Foxton
    Member
    Posted 1 year ago #

    Thanks Dave, what you've posted is my strongest lead yet.

    I have the same problem, version 6.3.5 on wordpress 3.5.1 with genesis 1.9.2.

    I've gone into the wp_options table and found a row with an "option_name" value of "theme_my_login_themed_profiles". I don't see an admin setting with b:0, I have this:

    a:8:{s:13:"administrator";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}s:6:"editor";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}s:6:"author";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}s:11:"contributor";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}s:10:"subscriber";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}s:13:"bbp_keymaster";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}s:13:"bbp_spectator";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}s:11:"bbp_blocked";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}}

    Any clues?

    Thanks

    Paul

  8. davefezz
    Member
    Posted 1 year ago #

    Hi Paul,
    the setting needs to be a zero for false with regard to restricting access - so I advised the wrong way around above :-) sorry bout that.
    For yours I would set them back to a zero and enable one at a time while testing your access and keep your database open to note the changes and to modify if your admin account access breaks. Not doing all at once within wp may be a safer bet. Doing in Steps maybe.
    This works as an example.
    a:5:{s:13:"administrator";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:0;}s:6:"editor";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}s:6:"author";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:0;}s:11:"contributor";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}s:10:"subscriber";a:2:{s:13:"theme_profile";b:1;s:14:"restrict_admin";b:1;}}

    Cheers,

  9. Paul Foxton
    Member
    Posted 1 year ago #

    Thanks very much Dave!

    In the end I removed the plugin folder and deleted the two 'Theme my Login' rows from the database manually. I've reinstalled but am staying away from the themed logins now!

    It's a bit odd that the developer hasn't answered any of these posts, there are some on his own site too that people have left, also unanswered.

    I get that the plugin is free, and I appreciate the work that goes into it. I'm just a bit surprised.

  10. davefezz
    Member
    Posted 1 year ago #

    good move Paul.
    happy coding.
    Dave

  11. davefezz
    Member
    Posted 1 year ago #

    good move Paul.
    try user profiles made easy.
    happy coding.
    Dave

  12. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    I cannot replicate this issue.

  13. charles.mak@icdt.com.hk
    Member
    Posted 1 year ago #

    I hit the same problem in last night, when I made change on the redrect parameters in theme_my_login plugin. Suddenly, every URL only redirect your_profle page only.

    Dear Paul, may I know which rows I should delete in the wp_option before I can install this plugin again.

  14. CreativeWP
    Member
    Posted 1 year ago #

    It happened to me, but I went to the database and erases ed the problem.

  15. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    I've resolved this issue in the development version.

  16. devin plombier
    Member
    Posted 7 months ago #

    I had this problem yesterday.
    I've resolved it by
    - uninstalling plug-in on backend // i had a tab opened on backend :)
    - deleting plugin folder on FTP
    - empty the cache

    and reinstalling the plug-in (no modification of the DB)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags