WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
keeps popping up in debugging mode (1 post)

  1. Nia.Ortiz
    Member
    Posted 10 months ago #

    Hi,

    I'm a complete novice but I'm learning quite a lot as I build this site. I turned on my debugging mode on my updraftsplus plugin and I am shown the following messages:

    Strict Standards: Declaration of C_DataMapper_Driver_Base::define() should be compatible with C_Component::define($context = false) in /Applications/MAMP/htdocs/wordpress/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/datamapper/class.datamapper_driver_base.php on line 529

    Strict Standards: Declaration of C_DataMapper_Driver_Base::initialize() should be compatible with C_Component::initialize() in /Applications/MAMP/htdocs/wordpress/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/datamapper/class.datamapper_driver_base.php on line 529

    Strict Standards: Declaration of C_Lightbox_Library_Mapper::define() should be compatible with C_Component::define($context = false) in /Applications/MAMP/htdocs/wordpress/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/class.lightbox_library_mapper.php on line 7

    Strict Standards: Declaration of C_Lightbox_Library_Mapper::initialize() should be compatible with C_Component::initialize() in /Applications/MAMP/htdocs/wordpress/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/class.lightbox_library_mapper.php on line 7

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method sidebar_generator::admin_print_scripts() should not be called statically in /Applications/MAMP/htdocs/wordpress/wp-includes/plugin.php on line 406

    They all seem to have to do with the NextGen Gallery plugin. I've uninstalled, reinstalled and even updated the plugin. When I uninstall the plugin everything works fine and there are no bugs. When when it's installed, even after the recent update I still get these error messages. I need this gallery on my website so I'd like to edit out the kinks and make it work.

    Can anybody help?

    http://wordpress.org/plugins/nextgen-gallery/

Reply

You must log in to post.

About this Plugin

About this Topic