WordPress.org

Ready to get started?Download WordPress

Forums

Google Routeplanner
[resolved] keeps complaining about startlocation (6 posts)

  1. nowton
    Member
    Posted 1 year ago #

    No matter what detection is set to, I always get the message: 'Could not find the start location. Please be more specific.'

    http://wordpress.org/extend/plugins/google-routeplaner/

  2. DerWebschmied
    Member
    Plugin Author

    Posted 1 year ago #

    Target location have to be entered manually.

    Starting location, the location your users/customers are, can be detected.

  3. nowton
    Member
    Posted 1 year ago #

    Well, I get this message when loading the page. And on trying to submit a location in the routeform I see the following in Firebug: `TypeError: navigator.geolocation is null
    google-routeplaner-js.php?planer_id=1&autofill=1()google...ofill=1 (line 11)
    [Break On This Error]

    navigator.geolocation.getCurrentPosition(setUserPos);`

  4. DerWebschmied
    Member
    Plugin Author

    Posted 1 year ago #

    The error says that your target location, the location you or you company is located, is not defined good enough. This has absolutly nothing to do with the detection.

    Please edit the route, enter a target location and try again.

  5. nowton
    Member
    Posted 1 year ago #

    That solved it, but the error message is flawed. It states 'start location not found'. You state 'target location not found'. That's confusing...maybe add a check in backend when keying in target location? I've seen similar solutions which geocode first, then accept the settings. Cheers.

  6. DerWebschmied
    Member
    Plugin Author

    Posted 1 year ago #

    That's correct. I'll edit the message with the next release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic