WordPress.org

Ready to get started?Download WordPress

Forums

Keeping Blog Posts Off [Static] Front Page (8 posts)

  1. sweetman
    Member
    Posted 1 year ago #

    Putting the finishing touches on my site which is built on the twenty eleven theme. Just added a blog post and it's showing up on my home page, which is [meant to be] set to static (settings - >reading-> Front Page Displays A Static Page, Front page selected to my home page, posts selected to go to "Blog"). Posts are also showing up in the Blog, which is where I want them.

    All of the help posts I found on this topic indicated that changing these reading settings solved the problem. This didn't seem to work for me. I'm pretty new to this so hopefully I'm missing something obvious.

    My site is http://www.kimberlysweetman.com

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    If you desire just a static home page, use only the option at Front Page - the option at Posts Page needs to be the default -select-

    Save your changes and make sure to clear any sever cache.

  3. sweetman
    Member
    Posted 1 year ago #

    thanks for the reply.

    Hmmm, so you are suggesting that under reading settings I just select the home page to static and leave the blog page as default? Not sure if I'm understanding this correctly, because changing it as I described has removed the blog posts from the blog page, yet they remain on the home page. What I wanted was to remove them from the home page and keep them on the blog page.

  4. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Let's solve the first issue...set the Front Page to your Page and make sure Posts Page is at default...report back if your Front Page is working, then we can discuss the Posts Page setup issue.

    Also, are you using a caching plugin???

  5. sweetman
    Member
    Posted 1 year ago #

    Front page set to my page and post page as default. Blog posts are only showing on front page with that setting. Check it at http://www.kimberlysweetman.com .

    When you ask about a caching plugin do you mean on WordPress or in my browser? I don't think I have one in WordPress (I only have a couple of plugins installed) and I don't set my browser (Firefox) to keep a history.

  6. agilous
    Member
    Posted 6 months ago #

    I'm having a similar issue. I have a static page set as the front page and a "News" page set as the posts page. Digested posts are on the home page and page footers as specified in theme. The only place they're not appearing is on the News page.

    There's no "news" directory blocking the page as I've heard that's frequently an issue with this type of behavior. Kinda at my whit's end. I'll post the solution if I find it.

    Any assistance would be appreciated.

  7. WPyogi
    Volunteer Moderator
    Posted 6 months ago #

    @agilous - please start your own thread and include relevant info - as per:

    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

  8. agilous
    Member
    Posted 6 months ago #

    So it appears it is an issue with the theme. I reactivated the default theme and the posts appeared everywhere I expected. Re-enabling the Medicenter theme (from QuanticaLabs) breaks the designated posts page.

    I guess I'm at the mercy of QuanticaLabs' support.

Topic Closed

This topic has been closed to new replies.

About this Topic