WordPress.org

Ready to get started?Download WordPress

Forums

Keep getting forced to d/l php script (41 posts)

  1. minimac
    Member
    Posted 8 years ago #

    Hi there, minor problem, may be related to my server config but im not sure.

    Recently, my site (shadednecros.net) has prompted me to d/l the php file (eg Post.php) whenever I click the confirm / save / publish button after about 20 - 30seconds after clicking.

    This has only just happened and means that updating / editing posts and also publishing is hard as it is hit or miss as to whether the post is published or not.

    Any ideas? Thanks for your time

  2. MichaelH
    Member
    Posted 8 years ago #

    Not to sure what "d/l" is?

    ********************
    Welcome to the WordPress Support Forums!

    Please help keep the Forums successful by reading:
    Using the Support Forums

    Also, remember the WordPress Codex and the FAQ pages.

    And, thank you, for letting us know if this information proves useful (or not)!
    ********************

  3. minimac
    Member
    Posted 8 years ago #

    Sorry: download. As in FireFox prompts me to download / save the 'post' script (using post as an example)

  4. MichaelH
    Member
    Posted 8 years ago #

    Any chance that file is called post.phps on your server? If so rename it to post.php.

  5. minimac
    Member
    Posted 8 years ago #

    Its only recently started doing it. And the file is called post.php

    I get the prompt to d/l in Firefox and page not found in IE. Any ideas? Thank you for your continued time.

  6. Mark (podz)
    Support Maven
    Posted 8 years ago #

    I would delete the post.php file and then upload another - this will rule out any accidental change that could have been caused by your host.

  7. minimac
    Member
    Posted 8 years ago #

    OK have done that. The problem is still there though. Something to do with CHMODs?

    I get a long loading message in FireFox and then the option to download the script. I'll email my host too.

    Thank you for your help I appreciate it. Any more ideas?

  8. minimac
    Member
    Posted 8 years ago #

    I've deactivated the Markdown plugin and it is still happening. Argh!

  9. Mark (podz)
    Support Maven
    Posted 8 years ago #

    If it only recently started happening, what has changed ?
    Browser upgraded ?
    New program to edit / use php files ?

  10. minimac
    Member
    Posted 8 years ago #

    Had the new version of FF, but it happens in IE too. Even after re uploading the post.php file.

    If i delete all the wp-files (but not the Database) could I reupload them and the content would still be there (after installing + connecting to DB)?

    Thanks

  11. Mark (podz)
    Support Maven
    Posted 8 years ago #

    It would be yes, but that could be a waste of time as you have already done that to one file.
    It's the fact that it is just happening now which needs tracking down - does this happen on any other page in admin, all of them, none of them ?

  12. TechGnome
    Moderator
    Posted 8 years ago #

    sounds like the wrong mime type is being sent by the server.... you might want to have your host check into that.

    Does it happen only on post.php, or on all PHP files?

    And, just to rule anything else out, what version of:
    1) WP?
    2) PHP?
    are you running?

    -tg

  13. minimac
    Member
    Posted 8 years ago #

    Post.php is the main one that is happens all the time with. Sometimes I get it when I edit options / preferences etc.

    I'll email my host.

    ****ing bihira.

    Thanks for help.

  14. rafleet
    Member
    Posted 8 years ago #

    Had the same problem on one of my WP installs. Posted a help message here...someone recommended running the upgrade script...it fixed the problem.

    Try it...can't hurt.

  15. minimac
    Member
    Posted 8 years ago #

    Version 1.5.2 of WP
    Unknown PHP version.

    Have run the upgrade script (the one step one) and problem still occurs. No email from host as of yet.

    Any last ditch ideas? Thanks for help so far.

  16. Mark (podz)
    Support Maven
    Posted 8 years ago #

    The problem is in one of two places:
    - the server
    - your machine
    We need to clearly rule one out, and the only way of doing that is to get someone else to try and see that page.
    If they can and all is good - it's your machine.
    If they cannot and get the same result - it's the server.

    I suggest getting someone you trust for a few minutes - because you should change your password after giving it out - to login and try to post. Try 2 people if you can - and then let us know ?

  17. minimac
    Member
    Posted 8 years ago #

    Hi there, I tried this on a school computer and a friends machine today. So its something to do with the server. But if I am having the problem, shouldnt there be topics in the hosts support forum?

  18. minimac
    Member
    Posted 8 years ago #

    bump :(

  19. moshu
    Member
    Posted 8 years ago #

    shouldnt there be topics in the hosts support forum?
    How could we know what's on your host's support forum?
    If there isn't any relate topic - start one. It's still better than bumping :)

  20. jazzle
    Member
    Posted 8 years ago #

    I've had a similar problem where Fx gets sent the eBay .dll!

  21. minimac
    Member
    Posted 8 years ago #

    You sure you got the right topic there Jazzle? Im confused :P

  22. Kamigoroshi
    Member
    Posted 8 years ago #

    I've got the same problem as well.

    http://wordpress.org/support/topic/54100

  23. error
    Member
    Posted 8 years ago #

    As best I can tell this problem is specific to Firefox 1.5. I never saw it prior to updating. But I'm not sure exactly what the problem IS...

  24. Artemis
    Member
    Posted 8 years ago #

    I've heard about this....

    Contact your host as this an issue with mod_security (either that firewall, or another firewall on the server). It's possibly due to a typo in the rules, or the rules not being added properly. The other people that experienced this said their host told them it was something dealing with the comment spam rule settings in the mod_security firewall.

  25. Kamigoroshi
    Member
    Posted 8 years ago #

    Could it be more specific? Because I don't really know what exactly to tell my host what to look for.

  26. minimac
    Member
    Posted 8 years ago #

    I've fixed my problem, it was due to me having a HUGE ping list set in the options menu. Made the script take too long. Just shorten that to only include select URLS.

  27. makemead
    Member
    Posted 8 years ago #

    Woops, didn't see you resolved the issue. :)

    (original post - Is it possible that you saved post.php it in rich text format and then uploaded it or something like that? Make sure you are saving it as plain text (probably utf-8) and then re-upload and see if that helps. This is just a guess. )

    A ping list shouldn't prompt you to download a php script though. :confused:

  28. Artemis
    Member
    Posted 8 years ago #

    I wouldn't think it would be a ping list either. I thought at first it might be a PHP issue related to the server, but one of the ladies in the WordPress Learning Buddies email group said her host said it was mod_security and something dealing with the comment spam rules. Several people in the email group are using that same host and all experienced the same problem... till the host fixed it.

    Kamigoroshi - Just explain to your host what is happening and tell them it might be either PHP related or something dealing with the mod_security rules. Are you going through Liquid Web? If so, they're fantastic so they'll probably know what it is right away.

  29. Kamigoroshi
    Member
    Posted 8 years ago #

    Ok, it turns out that it was the ping list that I had (I had about 8 sites that I was pinging). Right after that I could save and publish all my posts.

  30. SeiShonagon
    Member
    Posted 8 years ago #

    It seems that the ONE site (default, pingomatic) I had in my ping list was the cause. Since i deleted it, I haven't had the problem. I'll keep my fingers crossed just in case.

    still confused, though, if it really is the problem.

    One of the admins on my hosts support group suggested the problem might be linked to a php script taking too long to execute or overflowing memory.

    Any thoughts ?

Topic Closed

This topic has been closed to new replies.

About this Topic