WordPress.org

Ready to get started?Download WordPress

Forums

WP Supersized
Keep displaying controls with 1 image (because slidecaption is floating off) (1 post)

  1. pleasureinstitute
    Member
    Posted 1 year ago #

    When only one image is being displayed, the controls disappear, which is ok. Not so ok is that the caption now floats randomly on the page, whereas it's contained by the controls with nodes having multiple images.

    It's quite easy to solve this in the code. Go to WPsupersized.php (in the includes-folder of the plug-in), and go for the line 441. There you'll see conditionals in the like of:

    if ($options['navigation'] && $options['slideshow'] == '1' && $totalSlides > 1)

    Remove or comment the "&& $totalSlides > 1" and the controls will appear whether the node contains one image or more, which puts you back in control over the position of the #slidecaption.

    It should look like this now:

    if ($options['navigation'] && $options['slideshow'] == '1'/* && $totalSlides > 1*/)

    Fact is: this will get removed in the next update you apply of WPsupersized.

    There are 3 possible ways to avoid this

    1. Through a way to alter these lines in another file that's not going to get updated so the changes made here will sustain after an update. (How) can this be done in WP?
    2. An extra option in the UI in the next version of WPsupersized ("[ ] Hide controls if there is only one image").
    3. A class added to the slidecaption-div or the body that distinguishes between the node having 1 or multiple images, in the next version of WPsupersized.

    Any ideas?

    http://wordpress.org/extend/plugins/wp-supersized/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

  • RSS feed for this topic
  • Started 1 year ago by pleasureinstitute
  • This topic is not resolved
  • WordPress version: 3.5.1