WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Just upgraded to 3.8 now my dashboard icons are gone (17 posts)

  1. GL8899
    Member
    Posted 7 months ago #

    Never had this problem before. Did a routine upgrade to 3.8, now I don't have dashboard icons. It all works, but there are no icons. Annoying. I looked in wp-admin/images and all the image files are there. What gives?

  2. esmi
    Forum Moderator
    Posted 7 months ago #

    Try re-uploading all files & folders - except the root wp-config.php & .htaccess files and the the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  3. GL8899
    Member
    Posted 7 months ago #

    Thanks for the response. However, when I went to the dashboard from a second physical location and computer (but using Firefox in both places) it was working just fine. Therefore it must have something to do with my browser settings at the first location. Maybe some kind of cacheing issue.

    Interestingly, when I used MSIE 8 (which WP says is obsolete and that I should upgrade that browser), the icons are again missing.

  4. drewkinney
    Member
    Posted 7 months ago #

    I had the same issue.

    I had the plugin "Bootstrap Admin Theme" Version 1.16.2, installed.
    I deactivated it and my icons re-appear in a responsive views, devices, browsers & OS's.

    Consider a plugin conflict as 1 possibility.

  5. OutdoorsWriter
    Member
    Posted 7 months ago #

    In Firefox, go to Tools, Options, Content. In Fonts & Colors, go to Advanced. Check "allow pages to choose their own fonts...." That took care of it for me.

  6. MrBeta
    Member
    Posted 7 months ago #

    This is the reason why your dashboard icons have changed. With 3.8, the dashboard icons are actually a font. For example, if you do a firebug inspection, you will see that the "posts" icon is "\f109". From what I have read, by doing this, the icons load faster and are now responsive in size as a font. Also, you don't have to have a hover image because it is a font, it will automatically change according to your color scheme.

    Here is a link to the icons created by MP6 (the developers of the new dashboard). http://melchoyce.github.io/dashicons/

    So to use the dashicons, there are a couple of steps you need to take:

    When you register your post type you need to add the following line of code:

    'menu_icon' => '',

    So for example your code would look like this:

    $args = array(
        'labels' => $labels,
        'public' => true,
        'menu_icon' => '',
        'publicly_queryable' => true,
        'show_ui' => true,
        'show_in_menu' => true,
        'query_var' => true,
        'rewrite' => true,
        'capability_type' => 'post',
        'has_archive' => true,
        'hierarchical' => false,
        'menu_position' => null,
        'supports' => array('title', 'editor', 'thumbnail')
      );
      register_post_type('cptname',$args);
    }

    Doing this, adds a class to your custom post type. Now we can add a function to tell wordpress to use the new css.

    function cptname_post_type_css() {
       echo "<style type='text/css' media='screen'>
               #adminmenu .menu-icon-cptname div.wp-menu-image:before {
                    content: '\\f307';
                }
             </style>";
    }
    add_action('admin_head', 'cptname_post_type_css');

    Just change cptname to be the name of your custom post type.

    This can all be added to your themes functions.php file or you can do it through a custom plugin.

    There is also some documentation over at http://hofmannsven.com/2013/laboratory/wordpress-dashicons/ that show how to create your own custom icons that you can upload to your site as well.

    Hope this helps.

  7. GL8899
    Member
    Posted 7 months ago #

    THANK YOU OutdoorsWriter and MrBeta! You reign supreme! Your simple solution of setting Firefox to allow web pages to choose their own fonts took care of the issue for me! MrBeta, I had no idea these were actually fonts, not icons!

  8. OutdoorsWriter
    Member
    Posted 7 months ago #

    You're welcome! I had no idea the icons are fonts. Learn something new every day.

  9. MrBeta
    Member
    Posted 7 months ago #

    And you're welcome! This is the latest trend with 3.8. I have been messing with it a bit and love it. Way easier to add custom icons (less code...less mess) and I like the new look and feel of the dashboard. Kinda feels like the new iOS look and feel.

  10. cobourgpress
    Member
    Posted 7 months ago #

    OK enough of the geek talk as a regular user I am getting really tired of tweaking my sites to satisfy your revamp urges. Just as I get the program working the way it should according to me a non geek who has no interest in rewriting php files a plugin or program upgrade is instituted.

    All upgrades should explain the potential problems and then we have the choice whether to upgrade.

    Hate to tell you that this problem occurs in both IE and Firefox when the user chooses to override the the preset fonts in the options.

    Give me back my control. I decide what I watch not you.

  11. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    @cobourgpress - please start your own thread if you need help. This one is resolved so your issue is clearly not the same.

    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

  12. Roger2013
    Member
    Posted 7 months ago #

    @outdoorswriter Many thanks, worked for me as well!

  13. samdobrow
    Member
    Posted 7 months ago #

    This browser setting should be explained in the release notes.

  14. muldari
    Member
    Posted 4 months ago #

    I honestly do not believe this is the problem, as I have the exact problem of missing dashboard icons on ONE of over 20 sites running WordPress 3.8.1.

  15. MC
    Member
    Posted 4 months ago #

    It seems like its a font display issue that is related to firefox.

    After reading the thread, I tried to recreate the issue in chrome and they display fine.

    Will keep messing around with it.. must be some minor issue. I tried checking the 'let sites choose their own fonts' but it was already enabled..

  16. deviceguru
    Member
    Posted 3 months ago #

    I'm with MC on this. I have just been pulling out my hair over this after finally taking the leap to 3.8 from 3.7.2 due to the OpenSSH debacle, and have wasted a valuable hour trying to figure out why the admin icons weren't rendering from wp-content/images/* like they did previously. Then I found this thread and adjusted firefox and all is ok now. But it would have been useful for the upgrade to supply a warning that it was about to break my images if I had that mainstream browser set with a fairly common option.

  17. Larry
    Member
    Posted 2 weeks ago #

    There is probably a manual edit that can do this as well, but if you download the advanced settings add-on there is an option under the web sites icon to tellFirefox to download fonts embedded in web sites. I had to enable this to get the icons to display. However, now I seem to have some very odd characters in my dashboard fonts and I've seen them on some of the posts here as well. I would say it's an encoding issue, but all my encoding settings seem to be right. It makes it hard to read, particularly when typing inside edit boxes.

Reply

You must log in to post.

About this Topic