WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Just upgraded to 3.1 and post-excerpt field in admin disappeared (28 posts)

  1. The_liz
    Member
    Posted 3 years ago #

    Right after upgrade, there is no more post-excerpt field below the post-edit area in my admin. What could be causing this?

  2. rogersjosephjr
    Member
    Posted 3 years ago #

    3.1 has a few bugs out of the box.

    It removes Archive links
    Category Links

    Adds a Bar on top of the site client side, that there is no option to remove. It has upset many of my clients.

    If i am not mistaken, a FEATURE should always have the ability to turned on and off?

    Otherwise it is core functionality.
    Hummm...

  3. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    @The_liz Just clisk on screen options and turn post_excerpt back on, you can turn off and on whatever you like

    @rogersjosephjr Its best to start your own support thread, not hijack others
    --the admin bar can be turned off per user or by code
    http://voodoopress.com/2011/02/wordpress-3-1-admin-bar-upgrade-issues/

  4. Samuel B
    moderator
    Posted 3 years ago #

    3.1 has a few bugs out of the box.

    It removes Archive links
    Category Links

    I've now upgraded 16 sites - only one had a modest problem - so no there are not "bugs"
    and from what I've seen so far, about the usual number of problems in this version

  5. rogersjosephjr
    Member
    Posted 3 years ago #

    Realy? so what your saying is that the 80 reported so far of my 138 that the Category Links produce 404 errors after the upgrade are not errors? Well then, if its not an error, it must be a Feature.

    sorry didn't sign up for that feature.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    It removes Archive links, Category Links

    Not on any of my 10 sites it didn't. Including one that uses a positively ancient theme.

    Adds a Bar on top of the site client side, that there is no option to remove.

    Incorrect. See Troubleshooting WordPress 3.1 - Master List

  7. Realy? so what your saying is that the 80 reported so far of my 138 that the Category Links produce 404 errors after the upgrade are not errors? Well then, if its not an error, it must be a Feature.

    It's neither (come on, folks, lets work TOGETHER, eh?).

    Practically, we all MUST accept that it's mathematically impossible for WP's beta testers (the vast majority of whom are volunteers) to test EVERY server setup with EVERY mix and match of themes and plugins. Right? Okay. So yes, this are missed. Things are ALWAYS missed. We take what's missed, fix 'em and move forward to make next time better for everyone.

    So rogersjosephjr, I for one would greatly appreciate your help here :) Can you make a fresh topic detailing exactly what went wrong? I know it's work, but you can help the community by doing that.

  8. WordWeaver777
    Member
    Posted 3 years ago #

    @Rev Voodoo:

    You said:

    "Just clisk on screen options and turn post_excerpt back on, you can turn off and on whatever you like"

    When I go to the posts page and click on "Screen Options", there are check boxes for the following under "Show On Screen":

    Author
    Categories
    Tags
    Comments
    Date

    There is also a field to set the number of posts to show.

    However, I see no option to re-add the excerpt text area that was under the post editor in 3.0.5.

    Am I missing something?

    Thanks!

    The WordWeaver
    http://www.endtimeprophecy.net/Blog/

  9. 3.1 hides some screen options on posts & pages edit screensby default. Just turn on the ones you want.
    More info here: http://ottopress.com/2011/wp-quickie-metaboxes/

  10. WordWeaver777
    Member
    Posted 3 years ago #

    Hello Ipstenu,

    Thanks for your response.

    I followed the breadcrumbs and found the post made by Bill Erickson where he shared his code for making all of the metaboxes show by default under "Screen Options". I now have the "Excerpt" option back again on the "Add A Post" page.

    To save some of you the hassle, here is the code. Just place it in your theme's "functions.php" file, right before the final "endif;" at the bottom of file:

    // Change what's hidden by default
    add_filter('default_hidden_meta_boxes', 'be_hidden_meta_boxes', 10, 2);
    function be_hidden_meta_boxes($hidden, $screen) {
    	if ( 'post' == $screen->base || 'page' == $screen->base )
    		$hidden = array('slugdiv', 'trackbacksdiv', 'postexcerpt', 'commentstatusdiv', 'commentsdiv', 'authordiv', 'revisionsdiv');
    		// removed 'postcustom',
    	return $hidden;
    }

    The WordWeaver
    [sig moderated as per the Forum Rules]

  11. wadsworth2
    Member
    Posted 3 years ago #

    Thanks for that snippet, WordWeaver. So for CUSTOM POST TYPES, shouldn't something like this work? Not getting anywhere with it.

    if ( 'post' == $screen->base || 'page' == $screen->base || 'books' == $screen->base )

    Love custom post types, but they sure can be frustrating at this stage in the game. Any advice appreciated.

  12. kchristiehg
    Member
    Posted 3 years ago #

    I'm having the same problem: no place to input or edit excerpts when I'm adding or editing a post. The fixes above don't work, unfortunately.

    I added the "Excerpt Editor" plugin, and that works, but it's not convenient to go to Tools > Excerpt Editor instead of just adding an excerpt on the Add Post screen.

  13. kchristiehg - read http://ottopress.com/2011/wp-quickie-metaboxes/

    They're all still there, you just need to enable them again.

  14. kchristiehg
    Member
    Posted 3 years ago #

    Thanks. That works perfectly.

  15. sledge81
    Member
    Posted 3 years ago #

    Hello,

    I'm using wp 3.1 and despite enabling post excerpt it doesn't show up while adding a post.

    Also after adding a link in a post, I am redirect to a new post.

    Has anyone had a similar experience? Looking for a resolution

  16. sledge81 - Make a new TOPIC. This is not the same problem.

  17. vectyr
    Member
    Posted 3 years ago #

    How do I enable the excerpt area again globally for all users? I have a site where they want all authors to have access to the excerpt box without having to instruct them all to find 'screen options' and click the check box.

  18. ThreeToedCrow
    Member
    Posted 3 years ago #

    Just found this on a post from Otto Destruct at http://ottopress.com/2011/wp-quickie-metaboxes/

    Just go to your "Edit Post" page, then click on the "screen options" tab near the top right of the WP admin area. There you'll see several tic boxes to turn on and off ALL features for that page.

    Screen shot from Otto's site: http://ottopress.com/files/2011/02/metabox-dropdown.png

    This also works on ALL other pages throughout you WP admin area.

  19. surfintica
    Member
    Posted 3 years ago #

    I tried the Ottopress link and I cannot find anywhere the "screen options"

    Can someone please show me where they are in 3.1

    Thank you

  20. surfintica - Look at the TOP of your screen. See the grey admin bar?

    BELOW that and ABOVE the 'create a post' header is the tab. It's on the far right.

  21. kikolani
    Member
    Posted 3 years ago #

    I think the issue is that the screen options is missing. Here is my admin bar...

    http://farm6.static.flickr.com/5030/5551367248_75654ebeff_b.jpg

    I have screen options on some of my other sites, but this one that I just installed with WordPress 3.1 and Thesis 1.8 doesn't have the link. And I definitely need my excerpts field back!

  22. kikolani
    Member
    Posted 3 years ago #

    Found the problem (in mine at least). Disable the Jetpack plugin and the Screen Options show up again!

  23. That could do it. Interesting. I'll pass that on to them!

  24. vCopia
    Member
    Posted 3 years ago #

    Ipstenu... Just wanted to say thanks for the link to your recent article. I'm one of those dopes who needed a swift reminder kick to recheck the screen options so my excerpt section reappeared in the post editor after a 3.1.1 upgrade.

  25. lasthopeofhumanity
    Member
    Posted 3 years ago #

    Howdy

    The problem I had, even as an experienced WordPress user, designer and developer is that:

    A: I hardly ever go near Screen Options, used it once to change dashboard ages ago.
    B: The WordPress Update message hides the Screen Options dropdown. Considering I'm testing on my own webserver, it won't even let me update anyway.

    I can see the point of taking the not used often fields out but that really, really needed to be made obvious where to find them again. Come on guys, you can do better than that. Usability in WordPress Admin is normally exceptional.

  26. To solve B - Update manually.

  27. readydesigns
    Member
    Posted 3 years ago #

    To wadsworth2,

    For custom post types, you need to enable the features when you register them. Look here. Look specifically for the "supports" array, where you'll add "excerpt" to the list of supported features. You'll be doing something along these lines:

    register_post_type( 'prefix_yourposttype',
     array(
       'labels' => array(
         'name' => __( 'Your Post Types' ),
         'singular_name' => __( 'Your Post Type' )
       ),
       'supports' => array(
         'title',
         'editor',
         'excerpt'
       ),
       'public' => true,
       'has_archive' => true,
       'menu_position' => 20
     )
    );

    Alternatively, you can also use add_post_type_support().

    I hope that helps!

  28. readydesigns
    Member
    Posted 3 years ago #

    To add the excerpt feature to pages (assuming it isn't showing under "Screen Options"), add the following code to your functions.php file.

    //Add Excerpts to Pages
    add_action('init', 'yourprefix_add_page_excerpt_support');
    
    function yourprefix_add_page_excerpt_support() {
    	add_post_type_support( 'page', 'excerpt' );
    }

    Functions.php is found in "wp-content\themes\[your-currently-active-theme]\".

Topic Closed

This topic has been closed to new replies.

About this Topic