WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Just some blogs inaccessible (2 on 20) ! (11 posts)

  1. cornemu
    Member
    Posted 2 years ago #

    Hi !

    Here is a strange bug : I have about 20 blogs / sites on my wp multisite install and since a few days (maybe the last update... I didn't check everything at this time...) :

    - one blog send blank pages for all URL, login... (the server send a 404 message via firebug with a non existing URL but display a blank page too) : this is the installation blog, the first one, the current site in wp-config.php
    - another one send correctly the front end but wp send a 404 page not found on all admin pages (/wp-admin/, /login...)

    All other blogs are fine for everything !!!

    Of course I tried to deactivate all plugins for those two blogs directly in the database as well as clear all the rewrite rules... but nothing changed !

    Has somebody seen such a mess ? Or has any idea or solution to debug ?

    Thanks

  2. cornemu
    Member
    Posted 2 years ago #

    Oups ! ;-)

    One bug resolved... for the first blog, the problem came from the theme... the theme was used by two blogs and has been renamed, so that's for the blank pages...

    But the second bug still exists.

  3. Which is the second bug? Can't get to admin pages?

    Were you able to before?

  4. cornemu
    Member
    Posted 2 years ago #

    Yes, at this site, I was able to access to the admin area. It's FORCE_SSL_ADMIN config option but anyway, anything can be reached inside the admin dir in SSL or not.

    And the other 20 sites on the same multisite installation can be accessed...
    There is a plugin, theme my login activated, but the same as the other sites.

  5. Interesting, the URL kicks out to ?page_id=6&redirect_to=https%3A%2F%2Fsamsara.spoogue.org%2Fwp-admin%2F&reauth=1

    In the database, in the table wp_x_options (where X is that subdomain) what's the row with 'permalink_structure' got in it?

  6. cornemu
    Member
    Posted 2 years ago #

    It's :

    /%year%/%monthnum%/%postname%/

    And usually, the plugin Theme My Login redirects to https://domain.tld/login/?page_id=6&redirect_to=https%3A%2F%2Fdomain.tld%2Fwp-admin%2F&reauth=1

  7. Do you know how to disable plugins via SQL? I'd turn off the plugins.

  8. cornemu
    Member
    Posted 2 years ago #

    Actually, I tried by replacing the active_plugins field in the wp_x_options table by :
    a:0:{}

    The field was :

    a:10:{i:0;s:56:"aarons-no-ssl-flash-upload/aaron-no-ssl-flash-upload.php";i:1;s:19:"akismet/akismet.php";i:2;s:43:"all-in-one-seo-pack/all_in_one_seo_pack.php";i:3;s:36:"contact-form-7/wp-contact-form-7.php";i:4;s:19:"lightbox/plugin.php";i:5;s:47:"really-simple-captcha/really-simple-captcha.php";i:6;s:33:"theme-my-login/theme-my-login.php";i:7;s:21:"wp-print/wp-print.php";i:8;s:27:"wp-super-cache/wp-cache.php";i:9;s:39:"wp-table-reloaded/wp-table-reloaded.php";}

  9. And nothing?

    Wild... I would say try flushing the cached permalinks but I can't remember how to.

  10. cornemu
    Member
    Posted 2 years ago #

    Ok... you were right ! I changed the chmod of the plugin directory to 000 so the normal wp way to login appeared !

    I have to manage this plugin now...

    Thank for your help ! :-)

  11. cornemu
    Member
    Posted 2 years ago #

    It should be the cached permalinks... now that I can access the admin area, I will flush it : I think it can be done by changing the permalink structure, apply it and come back to what we want...

    Thank you again.

Topic Closed

This topic has been closed to new replies.

About this Topic