WordPress.org

Ready to get started?Download WordPress

Forums

just moved site, media upload broken (6 posts)

  1. johndove523
    Member
    Posted 1 year ago #

    I just moved my site from a /wordpress/ subdirectory to the root (http://caspca.org)

    Everything is working fine, except that my media upload is broken - error:

    “boot1.JPG” has failed to upload due to an error
    The uploaded file could not be moved to /home/caspca/public_html/wp-content/uploads/2012/06.

    I have looked at numerous related posts, all suggesting that this is a file permissions issue. My uploads folder is presently set to 755, and I have tried 666, 766, 767, 775, and even 777 will not allow me to upload media.

    Under my Settings > Media, the "store uploads" and "full url" fields are set to defaults (blank). That's as much information as I have to offer based on what due diligence I've done.

    Any help would be appreciated.

    Thanks,

    John

  2. johndove523
    Member
    Posted 1 year ago #

    note - I guess this update was considered a "bump", as this post was deleted within 30 minutes. Apologies if this was the case. In keeping with protocol, here is my follow up from yesterday:

    I just moved my site from a /wordpress/ subdirectory to the root (http://caspca.org)

    My media upload is broken - error:
    “boot1.JPG” has failed to upload due to an error
    The uploaded file could not be moved to /home/caspca/public_html/wp-content/uploads/2012/06
    .

    I am also having problems in Appearance > Editor making file writable, which I'm guessing goes to the same issue of making files writable. As an example, I can wipe out my header.php file completely via Dreamweaver on the live server, yet the header remains completely intact on the live site.

    I have looked at numerous related posts, all suggesting that this is a file permissions issue. I have tried changing permissions to my theme, wp-content, and uploads folders, everything from 666 to 777, including 766, 767, 775 ( presently set to 755), all to no avail. Plus, most of these threads are old, referring to Miscellaneous Settings, which are long gone.

    Under my Settings > Media, the "store uploads" and "full url" fields are set to defaults (blank), though I don't get step #11 from http://codex.wordpress.org/Moving_WordPress#On_Your_Existing_Server :
    You must also check and edit 'store uploads folder' under Settings > Media or all your new uploads will continue to go into the old folder. - edit to what??

    And I saw the suggestion to change the php.ini file to safe mode - OFF, which I looked at and it was set to "off."

    I don't know what else to do, but I need to get this fixed. I would greatly appreciate some help.

    Thank you,

    John

  3. “boot1.JPG” has failed to upload due to an error
    The uploaded file could not be moved to /home/caspca/public_html/wp-content/uploads/2012/06.

    What are the permissions on that folder?

    Don't worry about the rest of it right now :) Just check what /home/caspca/public_html/wp-content/uploads/ (and all the subfolders) are set to :)

  4. johndove523
    Member
    Posted 1 year ago #

    Mika,

    Thanks for your reply. I'm a bit confused by the "/home/caspca/public_html" part, as I can't see that part of the path in my ftp, but (starting with the first thing I *can* see, the permissions on the "/" (root) folder are 0.

  5. johndove523
    Member
    Posted 1 year ago #

    ...ending with the path "/uploads/2012/06" - all three of those are set to 755.

  6. johndove523
    Member
    Posted 1 year ago #

    I cannot change file permissions on the "/" (root) folder... I assume the web host has to do it...is this the problem?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags