WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
[resolved] Just displaying [theme-my-login] instead of the login form (20 posts)

  1. Nick5a1
    Member
    Posted 2 years ago #

    Hello,

    Just installed the latest version of this plugin, and on the login form created by the plugin the shortcode [theme-my-login] is displayed on the front end instead of the actual form. This is the case with both Twenty-Ten 1.3 and Twenty-Eleven 1.3. Any ideas?

    Thanks,
    Nick

    http://wordpress.org/extend/plugins/theme-my-login/

  2. thartung
    Member
    Posted 2 years ago #

    Hello Nick,

    i got this, when TML is deactivated. Checked, that Theme My Login is active?

    Kind Regards
    Thomas

  3. Nick5a1
    Member
    Posted 2 years ago #

    Yes of course. I've also tried deleting the plugin and re-installing.

    The only thing "Not default" I can think of about my installation is that the installation and site address were previously at a different URL on the same domain and server. Of course everything else works perfectly after the move. I didn't have theme my login installed before the move so I can't say whether this is the cause.

  4. Jeff Farthing
    Member
    Plugin Author

    Posted 2 years ago #

    There's only 2 reasons this would happen:

    1. TML is not active
    2. Your template is displaying the content with the_excerpt rather than the_content
  5. Nick5a1
    Member
    Posted 2 years ago #

    Hi Jeff,

    1. TML definitely is active.
    2. I am displaying my content with the_content. As mentioned above, I am experiencing this error with both the TwentyTen and TwentyEleven themes.

  6. Jeff Farthing
    Member
    Plugin Author

    Posted 2 years ago #

    Disable any other plugins and try again. Another plugin may be removing shortcodes from the content.

  7. Nick5a1
    Member
    Posted 2 years ago #

    Hi Jeff,

    This is also one of the first things I did. I had no other plugins at all enabled and with both the unmodified TwentyTen and TwentyEleven themes still experienced the problem.

    As I mentioned above, the only thing not default about installation is that it previously came from a different URL on the same server.

  8. Jeff Farthing
    Member
    Plugin Author

    Posted 2 years ago #

    Can I take a look? If you do not wish to post your site publicly, contact me here. Also, if you can give me admin access, it would speed up the process of me figuring out what is going on.

  9. Nick5a1
    Member
    Posted 2 years ago #

    Thanks Jeff. I've sent you login details via your contact form.

  10. Jeff Farthing
    Member
    Plugin Author

    Posted 2 years ago #

    Wow - I'm stumped. What PHP version are you running?

  11. Nick5a1
    Member
    Posted 2 years ago #

    So you've never seen this before?

    Php is 5.2.17.

  12. Nick5a1
    Member
    Posted 2 years ago #

    So I realised I have another installation of wordpress on the same server that I haven't looked at in a long time, and it has Theme My Login installed... and working. So it is this installation not the server or PHP version.

  13. Jeff Farthing
    Member
    Plugin Author

    Posted 2 years ago #

    I just disabled permalinks and it now works...

  14. Nick5a1
    Member
    Posted 2 years ago #

    That fits with my theory that it must be something to do with having moved the wordpress installation directory?

  15. Jeff Farthing
    Member
    Plugin Author

    Posted 2 years ago #

    It has me baffled - Permalinks have nothing to do with whether or not the shortcode should work. Can I see the contents of your .htaccess file?

  16. Nick5a1
    Member
    Posted 2 years ago #

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  17. Jeff Farthing
    Member
    Plugin Author

    Posted 2 years ago #

    What is the first block for?

  18. Nick5a1
    Member
    Posted 2 years ago #

    /blog/ is where the installation was located before I moved it to the root directory. Not sure why, perhaps the second block got appended. I've removed the first block.

  19. Jeff Farthing
    Member
    Plugin Author

    Posted 2 years ago #

    Funny - that fixed it.

  20. Nick5a1
    Member
    Posted 2 years ago #

    Odd - but great news! Thanks for the help troubleshooting! Hopefully this will help other people who run into the same (obscure) issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.