WordPress.org

Ready to get started?Download WordPress

Forums

Pinboard
Just change homepage template (29 posts)

  1. propronk
    Member
    Posted 1 year ago #

    How can I just change the homepage template to "Full Width" even though the default template is Content / Sidebar?

  2. Angus Todman
    Member
    Posted 1 year ago #

    I would like to know the answer to this also.. Did you find a solution?

  3. propronk
    Member
    Posted 1 year ago #

    Unfortunately not. Anyone a clue?

  4. paul.a.cunn
    Member
    Posted 1 year ago #

    Is this page static or a post page?

  5. Angus Todman
    Member
    Posted 1 year ago #

    mine is static home page.

  6. propronk
    Member
    Posted 1 year ago #

    And mine is a static homepage too.

  7. paul.a.cunn
    Member
    Posted 1 year ago #

    Since your pages are static you should be able to go to the "Pages" then select the static homepage of your site. On the right just select the page template you want. Here is a link to a screen shot of the template selector.

    http://snag.gy/oYmFR.jpg

  8. Angus Todman
    Member
    Posted 1 year ago #

    Yes I thought it would have been that easy as well. Though my home page does not show up in pages or in posts. here is my home page. http://www.globallingos.com. I must be missing something here. I do have 3 posts as part of the home page. Does that change things? Thanks so much paul!

  9. paul.a.cunn
    Member
    Posted 1 year ago #

    This is a post page, hence the posts on the page. :) If this is the page you want to edit then you are not actually using a static front page. For this you will need to edit a php file which is a little scary but this is really an easy fix. Go to "Appearance" then "Editor" then select Pinboard in the top right drop down menu. Find the file "index.php" Find and remove the following code. It should be towards the end. This should remove the sidebar from the landing page even if it has widgets in the sidebar.

    <?php get_sidebar(); ?>

  10. propronk
    Member
    Posted 1 year ago #

    Hi Paul, *ahumm* my homepage is a postpage as well ;)

    I deleted the code you mentioned and the sidebar-widgets doesn't show.

    But it looks like if the sidebar isn't completely removed from the landingpage. The sidebar accounts for 1 column from the grid (even though the sidebar doesn't appear).

    With 'full width' the homepage shows 3 post on a horizontal row. After removing the 'get_sidebar'-code the 3rd post jumps below the 2 other posts. If I change the grid layout dimensions to 4 content columns, there is still an empty white space on the right side (where the sidebar-widgets could appear).

    Any suggestions for the 3 post I want to show on my homepage?

  11. paul.a.cunn
    Member
    Posted 1 year ago #

    Yeah this is an easy fix just add a little css but I need a link to your site to correctly do this. For 3 columns you just need to add the following.

    .twothirdcol {
    width: 100%;
    }

    I would assume its something similar for 4 columns, but I can't be sure without the link.

  12. propronk
    Member
    Posted 1 year ago #

    Where do I need to add this little CSS code? Somewhere in the index.php?

  13. paul.a.cunn
    Member
    Posted 1 year ago #

    Download Jet pack (should be on your dashboard) and activate the custom css editor. Then under "appearance" you will see "Edit Css" just paste the above code in there and it will override the current css settings for whatever you pasted in there.

  14. propronk
    Member
    Posted 1 year ago #

    Thanks Paul. I pasted the code there.

    I guess we are almost there: but now the 2 posts appear on one entire (!) row. And the 3rd on the row below. I would like the 3 posts next to eachother :-)

    Should 'twothirdcol' be threethirdcol or something?

  15. paul.a.cunn
    Member
    Posted 1 year ago #

    Yeah it might be I need a link to your site to make sure as I said before :)

  16. paul.a.cunn
    Member
    Posted 1 year ago #

    Never mind I looked it up. Here is what you need

    .threefourthcol {
    width: 100%;
    }

    Cheers!

  17. propronk
    Member
    Posted 1 year ago #

    You are my hero :-)
    it works!
    Tnx

  18. paul.a.cunn
    Member
    Posted 1 year ago #

    No worries sorry for the elongated fix! Marked this as resolved so other people can look at the fix!

  19. propronk
    Member
    Posted 1 year ago #

    Paul, because of the CSS change -meant for the homepage- it looks like the default template (content/sidebar) gets overruled by this code:
    .threefourthcol {
    width: 100%;
    }

    The normal contentpages don't show the default template when I place widgets in the sidebar. Those widgets appear under the left content column.

    Do you know how to get the widgets next to the content with the template content/sidebar? Except for the homepage :-) That one is okay now!

  20. paul.a.cunn
    Member
    Posted 1 year ago #

    When you say "under the left column" do you mean they do not appear on the side at all and that they get pushed to the bottom of the page?

  21. propronk
    Member
    Posted 1 year ago #

    Yes, that's what I mean. White space on the right side and the widgets pushed down under.

  22. Angus Todman
    Member
    Posted 1 year ago #

    Im not sure if this helps, though I had a very similar issue as you as you can see from the earlier posts. This fixed my page up perfectly.

    example.. http://globallingos.com/classes/live-classes/

    I put it in the Appearance/Theme optins/layout. Then down the bottom of that page there is a custom CSS section (You do use Pinboard right?)

    .twocol {
    width:32%
    }

    Also I had my default layout as 'Full width' which you can find on the same page as you put the custom CSS. and I has the actual page where I want the widgets neatly on the right as Content/sidebar.

    Hope that helps..

  23. hartmutnz
    Member
    Posted 1 year ago #

    ..hope you gus resolved this? Really, it's not a good idea messing with the native css pages, because you will have to keep track of that in case of UPDATES, which destroys all your work.. So only use the "custom css " field under : Theme Options >> Appearance >> Layout to insert code. To address the original problem: Set homepage to full template. First of all most times you install this theme there is no static "Homepage" already there. Simply edit the "Sample" page it to your needs, then re-name it HOME. Then edit the MENU to include and reflect the change. Hope this helps. Most time the theme displays the "empty" home page with the WIDGETS showing. The widgets are showing usually 1 full post , then the Links in grid view to category pages or whatever they have been set to. Hope this helps. If you use a static home page you can do whatever you like with it. If you want to include other posts there use SHORTCODES, or widgets, hope that helps.. Look at the possibilities of the Pinboard theme on my site: http://www.artandcraftconnection.com

  24. Angus Todman
    Member
    Posted 1 year ago #

    Hi Harmutnz..

    Could you please explain this step that you have jsut mentioned?

    "Simply edit the "Sample" page it to your needs, then re-name it HOME. Then edit the MENU to include and reflect the change".

    I was always wondering how to find my "Home page" in the admin.

    Thanks

  25. hartmutnz
    Member
    Posted 1 year ago #

    There is no home page really... what you see originally is the "sample" page. If you re-name it HOME in the Title , set the HOME page as your static page in THEMES >> CUSTOMIZE, it will be your home page. Then Go to APPEARANCE >> MENUS >> and create a new menu. Then add the pages (from the list on the right)you want and save the menu. Then there is a field on the right where you determine what menu to use on the top navigation bar.. set it to the menu you created. Done. Have fun!

  26. propronk
    Member
    Posted 1 year ago #

    Paul described a solution for a post (landing)page (not a static page).
    1. This code removed the sidebar from the landingpage
    <?php get_sidebar(); ?>

    2. To show 3 columns on a row on the landingpage I had to add this code in the CSS
    .threefourthcol {
    width: 100%;
    }

    3. My default layout template is 'Content/Sidebar' with 3 content columns.
    When I select 'default template' on a page, the widgets in the sidebar of a page show perfect next to the content.

    BUT: on the landingpage the 3 posts don't appear in one row next to eachother. The 3rd post is pushed to the bottom of the page.
    If I change the content columns to 4, the landingpage is okay. BUT the rest of the contentpages is not. Then the sidebar gets pushed under te content...

    My question:
    Do I need to change this code, so the landingpage shows 3 columns?
    .threefourthcol {
    width: 100%;
    }

    My next question:
    Or is the only solutions: make a static homepage?
    Where do I find "sample" page, so I can change the title in 'Home' (etcetera)?

  27. paul.a.cunn
    Member
    Posted 1 year ago #

    @Hartmutz: This will only work for a static page also there is no editing of native css style sheets in this thread. The only native page that was edited was the php page which is such an easy fix that when you do update the theme it takes less than 2 seconds to do the same thing. Alternatively you could download the child theme plugin and then upload a new php page to that which will override the pinboard php page (which is what I do).

    @Angus your css fix is great but it does this on every page which will not fix the issue if you have multiple pages and want the sidebar on those pages but not the index page.

    Here is a link where they are dealing with the same issue.
    http://wordpress.org/support/topic/how-to-remove-sidebar-on-1-page-and-keep-it-on-the-others

  28. hartmutnz
    Member
    Posted 1 year ago #

    Thanks Paul, great help! I'll give the child theme a go, because in the long run it's the best solution as you say..

  29. hartmutnz
    Member
    Posted 1 year ago #

    Now, this thread has become a bit of a mess. Lets get back to the start. The question was how to get a homepage with no sidebars and 3 columns. OK, with a fresh installation, add pinboard as theme. Then to set the home page either static or dynamic, go to: APPEARANCE >> THEMES >> Customize . Click Customise button. On the right side you have options: Static Frontpage OR Your latest posts. Click whatever you like! If you choose a static Frontpage you select the page SAMPLE. This is you actual static home page! Click Save and Publish - Then go back to the admin panel DASHBOARD, click on: EDIT YOUR FRONTPAGE it is the first link.
    - Your Frontpage pops up. Change the TITLE on top from "sample page" to HOME or whatever you like to call it. If you call it Home it will make a navigation button : HOME on your website. Choose the template on the right: Set it to NO SIDEBARS , save the page or publish.
    This will look like: http://www.artandcraftconnection.com/restaurant5/

    DONE - to set 3 columns: GO TO >> APPEARANCE >> THEME OPTIONS >> LAYOUT - Scroll to where it says: Grid Layout Dimensions >> Content Columns: and set to 3 - DONE, set more options there if you like and save..
    This should all be working now. You can play around with more options in the Layout Options, Design, General and Typography on the THEME OPTIONS page.
    Also be aware to set the amount of posts you want to show on the homepage, this is set in theme options >> General: where it says: Home Page >> Full posts to display: xxx Full posts to display before grid, set the xxx to the number you want. it will show a thumbnail of your Featyured image and a small excerpt, linking to the post pages.
    See how this looks on my site:
    http://www.artandcraftconnection.com/ (The only difference is that I use the sidebar)
    Hope this helps anyone, cheers, Groogo

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.