WordPress.org

Ready to get started?Download WordPress

Forums

Relevanssi - A Better Search
[resolved] Just a few results when a number is part of the search query (13 posts)

  1. oldalgazda
    Member
    Posted 1 year ago #

    Developing a software knowledge base using WP and this wonderful plugin, whe have noticed that it we enter a search query like:

    [Software name] + [two-digit version number]
    like:
    Firefox 22

    Then we only get two results when there are hundreds of pages containing that expressions.

    But if we put the query in quotes:
    "[Software name] + [two-digit version number]"
    like:
    "Firefox 22"

    Then Relevanssi lists all the relevant results...

    What might be the reason for this? (Minimum word length to index is set to 1 and none of the words are included in the stopwords' list.)

    http://wordpress.org/extend/plugins/relevanssi/

  2. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Does searching for just "firefox" help? What if you search for "22" alone?

  3. oldalgazda
    Member
    Posted 1 year ago #

    Terve Mikko,

    Thank you for your quick answer!

    Well, both

    firefox

    and

    22

    provide satisfactory results.

    The problem occurs when I enter

    firefox 22

    only two or three results are listed.

    The reason why it would be vital to have good results for queries like

    firefox 22

    is that users will want to search for version specific content.

    Thank you,
    József

  4. LilyRuzza
    Member
    Posted 1 year ago #

    Hi there

    Just read this post and it seems I am having a similar issue.

    I use Relevanssi for the following website: http://nordicwalkingforhealth.co.uk it's a fantastic plugin, however my client recently highlighted that typing in Tailor-made course into the search bar doesn't bring up the 'courses' page that features a 'Tailor-made courses' section, it only brings up the 'Poles' page.

    When I put "Tailor-made course" in (inside quotes) the courses page comes up. I have tinkered around with the settings but can't grasp why the courses page won't come up without the quotes.

    Any ideas?

    Thanks, Lily

  5. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Oldalgazda, are you using AND or OR searches? Whichever you're using, try switching the setting.

    Lily, are those course sections on the "Courses" page just normal post content, or perhaps included from somewhere else?

    +1 for Nordic walking.

  6. LilyRuzza
    Member
    Posted 1 year ago #

    Hello Mikko

    Thanks for your response, I have used Advanced Custom Fields for a lot of the site as it needed to be highly customisable.

    So each course write up is a WYSIWYG ACF block

    e.g. <?php the_field('course_block_5'); ?>.

    Relevanssi and ACF seem to work really well together so I am not sure why this particular bit of content won't appear under the term tailor-made course.

    Thanks again for your time

    Lily

  7. oldalgazda
    Member
    Posted 1 year ago #

    Mikko,

    Thank you for your answer!

    We are using the following options:
    Default operator for the search: AND
    Disable OR fallback: YES
    Don't use fuzzy search: YES

    Thanks,
    József

  8. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    József, so, your problem is about the invisible spaces.

    Lily, that's the problem - Relevanssi doesn't understand that, and doesn't see the content of the field as part of the post. You need to make Relevanssi index those custom fields, then the content will be found. Add the "field name" in the Relevanssi option about indexing custom fields.

  9. oldalgazda
    Member
    Posted 1 year ago #

    Mikko,

    Unfortunately no, the problem still remains, this issue:
    http://wordpress.org/support/topic/minor-issue-with-non-breaking-spaces
    was only "responsible" for a few missing results.

    Even though having eliminated all non-breaking spaces, still the problem remains. I just mentioned there that during the investigation of this problem I have discovered an other minor one.

    Thanks,
    József

  10. LilyRuzza
    Member
    Posted 1 year ago #

    Hi Mikko

    My issue is resolved, thanks ever so much for your support.

    Love live ACF :)

    Lily

  11. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    So, József, what kinds of numbers were are talking here? How many posts in your database? Do you have the "Limit searches" option enabled? If you have, does disabling it help?

  12. oldalgazda
    Member
    Posted 1 year ago #

    Mikko,

    Thank you for your tip, it solved the problem. I have disabled the "Limit searches" option, and now everything seems fine.
    I don't know the internals, but you know apart from

    Firefox 22

    -like searches, that is where a two-digit number was also used, every other search results seemed to be just fine with the "Limit searches" enabled.
    Anyway, I have set this to 45 as we already have cca. 6000 posts, and wanted to make sure make the site is as fast as possible. Now with cached results it works still without speed problems - even with the "Limit searches" having disabled.

    Paljon kiitoksia!
    József

  13. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    45 is a fairly low limit, I think might experiment with values in the range of 200-500. But glad you got it sorted out.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic