WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Just a few minor tweaks needed (5 posts)

  1. pete_398
    Member
    Posted 3 years ago #

    Have now installed 3.1.3 from an XOOPS/XPress system. Despite a few hiccups with importing posts, etc, all went fairly well. Now, there are only a few minor thing.

    1. I have comments completely disabled, yet I see "Leave a comment" link ? How do I get rid of that please ?

    2. The login link is under the 'meta' label in the menu. I tried using the widgets under admin to see if I can get rid of that login link, but cannot see how to do it.

    3. Assuming I can get rid of the login link, can I rename the login file, so that people cannot attempt to login (unless they know the name of the login file).

    Pete

  2. webjunk
    Member
    Posted 3 years ago #

    1) Check the individual Post/Page and see if Comments are enabled. If you do not see it then change Show Options (near Top-right) to renable Comments in the Edit Page.

    2) Could be hardcoded in your theme?

    3) Can't help with this one. Sorry.

  3. pete_398
    Member
    Posted 3 years ago #

    Thanks for your help, much appreciated. I couldn't get it to 'turn off'.

    The theme I use is 'twentyten', and this is the line that displays the comment ..

    <span class="comments-link"><a href="http://example.com/?p=11#respond" title="Comment on this post">Leave a comment</a></span>

    Under admin/discussion settings, I have ..

    Allow people to post comments on new articles - unchecked
    Comment author must fill out name and e-mail - checked
    Users must be registered and logged in to comment - checked

    and I have registrations turned off.

    In the file /wp-content/themes/twentyten/loop.php , the following line appears 3 times ..

    <span class="comments-link"><?php comments_popup_link( __( 'Leave a comment', 'twentyten' ), __( '1 Comment', 'twentyten' ), __( '% Comments', 'twentyten' ) ); ?></span>

    Viewing individual posts, there is no comment links/lines, but viewing either the home page, or monthly archives, that annoying comment link/line is there.

    I want to remove it before opening up the site to 'public', otherwise crawlers and bots will continue to try to 'leave a comment'.

    Seems a LOT of people are having this problem try a forum search of 'twentyten comment'

  4. webjunk
    Member
    Posted 3 years ago #

  5. pete_398
    Member
    Posted 3 years ago #

    Thanks, I watched the videoas, no sound, but that is probably because my computer doesn't like youtube videos. Anyway, I was able to see what you were saying there, thanks.

    When I went into an individual post, comments were definitely 'off' (no comments), yet the "leave a comment" was still there. So, I unchecked 'Pingbacks and Trackbacks', for that post and that did it, it now displays 'Comments Off'.

    I then went into admin/discussion, and turned 'off' Pingbacks and Trackbacks, yet all the other posts still had that annoying link. So, checked the db, and there is a row in the posts table called 'ping_status', so some sql to do all posts ..

    UPDATEdatabase_name.wp_postsSETping_status= 'closed' WHEREwp_posts.ID>0;

    Thanks for your help,

    Pete

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.