WordPress.org

Ready to get started?Download WordPress

Forums

Jumping and disappearing widgets (9 posts)

  1. kjetilgf
    Member
    Posted 6 years ago #

    I experience several problems in the widgets panel.

    • When I try to move a widget, it does'nt drop in place like it should. Instead it jumps somewhere else (eg to the top of the screen) or the drop-place goes blank until I click save. If I at least get it in place (even if blank), when I then click save, it's there.
    • Its impossible to update widget settings, or the settings on one is blanked out even if I have just worked on an other. For instance setting excluded categories in "Enhanced categories" or php code in the "Widget Logic" field is likely to be a waste of time.

    Is this a bug?
    I have tried
    deactivating all plugins (apart from the one I'm eventually testing on) - I have replaced the WP widget files (see my entry) - and also emptied cache twice for each test.
    I have experienced similar problems with the included widgets, but using just them is not sufficient for my cms setup.
    From the other threads on this topic, I believe this must be a bug. Or do we have any ideas on how to solve it?
    Thanks,
    Kjetil

  2. Roy
    Member
    Posted 6 years ago #

    It's not really a bug, but I had some problems getting this to work as well. Drag and drop is no longer available in 2.5 (I don't know about 2.5.1 yet) and you have to add a widget, save changes, then change it, save the widget changes and then save changes for all widgets again. I have no problems with that screen anymore. I did have to upload the widgets.php and widgets.css (both in both folders) again.

  3. kjetilgf
    Member
    Posted 6 years ago #

    I've done all of that, too (after your tip on another thread) - and the procedure is as you describe it.
    The problem is that even then, the changes dissappears, especially in the widgets' text fields.
    I could also add that the widget panel loads veeery slowly (20sec+) - but only with the different widget plugins active (those above + Daiko's text widget) - all 2.5 campatible.
    Kjetil
    - on Mac with Firefox 2.0.0.14 (most reliable browser)

  4. Roy
    Member
    Posted 6 years ago #

    There're some upgrades regarding the widget panel in 2.5.1, did you already upgrade?

  5. kjetilgf
    Member
    Posted 6 years ago #

    Yes, straight away. I believe I also added a 2.51 tag on my initial entry here.
    By the way - a little correction: It is completely random which settings are being zeroed. But at least it always happens when working in the widget panel.
    I could also add that I'm using 40 widgets of 6 different kinds to give different sidebars in different category views. After all, its not just a blog I'm building. (dolcevita.no/wp)

  6. Doodlebee
    Member
    Posted 6 years ago #

    I'm having this same issue. New blog, running WordPress 2.5.1. I add widgets to the sidebar, and they "jump around" - instead of dropping where I want it to go, it goes above the sidebar thing or below it (I've noticed if I'm dragging up, then the widget will pop all the way up; if I'm dragging down, it goes all the way down. I don't mean to the end of the list, either - I mean off the charts.)

    After I get them settled, they take, everything's fine...but within 30 minutes, it resets and ALL of my sidebars disappear completely. I can go back in and drag them back over (the content in them isn't lost, but they just remove themselves from the sidebar) and go through all of the "jumping " again, get it set - everything's fine....until 30 minutes of inactivity later. (meaning, if I'm working on he site, it's totally fine for hours. If I stop, within 30 minutes, it's reset itself to no sidebars again).

    yes, I've changed to default, I've repaired the wp_options table (as suggested in another thread), cleared the cache, disabled all plugins, deleted and uploaded new files - it still does it.

    I'm going to have to revert to using the "if no sidebar" stuff and have it show my stuff by default, but I'd love to have that rearrangement ability. In fact, I *need* to have it.

    If anyone knows what's up, I'd love to hear the solution!

  7. moneypumps
    Member
    Posted 6 years ago #

    My problem with widgets in slightly different. I am using a theme with 3 side bars. No matter what I do, all the widgets I add go into sidebar one.

    I have tried this with different blog, different servers, different themes and the problem is always the same. Everything goes in sidebar one.

    Also, widgets cannot be rearranged at all.

  8. moneypumps
    Member
    Posted 6 years ago #

    I found this, which may be helpful to some. Unfortunately it did not fix my problem, but it may fix yours.

    http://www.wordpressmax.com/customize-wordpress/fix-widgets

  9. threestyler
    Member
    Posted 6 years ago #

    I have the the same expereince on several WordPress installs. When trying to change the order of Widgets they appear at the top of the screen.

Topic Closed

This topic has been closed to new replies.

About this Topic