WordPress.org

Ready to get started?Download WordPress

Forums

JSON API
JSON API doesn't work with more than 10 comments (4 posts)

  1. santito95
    Member
    Posted 8 months ago #

    Hi guys

    I'm making an app to BlackBerryEmpire.com, apparently all works fine, but when I enable a pulgin with facebook (like) integration, or when exists more than 10 comments, that api doesn't work properly.

    Check the following example:

    First try:
    http://blackberryempire.com/ctv-news-releases-blackberry-10-app/?json=1
    - Great! That works fine! (but without comments)

    Second Try:
    http://blackberryempire.com/holiday-giveaway-part-2-win-free-blackberry-z10-exclusively-blackberry-empire/?json=1
    - Oh snap! It have more than 10 comments and doesn't work properly.

    Really I don't know why is happen that.

    Anyone can help me?

    Thanks!

    http://wordpress.org/plugins/json-api/

  2. monkeypunch3
    Member
    Posted 8 months ago #

    You may need to add count=100 or whatever you choose as your max number of comments.

  3. santito95
    Member
    Posted 8 months ago #

    Where can I put or modify that setting?

  4. monkeypunch3
    Member
    Posted 8 months ago #

    I visited those pages and I think it could be multiple issues so I'll suggest a few things. I've had other plug-ins interfering with the output before so I would disable them one by one and see if it fixes anything. It also looks like you are using fancy URL's, (so "site.com/name-of-post/" versus "site.com/?p=100". There is a different syntax for fancy URLs, see http://wordpress.org/plugins/json-api/other_notes/. Also, visit the JSON-API plug-in page and see if there is a option to enable fancy URLs. You can also check the path you should use for your site. I don't use them myself. You could also try accessing the post by query string even with fancy URLS. So for example, use, "/?p=200&json=1" but replace 200 with the id of your blog post.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.