WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
JS error when try quick edit on SEO stuffs on all pages (8 posts)

  1. biswajeet
    Member
    Posted 11 months ago #

    Hi, just gave it a try with all latest version. When tried to edit the title, description or keywords I am getting javaScript error on all pages screen. So, check it out.

    Additionally, I am happy to see that the plugins handle the generation of xml sitemap nicely with the option of exclusion on per page/post basis. Thus we no longer need to use another plugin only for xml generation!

    But I would like to mention one thing regarding option - noindex, nofollow on per page/post basis is that when these are selected, It should be automatically exclude the post/page from the xml sitemap ~right :) that make sense. Because why one would do noindex/nofollow and then add the like to sitemap?

    thanks & appreciate!

    http://wordpress.org/plugins/all-in-one-seo-pack/

  2. Peter Baylies
    Member
    Plugin Author

    Posted 11 months ago #

    biswajeet,

    What is the Javascript error that you're getting?

    Re: why would people set X option and not set Y option - I don't know why people do what they do, but believe me, they do it... :)

  3. biswajeet
    Member
    Posted 11 months ago #

    The error is on quickedit_functions.js on line 7

    ReferenceError: aioseopadmin is not defined error source line:	
    
    ...<img src="' + aioseopadmin.imgUrl+'accept.png" border="0" alt="" title="'+meta+'...

    For second part suggestion with the reference above what actually I meant to say is simply to make exclude checkbox field depends on noindex or nofollow such that selecting any one of them auto select exclude checkbox. So, this makes the perfect logic that with noindex or nofollow set on it will be automatically excluded from the sitemap.

  4. Peter Baylies
    Member
    Plugin Author

    Posted 11 months ago #

    biswajeet,

    Ok, that should be defined in the header of the page. It should get loaded via the admin_init and admin_head hooks, and include a quickedit_functions.js file; do you see that in your header?

  5. biswajeet
    Member
    Posted 11 months ago #

    All right, I have found the problem. Its because of the black slash character in JS object aioseopadmin for pluginPath property. I am using windows and Xampp as development environment and that property comes out as
    pluginPath: "M:\xampp\htdocs\wptest\wp-content\plugins\all-in-one-seo-pack/"

    I just comment that property and it works. So, I think this problem doesn't arise other than windows.

    Better use wp_script_localization for JS object output which handle such situation nicely.

  6. Peter Baylies
    Member
    Plugin Author

    Posted 11 months ago #

    biswajeet,

    Thanks! I'll see if I can test and fix that on Windows for the next release...

  7. Peter Baylies
    Member
    Plugin Author

    Posted 10 months ago #

    biswajeet,

    I just tested this on Windows against 2.0.4 and it's working for me; I used Instant WordPress to test.

  8. biswajeet
    Member
    Posted 10 months ago #

    Thanks for the update info...
    I will check it.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.