WordPress.org

Ready to get started?Download WordPress

Forums

Codestyling Localization
[resolved] JS error - plugin not working (13 posts)

  1. straw94
    Member
    Posted 1 year ago #

    Hi,

    I installed Codestyling Localization but nothing happens when I click on "modify", "scan" or "delete" a translation file.

    I thought it was a conflict issue so I deactivated all plugins except Codestyling Localization plus switched to Twenty Twelve and still had the issue.

    I have some javascript errors showing up on the admin CodeStyling Localization page that seem to be the reason for this : http://cld.wthms.co/GJJC
    It looks like CodeStyling Localization is removing scripts it is adding by itself.

    Any idea to help ?

    Thanks,
    D.

    http://wordpress.org/extend/plugins/codestyling-localization/

  2. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    Twenty Twelfe is working with the plugin as only one.
    Do you have the latest version of CSL plugin?
    Do you have must-use plugin installed?

    BTW: screenshots are not suitable at all to investigate potential problems.

  3. straw94
    Member
    Posted 1 year ago #

    Hi,
    Sorry about the screenshot, my site is not released yet.
    Yes, I do have the latest version of the plugin.
    Do you want me to send you some admin codes so you can have a look at it?
    Best,
    D.

  4. toscho
    Member
    Posted 1 year ago #

    The error is:

    Uncaught exception: TypeError: 'Object.extend' is not a function
    Error thrown at line 4816, column 0 in http://single.wp/wp-admin/tools.php?page=codestyling-localization/codestyling-localization.php:
        Object.extend(Array.prototype, {

    Clicking the Add new language button raises the next error:

    Uncaught exception: TypeError: '$' is not a function
    Error thrown at line 4885, column 1 in csp_add_language(elem, type, name, row, path, subpath, existing, type, simplefilename, transtemplate, textdomain, denyscan) in http://single.wp/wp-admin/tools.php?page=codestyling-localization/codestyling-localization.php:
        elem = $(elem);
  5. straw94
    Member
    Posted 1 year ago #

    Thanks toscho.
    Any idea of the reason why this happens or how I can prevent it from happening ?

    Cheers, D.

  6. toscho
    Member
    Posted 1 year ago #

    @straw94 Sorry, no. The JavaScript is a … very large block, and I don’t have time for debugging now. Try Glotpress.

  7. straw94
    Member
    Posted 1 year ago #

    Sure ! Thanks :-)

  8. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    I can't analyse the issue completely. But you are using

    http://single.wp/
    as your domain and I assume, you did configure a local vhost within Apache doing so.
    My plugin currently requires protoype.js library which have been removed from WP since WP3.5 and replaced by CDN loading if required via google.
    I did replace that routing in terms of my plugin with self maintained versions of protoype.js (script.acoulo.us) delivered at my pages as usual.
    The WordPress own jquery version calls at last statement the jQuery.noConflict() but I have seen replacements from jQuery within wp-includes folder, not having that last line at supported other users.
    The did replace the WordPress bundled files with their own newer version but didn't realize, why WordPress is doing so.

    So in total: it could be a url request issue for the prototype.js files (should be visible at firebug with 404 delivery) or could be a jquery modification at your installation.

  9. straw94
    Member
    Posted 1 year ago #

    Hi,
    And thanks for the explanation ! I'm not a dev though, so it's not really clear to me ^^
    The thing that I hadn't noticed before and that you highlighted is that my domain is not http://single.wp at all (no idea what this is) but I have done nothing (configure local host within Apache or else) to have it set up like this. Unfortunately it doesn't help because I've already tried to deactivate all plugins and switch to theme "Twenty Twelve" and it was still unusable. My website is visible on http://www.mychocobox.fr/demo (not online yet). Please tell me if you require admin access to investigate this issue.
    Cheers,
    D.

  10. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    An Account would be a good idea to inspect the issue in real live. Could you please send me the credentials by mail (can be found at my blogs imprint page)?

  11. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    Have been analysed in cooperation and will be solve with version 1.99.30 comming soon.

  12. straw94
    Member
    Posted 1 year ago #

    Thanks, much appreciated !

  13. kool_69
    Member
    Posted 1 year ago #

    I am facing exactly the same issue like straw 94. I just installed version 1.99.30 but this did not change anything.

    When I go to Tools -> Localization it says:

    Scripting Guard [ details ] The Plugin Codestyling Localization was forced to protect its own page rendering process against 999 incidents !

    under details I even find the following entry:

    Malfunction at 3rd party Plugin detected!
    Name: CodeStyling Localization | Author: Heiko Rabe
    Below listed scripts has been automatically stripped because of injection:

    *domain*/wp-content/plugins/codestyling-localization-1/js/prototype.js
    *domain*/wp-content/plugins/codestyling-localization-1/js/wp-scriptaculous.js
    *domain*/wp-content/plugins/codestyling-localization-1/js/effects.js

    So prototype.js has been removed and I guess this must be the reason if I understand your earlier postings right!? Any idea what could be the reason or what I could do?

    Thanks in advance.

    Cheers,
    Kool

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.