WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate CMS
[resolved] JS error in admin menu (13 posts)

  1. Dravenrip
    Member
    Posted 1 year ago #

    HI !

    i just install this great plugin on my new WP 3.5 website and i get some problems.

    First of all, i can't use the drag'n drop system from the nav-menu admin interface.
    I get an JS error that say "e.widget.extend is not a function in
    file http://www.mySite.local/wp-admin/load-scripts.php?c=1&load=jquery,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-draggable,jquery-ui-droppable,wp-ajax-&load=response,jquery-color,wp-lists,postbox,nav-menu&ver=3.5
    Ligne : 15"

    When i turn off the plugin, everything is ok.

    Other bugs, when i'm using the ultimate CMS interface i get some php notice/warning like this one :
    Notice: Undefined variable: xydac_core_show_doaction

    is this a incompatibility problem with WP 3.5 ?... can i solve these problem easily ?

    thanks for your help !!

    http://wordpress.org/extend/plugins/ultimate-cms/

  2. acmb3
    Member
    Posted 1 year ago #

    Hey Dravenrip,

    I had a custom plugin that was causing the same error "e.widget.extend" - to fix it I removed my call to my own jquery library within the plugin and used WP's default.

    You might be able to fix the above issue doing the same, go into the plugin ultimate cms and comment out the base jquery include (leaving any custom ones of course). See if that fixes it.

  3. Dravenrip
    Member
    Posted 1 year ago #

    Well done acmb3 !! it solved my JS problem !!
    Thanks a lot, i can reactivate the plugin now.

  4. aaronrobb
    Member
    Posted 1 year ago #

    What file was the jquery that you commented out??

  5. XYDAC
    Member
    Plugin Author

    Posted 1 year ago #

    Please update to latest version.

    Regards,
    -Xydac

  6. GuruOnline
    Member
    Posted 1 year ago #

    I'm having the same problem - I have updated the plugin to the latest version but still having the issue. I a using WP 3.5.1.

    As aaronrobb asked, what file / line needs to be edited out for this fix?

    By the way Xydac...great plugin :)

  7. XYDAC
    Member
    Plugin Author

    Posted 1 year ago #

    Guys,
    This may be due to some compatibility issues,
    you may try commenting line with code
    wp_enqueue_script("jquery");
    and write it as
    //wp_enqueue_script("jquery");

    This would be at line 193 in index.php at /wp-contents/plugins/ultimate-cms/index.php
    Please let me know if this solves the issue..!!!

    Regards,
    -Xydac

  8. GuruOnline
    Member
    Posted 1 year ago #

    Thanks Xydac - I've tried this fix but unfortunately it's still not working.

    I've had one or two issues on other sites I maintain and the issues have been due to the JQUERY update (on the Google CDN) that had been recently updated (not sure if this is related).

    All was working fine two weeks ago and today having gone to the site I am getting this issue. The only issue I've noticed is to do with the "drag n drop" UI on WP admin interface when tryin gto organise widgets. When I disable the Ultimate CMS plugin all is fine

  9. XYDAC
    Member
    Plugin Author

    Posted 1 year ago #

    Found the issue,
    there was a conflict between jQuery UI 1.10 and WordPress jQuery UI 1.9

    Reverted to 1.9 to fix.

    Kindly update to latest...

    Regards,
    -Xydac

  10. GuruOnline
    Member
    Posted 1 year ago #

    Where can I get the fix? Has the WordPress repository been updated or do you have a download link please?

    Thank you very much for your swift movement and help on this :)

  11. XYDAC
    Member
    Plugin Author

    Posted 1 year ago #

    grab it from WP repo..

  12. GuruOnline
    Member
    Posted 1 year ago #

    Brilliant - I can confirm that this fix worked for me!!!

    Thank you so much - I feel a review coming on. :)

  13. XYDAC
    Member
    Plugin Author

    Posted 1 year ago #

    Cheers...

    and thanks for review..

    -Xydac

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.