WordPress.org

Ready to get started?Download WordPress

Forums

Edge Suite
[resolved] jQuery issues (13 posts)

  1. pjburnhill
    Member
    Posted 1 year ago #

    Hi,

    I'm having some loading issues with Edge Suite v0.4 for WP v3.5. I'm using the Imbalance 2 theme from http://imbalance2.wpshower.com/. It loads a jQuery for the infinite scroll plugin and because Edge Suite loads another jQuery, there is two versions loaded. I'm having issues now because of this. What's the solution here? Is there a way to point Edge Suite to another jQuery than the one bundled with the .oem?

    Thanks,
    PJ Palomaki

    http://wordpress.org/extend/plugins/edge-suite/

  2. pjburnhill
    Member
    Posted 1 year ago #

    The jQuery conflict is really messing up with my site layout, so I've decided to disable it and use other animation in stead. There really should be an option to either link to a already existing jQuery or something similar..

  3. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Have you checked the other issues in the queue? E.g. http://wordpress.org/support/topic/javascript-jquerry-conflict

    Try the dev version of the plugin
    http://downloads.wordpress.org/plugin/edge-suite.zip and activate the jquery no-conflict mode in the settings

  4. pjburnhill
    Member
    Posted 1 year ago #

    Right, installed dev version and enabled no-conflict mode and it seems to work, console reports another version of jQuery include already exists but seems to deal with that ok.

    How 'reliable' is this no-conflict mode? I.e. is it going to have cross-browser or other issues like that?

    Thanks for your help ti2m, seems like the plugin is doing its work.

    Also I've used a webfont in the animation and got it to work with the edge animation, it would be great to have some sort of webfont support in the plugin, but I assume that's possibly more down the line.

    PJ

  5. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    the message about the other jquery version is just a log message that the plugin prints so you know that you are running in no conflict mode. This shouldn't appeare unless you enabled the debug setting, I'll check up on that.
    In theory the no conflict mode should be stable, at least so far no one had any issues anymore, I'll soon push the feature into the stable branch. As this relies on the core jQuery no conflict feature there shouldn't be any crossbrowser/device issues. But time will tell ;)

    I'm not sure in what way the module should support webfonts. Webfonts in edge are handled through the edge runtime and are not CSS specific anymore as far as I remember. So webfonts should work out of the box. If not, what did you have to do to get the webfonts to work within the animation in WP?

  6. pjburnhill
    Member
    Posted 1 year ago #

    Sorry for the confusion, what I meant is custom webfonts, not only the ones you can choose in edge animate. I've used the Bree webfont and included it in the WP template header: <script src="http://use.edgefonts.net/bree-serif.js"></script>

    In Edge Animate I typed in bree-serif in the webfont selection but I had to manually include it in the template header. I assume that if I used the bundled webfont picker in EA, it would include it automatically? Am I right? Anyway this seems to work fine so far.

    On the jQuery, just off-chance, is it possible that the other jQuery could load (because of network lag?) AFTER Edge Suite's jQuery and since it's NOT enabled for non-conflict, it would have issues? Is this even possible? I.e. should both of the jQuery's be loaded as non-conflict?

    Thanks Tim

  7. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, I think EA handles all the webfont stuff if you use the build in functionality.

    The problem with jQuery is that a lot of plugins extend the jQuery variable, like in your case. Then EA comes in and overwrites the jQuery var, so the extensions are gone and you get errors. In general I don't know how clever it is to extend the jQuery object, but EA doesn't seem to do that. If EA loads first and then gets overwritten it doesn't matter as it will just use that version. That of course just works as long as the jquery versions are equal, or at least similar enough.

    So, the no conflict mode isn't 100% bullet proof but that is a problem on a more general level and then the other plugins need to stop using the jQuery object + namespace as it is right now.

  8. pjburnhill
    Member
    Posted 1 year ago #

    Thanks, well if I run into more jQuery issues, I'll let you know. The no-conflict seems to do the trick for now.

    Thanks again for your help,
    PJ

  9. Ninjamankid
    Member
    Posted 1 year ago #

    Hi,

    installed the above dev version of the plugin. I tick the "Run a separate instance of jQuery for Edge Animate." radio button, but when I Save it gets unticked. Very weird...

    Johan

  10. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    can't reproduce this. Did you maybe just replace the plugin files and the stable version was installed before? If so please remove the plugin completely and then get the dev version. The activation hook of the dev version needs to run to add the option for jquery to the database.

  11. Ninjamankid
    Member
    Posted 1 year ago #

    Hi,

    thnx for taking time to answer. What is a "activation hook" and how do I get it to run? :-)

    Johan

  12. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hey,

    forget the activation hook, that was just some technical background. Basically just try to deactivate and activate the plugin. If that doesn't work remove the plugin completely and do a fresh reinstall of the dev version.

  13. Ninjamankid
    Member
    Posted 1 year ago #

    Hi,

    thanx for helping me out! It worked removing the original plugin and installing the dev version instead. I can now activate the "Run a separate instance of jQuery for Edge Animate." and "Run Edge Suite in debug mode" buttons.

    Don't want to hijack thread but my real problem is that all new .aom files that upload to WP refuses to show on a page. I have posted about it here:
    http://forums.adobe.com/message/5056843#5056843

    Hoped that running a separate instance of jQuery might help but it didn't.

    Johan

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic