WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] jQuery error on 3.6 upgrade jquery-1.10.2.min.map 404 (37 posts)

  1. Wil
    Member
    Posted 1 year ago #

    All of my recently upgraded 3.6 sites are trying to load the jQuery resource /wp-includes/js/jquery/jquery-1.10.2.min.map

    e.g.
    GET http://www.limecanvas.com/wp-includes/js/jquery/jquery-1.10.2.min.map 404 (Not Found)

    The file is not there.

    Anyone else have this problem

    Wil.

  2. Jon Täng
    Member
    Posted 1 year ago #

    I have that to.

  3. bdm55
    Member
    Posted 1 year ago #

    Since I updated I'm getting this ..on one of my sites ...

    blockUI requires jQuery v1.2.3! You are using v1.10.2.

    Any help available out there??

    Thanks

  4. ChipsOnFire
    Member
    Posted 1 year ago #

    I just posted this in a separate post. It will hopefully sort you out...

    http://wordpress.org/support/topic/wordpress-36-and-jqueryblockui-version-problem-solution

  5. Wil
    Member
    Posted 1 year ago #

    Thanks @ChipsOnFire

  6. markomavric
    Member
    Posted 1 year ago #

    As I can see, jQuery has problem with missing file. So possible solution is to copy file from http://code.jquery.com/jquery-1.10.2.min.map to your wp-includes/js/jquery/ folder.

  7. ChipsOnFire
    Member
    Posted 1 year ago #

    As I can see, jQuery has problem with missing file. So possible solution is to copy file from http://code.jquery.com/jquery-1.10.2.min.map to your wp-includes/js/jquery/ folder.

    I am not sure what you are referring to here markomavric. Where can you see that there is a problem with that file missing for jQuery??

  8. ChipsOnFire
    Member
    Posted 1 year ago #

    Ah, don't worry, I see it now :-)

  9. As I can see, jQuery has problem with missing file. So possible solution is to copy file from http://code.jquery.com/jquery-1.10.2.min.map to your wp-includes/js/jquery/ folder.

    No, don't do that ever. Seriously that is 100% a really bad idea. Never modify anything or add new files into the WordPress directories. Aside from losing that file with an update it's really not manageable or supportable.

    Sometimes when sites become corrupted (that happens sometimes due to host or user errors) the fix is delete the wp-includes directory and copy the files back from the zip file.

    If ChipsOnFire's solution works then please use that instead.

    http://wordpress.org/support/topic/wordpress-36-and-jqueryblockui-version-problem-solution?replies=6#post-4486355

    http://wordpress.org/support/topic/troubleshooting-wordpress-36-master-list?replies=5#post-4484014

  10. s7uar7
    Member
    Posted 1 year ago #

    Have I missed something or did no one actually address the jquery-1.10.2.min.map 404 problem? Lots of talk about blockUI but that seems to be because the thread was hijacked by bdm55 in post 3.

    I'm getting the 404 on jquery-1.10.2.min.map after upgrading too. I've downloaded the WordPress zip file to check but it doesn't include /wp-includes/js/jquery/jquery-1.10.2.min.map

  11. bdm55
    Member
    Posted 1 year ago #

    s7uar7 ...

    You are correct in part I did post about the blockUI ..

    At the time I did not realize I was in the wrong thread.

    I apologize for causing any deviation from the topic. However - hijacked is an unnecessarily hostile word and implies intent - which I did not have.

    Again - I'm sorry for the inconvenience.

  12. s7uar7
    Member
    Posted 1 year ago #

    No problem bdm55; I didn't mean you did it deliberately.

    I've tested on a WordPress installation with the default Twenty Thirteen theme enabled and no plugins and I get the same error, so it would seem it's a problem in the core WordPress install.

  13. flash_dg
    Member
    Posted 1 year ago #

    I don't know why this is the reason, but the error occurs as a result of this line:

    //@ sourceMappingURL=jquery-1.10.2.min.map
    /wp-includes/js/jquery/jquery.js line 2

    If you remove that line (and obviously you shouldn't as that's hacking the WP core) then the error goes away.

  14. flash_dg
    Member
    Posted 1 year ago #

    Okay, so have dug a bit deeper into this and it seems that sourceMappingURL is a relatively new tool you can use in JS when minifying your code to map each line of it back to the un-minified version of the source. See here for reference. So basically you either have to comment out the sourceMappingURL line in the jquery.js file or you have to download the source map if you can find it. Think this is something that the guys at WP will have to resolve - it's not theme specific, it's a problem with the core.

  15. s7uar7
    Member
    Posted 1 year ago #

    I have a suspicion that the download is only triggered if you are using one of these analysis tools. If it was requested every time then my logs would be full of 404 responses for 'normal' users, but it's not.

  16. swiftdemise
    Member
    Posted 1 year ago #

    s7uar7 I think you're right. I no longer get the jQuery error even though WP hasn't been updated. Must be one of the plugins.

  17. stilfx
    Member
    Posted 1 year ago #

    I'm getting this as well..

    GET https://s1.wp.com/_static/jquery-1.10.2.min.map 400 (Bad Request)

    I think this is a Jetpack error?

  18. stilfx
    Member
    Posted 1 year ago #

    I cannot find any other posts or resolutions on it though??

  19. Matt Lowe
    Member
    Posted 1 year ago #

    On a site I administer they were seeing this. I traced it to the Ozh' Admin Drop Down Menu plugin. I upgraded it and all was well again. If you're not using that plugin then try deactivating plugins in turn until you find the culprit. If you can update it do, otherwise leave a message on the plugin's forum asking them to look into the issue.

  20. Seth Carstens
    Member
    Posted 1 year ago #

    I get this error on all pages, I disabled all plugins, I activated the 2013 theme, and I check front end and back end, the same 404 message shows up. I actually think its connected to the WP-Admin bar, simply because the script that creates it is very close to the admin bar, and I only see the error when logged in.

    Anyone know of a solution?

  21. Devin Walker
    Member
    Posted 1 year ago #

    Same issue here - 404 in the admin

  22. simonseddon
    Member
    Posted 1 year ago #

    I sorted this by de-registering jQuery in functions.php:
    <?php wp_deregister_script( 'jquery' ); ?>
    - really didn't like having a wp-includes/ directory in my source code.

    Obviously you need to register a new jquery after doing this if your theme relies upon it, but that's a good thing. I like to control how, where, and which version gets loaded:
    http://codex.wordpress.org/Function_Reference/wp_register_script
    - not forgetting to enqueue it afterwards, of course.

    This works fine but seems to affect both the front and back-end. Not a problem, but annoying. I'm sure previous versions of WP didn't do this but I could be wrong.

  23. davidmh
    Member
    Posted 1 year ago #

    simonseddon, you can wrap the de-register/register inside a condition using !is_admin()

    http://puu.sh/4bAgP.png

    http://codex.wordpress.org/is_admin

  24. kim vin
    Member
    Posted 1 year ago #

    It's not a prob just for source debug. It can be closed by uncheck the "Enable source maps" setting in Developer Tools.

  25. mgratch
    Member
    Posted 1 year ago #


  26. joefletcher
    Member
    Posted 1 year ago #

    kudos to kim vin! I unchecked "Enable source maps" in Chrome Developer Tools, and the jquery-1.10.2.min.map 404 error went away.

  27. Devin Walker
    Member
    Posted 1 year ago #

    So this isn't actually a problem with WordPress but rather a bug in Chrome Dev tools? That's where I've seen the error, haven't bothered checking in Firebug.

  28. JsonB123
    Member
    Posted 1 year ago #

    I made a long post about how my "enable source maps" was checked and I was still getting an error...and then I reread haha. UNchecked.

    However, doing this means you cannot edit JavaScript on that page, correct?

    Are there any other implications to unchecking this box on Chrome?

  29. tjtate
    Member
    Posted 1 year ago #

    This is a wordpress 3.6 issue. This will be resolved in 3.6.1

    http://core.trac.wordpress.org/ticket/24994

    in the meantime remove the:

    //@ sourceMappingURL=jquery-1.10.2.min.map
    /wp-includes/js/jquery/jquery.js line 2

    as mentioned above and update to 3.6.1 when its released.

  30. kim vin
    Member
    Posted 1 year ago #

    @JsonB123, @Devin Walker
    It's a tool for keep your client-side code readable and more importantly debuggable even after you've combined and minified it, for more detail: Introduction to JavaScript Source Maps

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags