WordPress.org

Ready to get started?Download WordPress

Forums

Len Slider
[resolved] jQuery error on 2.0.9 with Vania Fit skin (4 posts)

  1. kevinhower
    Member
    Posted 1 year ago #

    My coworker installed LenSlider (1.2 I believe) on a site he built, and when we updated the plugins recenly, LenSlider 2.0.9 doesn't work correctly. I was able to revert to that earlier version which is what the live site is currently using and the hosting company helped me create a debugging version of the site so I could continue to try to resolve the problem.

    I did some checking with some of the debugging tools in the browsers:

    I found that in the Firebug console, it gives an error that says:

    Type Error: JQuery(…).tabs is not a function
    jQuery("ls_van_fit_ibanner").tabs();

    then to the right, there is an url for the file in which the error occurs: [site url] /wp-content/plugins/len-slider/skins/vania_fit/output/js/custom.js?ver=2.0.9

    In Chrome's developer tools, in the Scripts section, when I look at that same file, it gives a big red-highlighted error:

    Uncaught TypeError: Object#<Object> has no method 'tabs'

    In that same Chrome tool, when I look at the default-skin-custom.js, it does not give me the same Uncaught TypeError. Only the custom.js file does this. I know just enough to be dangerous, as the saying goes. But I'm hoping that I've provided enough info for a start but please let me know if I need to give you more. Hopefully this will help in improving the plugin as well. In case it is of use, the theme he built the site on is Rutherfordiumy, which is a free theme.

    Thanks so much,
    Kevin

    http://wordpress.org/extend/plugins/len-slider/

  2. kevinhower
    Member
    Posted 1 year ago #

    BTW, I used site url instead of the real url. I'm hesitate to post that for security reasons.

  3. Igor Sazonov
    Member
    Plugin Author

    Posted 1 year ago #

    Hi! I will take a look at this week! Thanks for good info!

  4. Igor Sazonov
    Member
    Plugin Author

    Posted 1 year ago #

    I think this is not a plugin problem. Seems your template hasnt wp_head or wp_footer functions or something wrong with WP/theme files, because tabs is a function of jQuery UI that must be called in footer/header, so plugin calls jQuery UI as well. Take a look at your theme or send me your site url at sovletig(gav-gav)yandex(dot)ru

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic