WordPress.org

Ready to get started?Download WordPress

Forums

Admin Menu Editor
[resolved] Jquery Error After Saving (5 posts)

  1. infoaltea
    Member
    Posted 1 year ago #

    Hi,

    I can install the plugin ok, and see the Menu Edit page, I can play around, but after saving I get a page with no css loaded and nothing saves if I relaod the admin panel.

    Firebug says: ReferenceError: jQuery is not defined
    [Stop on this error]

    Here is the code:

    (function($){
    $('#screen-meta-links').append(
    '<div id="ws-pro-version-notice">' +
    'Upgrade to Pro' +
    '</div>'
    );
    })(jQuery); == ERROR!

    Any help!!¿¿

    http://wordpress.org/extend/plugins/admin-menu-editor/

  2. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    It sounds like the menu data might be getting stripped out by something. What URL do you see in the address bar after you click "Save Changes"?

  3. infoaltea
    Member
    Posted 1 year ago #

  4. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, it appears that something strips the menu data before the plugin can save it. There are several things that could cause this:

    - A security system like mod_security2 or similar is running on your server and blocking menu data because it contains "suspicious" keywords. Other users have encountered similar problems where it turned out that mod_security was preventing them from saving the menu because menu settings contained words like "update" and "set" (as part of "Settings").

    Solution: Ask your hosting provider if mod_security2 or something similar is installed on the server. If so, tell them to add an exception for this plugin, or to disable the offending configuration rule.

    - The server discards menu data because it exceeds the post_max_size limit set in PHP.ini.

    Solution: Set post_max_size to a higher value (at least 1MB).

    - Suhosin is installed on your server and strips out the menu data because it exceeds the configured maximum size of values sent via a POST request.

    Solution: Increase suhosin.post.max_value_length and suhosin.request.max_value_length to at least 300000. If you don't know how to edit Suhosin's configuration, ask your hosting provider to do it for you.

  5. infoaltea
    Member
    Posted 1 year ago #

    suhosin.post.max_value_length issue...!!

    Thx for guiding me in the right direction,.... Didnt think about checking the apache error log ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic