WordPress.org

Ready to get started?Download WordPress

Forums

Post Types Order
[resolved] jquery error? (7 posts)

  1. jynk
    Member
    Posted 1 year ago #

    not sure when this stopped working but i can no longer update positions. I can drag and drop OK but on trying to update i get this error -

    Error: cannot call methods on sortable prior to initialization; attempted to call method 'serialize' on wordpress's wp-includes/js/jquery/jquery.js

    /*! jQuery v1.8.3 jquery.com | jquery.org/license */

    http://wordpress.org/extend/plugins/post-types-order/

  2. nsp-code
    Member
    Plugin Author

    Posted 1 year ago #

    Most probably another plugin de-register the default jQuery sortable and enqueue another one. You should try to de-active the plugins one by one to see which one create the problem. You may want to switch the theme to default to make sure it's not the problem.
    You can also try a browser cache clear or another browser.

  3. jynk
    Member
    Posted 11 months ago #

    OK - still got nowhere with this despite deactivating all other plugins and removing all related queued scripts. Could you supply the correct cods to get this working with jquery?

    I'v bought the advanced version so would be good to be able to use this. Weirdly the non advanced version works fine but obviously i want to re-order inside categories.

    I can drag the objects but when i click update i still get this error.

    Error: cannot call methods on sortable prior to initialization; attempted to call method 'serialize'

    Using the latest version of WP and plugin.

  4. nsp-code
    Member
    Plugin Author

    Posted 11 months ago #

    Hi,
    If you own the advanced version, please get in touch with us through Contact http://www.nsp-code.com/contact-us/ and someone will help you / check on this right away.

    Thanks

  5. nsp-code
    Member
    Plugin Author

    Posted 11 months ago #

    By the way the latest plugin version is 2.5.7.3

  6. jynk
    Member
    Posted 11 months ago #

    ace - needed update & working now.

    I keep forgetting purchased plugins need to be manually updated/checked.

  7. nsp-code
    Member
    Plugin Author

    Posted 11 months ago #

    In fact all versions newer than 2.5.4.9 can be updated automatically through WordPress, either from Plugins or Dashboard Updates.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic