WordPress.org

Ready to get started?Download WordPress

Forums

Lightbox Plus Colorbox
JQuery Colorbox Internet Explorer IE 8 Error in jquery.colorbox.1.3.32 (3 posts)

  1. jchambo
    Member
    Posted 1 year ago #

    It appears that IE8 is giving me the following error when trying to launch this plug-in. It works in EVERY other browser, besides IE8.

    Webpage error details
    
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; chromeframe/24.0.1312.57; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E)
    Timestamp: Thu, 14 Feb 2013 17:43:10 UTC
    
    Message: Invalid argument.
    Line: 560
    Char: 4
    Code: 0
    URI: http://itc.advocatehealth.com/itckb/wp-content/plugins/lightbox-plus/js/jquery.colorbox.1.3.32.js?ver=1.3.32

    Line 560 shows the following information:

    function modalDimensions(that) {
    $topBorder[0].style.width = $bottomBorder[0].style.width = $content[0].style.width = (parseInt(that.style.width,10) - interfaceWidth)+'px';
    $content[0].style.height = $leftBorder[0].style.height = $rightBorder[0].style.height = (parseInt(that.style.height,10) - interfaceHeight)+'px';
    }

    Any help would be greatly appreciated!

    http://wordpress.org/extend/plugins/lightbox-plus/

  2. pivanov
    Member
    Posted 1 year ago #

    Hey,

    Reset/Re-initialize did it for me. The problem appears to be in the initial settings after plugin activation. You can, probably, reproduce this "bug" if the plugin is installed on a fresh WP site (i.e. no database entries for it's options). If you have error reporting for development you'll notice a ton of 'undefined variable' messages on the plugin's settings page after activation. It appears that the default options are not set.
    A quick look at 'init.class.php', more specifically line 33, reveals that the default options will never be initialized on activation since $lightboxPlusOptions is always set. The following might be a potential fix:>>>
    diff --git a/wp-content/plugins/lightbox-plus/classes/init.class.php b/wp-content/plugins/lightbox-plus/classes/init.class.php
    index f1777c3..49541de 100644
    --- a/wp-content/plugins/lightbox-plus/classes/init.class.php
    +++ b/wp-content/plugins/lightbox-plus/classes/init.class.php
    @@ -16,7 +16,8 @@
    */
    function lightboxPlusInit( ) {
    global $g_lightbox_plus_url;
    - $lightboxPlusOptions = get_option('lightboxplus_options');
    + $lightboxPlusOptions = get_option('lightboxplus_options', FALSE);
    + $lightboxPlusOptionsExist = (bool) $lightboxPlusOptions;

    /**
    * Remove following line after a few versions or 2.6 is the prevelent version
    @@ -30,7 +31,7 @@
    *
    * @var wp_lightboxplus
    */
    - if (!isset($lightboxPlusOptions) || isset($_POST['reinit_lightboxplus'])) {
    + if (FALSE == $lightboxPlusOptionsExist || isset($_POST['reinit_lightboxplus'])) {
    $lightboxPlusPrimaryOptions = $this->lightboxPlusPrimaryInit();
    $lightboxPlusSecondaryOptions = $this->lightboxPlusSecondaryInit();
    $lightboxPlusInlineOptions = $this->lightboxPlusInlineInit();
    <<<

  3. Pankaj Asopa
    Member
    Posted 11 months ago #

    Try resetting the plugin and this will work/

    See Here

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic