WordPress.org

Ready to get started?Download WordPress

Forums

124

Comprehensive Google Map Plugin
[resolved] [closed] jquerey error after wordpress 3.6 update (92 posts)

  1. bball349
    Member
    Posted 11 months ago #

    After updating to wordpress 3.6, Comprehensive Google maps stopped working. I have verified on another site that the plugin works properly before the 3.6 update but stops working after. Please help!!!!

    I get the error message below:

    "ATTENTION! (by Comprehensive Google Map Plugin)

    Your blog/site theme or one of your plugins uses jQuery javascript library which is older than the version 1.3.0.
    The Comprehensive Google Map plugin will not work with such outdated jQuery version.

    The minimum jQuery requirement for Comprehensive Google Map plugin is version 1.3.0. Apologies for the inconvenience."

    Please help!!!

    http://wordpress.org/plugins/comprehensive-google-map-plugin/

  2. jacklee2
    Member
    Posted 11 months ago #

    ya i having this prob also ... anyone can help pls...

  3. pma4life
    Member
    Posted 11 months ago #

    Same here.

  4. gary.coleman@peritus.co.za
    Member
    Posted 11 months ago #

    Ye same issue here.

  5. JaeIk Jeong
    Member
    Posted 11 months ago #

    I have same issue. help

  6. stopczas
    Member
    Posted 11 months ago #

    I also sign on this list with same problem

  7. coastlog
    Member
    Posted 11 months ago #

    Quick workaround:

    You need to edit the file assets/js/cgmp.framework.min.js

    Find the line

    if(1.3>m)return alert(i.oldJquery),!1;

    and change it to:

    if(1.1>m)return alert(i.oldJquery),!1;

    Then open the file assets/js/cgmp.framework.js

    Find

    var version = parseFloat($.fn.jquery);
    if (version < 1.3) {

    and change that to:

    var version = parseFloat($.fn.jquery);
    if (version < 1.1) {

    That should do the trick...

    Regards,

    Michael
    // coastlog.net

  8. InsightDezign
    Member
    Posted 11 months ago #

    Worked Perfectly! Thank you.

  9. Marius Jensen (Clorith)
    Member
    Posted 11 months ago #

    This is caused by the upgrade to jQuery 1.10.2 with WP 3.6, seems the version check can't distinguish between .1 and .10

  10. jacklee2
    Member
    Posted 11 months ago #

    change frame.js already ... still same getting error

  11. Nick McBurney
    Member
    Posted 11 months ago #

    Yeah worked for me, thanks alot!

  12. jacklee2
    Member
    Posted 11 months ago #

    ...why not work for me d .... .....

  13. JaeIk Jeong
    Member
    Posted 11 months ago #

    map plugin disable and enable.

  14. coastlog
    Member
    Posted 11 months ago #

    @jacklee2: If all else fails, delete the following lines from assets/js/cgmp.framework.js:

    if (version < 1.3) {
        alert(CGMPGlobal.errors.oldJquery);
        //Logger.fatal("Client uses jQuery older than the version 1.3.0. Aborting map generation ..");
        return false;
    }

    Don't forget to make a backup first.

    Regards,

    Michael
    // coastlog.net

  15. daviz1982
    Member
    Posted 11 months ago #

    Thanks coastlog, you make my day :D

    Anyway, I'd rather prefer to write
    if (version < 1.3 && version != 1.10)
    instead of downgrade plugin to jquery 1.1

  16. onlyjc
    Member
    Posted 11 months ago #

    Thanks coastlog, worked a treat

  17. bball349
    Member
    Posted 11 months ago #

    Thank you coastlog. Thank worked!!!!

  18. Nick Sarro
    Member
    Posted 11 months ago #

    Still getting error after doing all that was said here.

    I then tried what COASTLOG said - (Delete this)

    if (version < 1.3) {
    alert(CGMPGlobal.errors.oldJquery);
    //Logger.fatal("Client uses jQuery older than the version 1.3.0. Aborting map generation ..");
    return false;
    }

    With no luck in finding that in the assets/js/cgmp.framework.js

  19. Nick Sarro
    Member
    Posted 11 months ago #

  20. lindleworks
    Member
    Posted 11 months ago #

    I just fixed this on one of my clients sites as well. The latest version of jQuery has sure been problematic.

  21. Didier77
    Member
    Posted 11 months ago #

    Thanks coastlog!! Your workaround works for me!

  22. nickduq
    Member
    Posted 11 months ago #

    This fixed my issue with Chrome users however people using IE 9 and 10 just get the 'loading' image and it never loads.

    :(

  23. ArtShop
    Member
    Posted 11 months ago #

    Thanks, Coastlog.

  24. Nick Sarro
    Member
    Posted 11 months ago #

    Strange It just started working. Awesome!

  25. andioh
    Member
    Posted 11 months ago #

    Same issue, will there be a update who fix this problem? i'am not that good to change this in code. Hopw you will release a update soon! Thanks!

  26. normanlacy
    Member
    Posted 11 months ago #

    Sorry, but I am new at this.
    But where do I find the file "assets/js/cgmp.framework.min.js" ?

  27. coastlog
    Member
    Posted 11 months ago #

    @normanlacy:

    The complete path is:

    wp-content/plugins/comprehensive-google-map-plugin/assets/js

    Regards,

    Michael
    // coastlog.net

  28. asutosh
    Member
    Posted 11 months ago #

    i have done first change but unable to find

    var version = parseFloat($.fn.jquery);
    if (version < 1.3) {
    and change that to:

    in the file assets/js/cgmp.framework.js

    also my banners stopped scrolling anybody please help.

  29. normanlacy
    Member
    Posted 11 months ago #

    Thanks Michael,

    With your help I have now found "cgmp.framework.min.js." using your path "wp-content/plugins/comprehensive-google-map-plugin/assets/js"

    But I have searched that file and cannot find "var version = parseFloat($.fn.jquery);
    if (version < 1.3) { "

  30. normanlacy
    Member
    Posted 11 months ago #

    Hi Michael,

    I have found this towards the bottom of the page.
    "m=parseFloat(a.fn.jquery);if(1.3>m)"

    Is this where I change the "1.3" to "1.1"

    And how do I do that when the page doesn't accept edits. I am using the browser Mozilla Firefox.

124

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic