WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] .jpg files don't generate thumbnails (10 posts)

  1. n44ps
    Member
    Posted 1 year ago #

    Hello everyone,

    I'm currently working on a website and I'm using two plugins :

    Post thumbnail editor
    Simple Image Size

    I added some image size to my functions.php file and I forced them to be inserted into posts. With Post thumbnail editor I can crop and make my thumbnail looks different for each size.
    My trouble is that somehow the .jpg file I'm uploading can't be modified with the plugin. I searched and found out that their thumbnails was not generated within the /uploads folder and therefore the plugin can't crop unexisting pictures.

    I can upload and generate thumbnails with .png files
    I can upload .jpg file but no thumbnail generated

    There's no difference between small/big images size

    Any idea ?

    Thank you

  2. Cena Plynu
    Member
    Posted 1 year ago #

    Hi, is your safe_mode ON on server? I have similar problem while I had safe_mode set to OFF.

  3. n44ps
    Member
    Posted 1 year ago #

    Thanks for your answer,

    This is the case, I checked the safe mode with phpinfo(); and I have :

    ...
    safe_mode Off Off
    safe_mode_exec_dir no value no value
    safe_mode_gid Off Off
    safe_mode_include_dir no value no value
    ...

    Can I handle the issue with an htaccess ?

  4. Yui
    Member
    Posted 1 year ago #

    does phpinfo() show that you have GD extension and JPEG support in GD?

    ps: you can check your php error_log (or enable showing errors to display)
    if there is a problem

  5. n44ps
    Member
    Posted 1 year ago #

    It does :

    GD Support enabled
    GD Version bundled (2.0.34 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    FreeType Version 2.4.2
    T1Lib Support enabled
    GIF Read Support enabled
    GIF Create Support enabled
    JPG Support enabled
    PNG Support enabled
    WBMP Support enabled
    XPM Support enabled
    XBM Support enabled

    I don't know where I could find this log in my FTP :/

  6. n44ps
    Member
    Posted 12 months ago #

    Hello again,

    I've been searching a while but still no answer. My hosting provider told me I should get a better "offer" but I can't really do that. Is there an other way around ?

  7. esmi
    Forum Moderator
    Posted 12 months ago #

    A better offer of what?

  8. n44ps
    Member
    Posted 12 months ago #

    By "a better offer" I meant a better subscription, more expensive.

  9. n44ps
    Member
    Posted 12 months ago #

    I forgot to tell you that the previous WordPress was installed by my host provider OVH.
    I tried to reinstall an other WordPress on my own just to check the problem really comes from the server. A few minutes after I could upload images and have their thumbnails generated, so it's not the server but maybe the way it was installed (Permissions ?).

    My problem is resolved for now,

    Thanks all !

  10. n44ps
    Member
    Posted 12 months ago #

    Edit : I'm an idiot, a plugin called "Media features" was blocking the generation of thumbnails. I desactivated it and everything's ok !

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.