WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] jpegtran : Update available (20 posts)

  1. polkade
    Member
    Posted 1 year ago #

    I have the message "jpegtran : Update available" even if I manually put the file in the folder. Where can I find the last version of jpegtran ? The link "manually" seems not deliver the right version...

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

  2. polkade
    Member
    Posted 1 year ago #

    Sorry, I've forgotten. The plugin says I have this version : Independent JPEG Group's JPEGTRAN, version 8b 16-May-2010

  3. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have optipng and gifsicle enabled and installed? Can you post the entire plugin status, and the debug info (Use the Debug link near the top of the settings page).

  4. polkade
    Member
    Posted 1 year ago #

    yes absolutely. This is the Plugin Status :

    jpegtran: UPDATE AVAILABLE* Install automatically | manually version: Independent JPEG Group's JPEGTRAN, version 8b 16-May-2010
    optipng: OK version: OptiPNG version 0.7.4
    gifsicle: OK version: LCDF Gifsicle 1.68
    Graphics libraries (only used for conversion, not optimization): GD: OK   Imagemagick 'convert': OK
    safe mode: Off  exec(): OK  shell_exec(): OK  
    Only need one of these: finfo: MISSING  getimagesize(): OK  mime_content_type(): MISSING
    Debug Info

    jpegtran path: jpegtran
    optipng path: /homepages/35/d279464009/htdocs/wp-content/ewww/optipng
    gifsicle path: /homepages/35/d279464009/htdocs/wp-content/ewww/gifsicle
    pngout path:
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0755

    Operating environment: Linux infong 2.4 #1 SMP Fri May 18 17:32:59 UTC 2012 i686 GNU/Linux Linux infong 2.4 #1 SMP Fri May 18 17:32:59 UTC 2012 i686 GNU/Linux Linux infong 2.4 #1 SMP Fri May 18 17:32:59 UTC 2012 i686 GNU/Linux Linux infong 2.4 #1 SMP Fri May 18 17:32:59 UTC 2012 i686 GNU/Linux

  5. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    I would suspect that the jpegtran binary is compiled on a system that is too new for your server to run. I'll look into bundling that with the plugin in the future to see if I can compile one that is better supported than the one from jpegclub.org. I'm honestly a little surprised that gifsicle and optipng even run on that kernel. I haven't seen a 2.4 kernel in almost 10 years. Do you mind sharing who your webhost is?

  6. polkade
    Member
    Posted 1 year ago #

    Thanks for your reply. My webhost is 1&1.

  7. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Try using this one: http://www.shanebishop.net/uploads/jpegtran

    While the one from ijg.org was compiled for an older kernel, it was also dynamically linked, whereas I use static linking on all the tools I bundle with the plugin, so hopefully that does the trick.

  8. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    ah, forgot to mention also, you'll need to rename it as 'jpegtran-custom' when you upload it, or will still fail the validation routines

  9. polkade
    Member
    Posted 1 year ago #

    sorry, but it still does not work. I downloaded jpegtran by renaming jpegtran-custom then put on my server. I also tried to rename jpegtran but nothing works. I always version 8b 16 may 2010. Is that I missed a step?

  10. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have shell access on your server?

    If so, try these commands via shell/ssh:

    /homepages/35/d279464009/htdocs/wp-content/ewww/jpegtran-custom -v
    /homepages/35/d279464009/htdocs/wp-content/ewww/jpegtran -v

    It will stall out there waiting for an image, but you can press Ctrl+C to kill the process after it outputs version information, although likely it will spit out some error message and then die.

    If not, you can create a php file with this code, and paste the output here:

    <?php
    echo shell_exec('/homepages/35/d279464009/htdocs/wp-content/ewww/jpegtran-custom -v 2>&1');
    echo shell_exec('/homepages/35/d279464009/htdocs/wp-content/ewww/jpegtran -v 2>&1');
    ?>
  11. polkade
    Member
    Posted 1 year ago #

    I have shell access on my server but when I entered your orders, the access is denied. I think I get the same thing with a php file because it is the access to the directory that is denied...

  12. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Aha, that is a different issue then. You probably need to make it 'executable'. If you do this from the shell:

    ls -l /homepages/35/d279464009/htdocs/wp-content/ewww/jpegtran

    what do you get?

  13. polkade
    Member
    Posted 1 year ago #

    I have the message "-rw-r--r-- 1 u52737577 ftpusers 433626 Feb 3 10:42 /homepages/35/d279464009/htdocs/wp-content/ewww/jpegtran"

  14. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    ok, that's what I thought you might see. There will be a fix in the next version to check for missing permissions on jpegtran, so thank you for reporting this bug.
    That said, here's how you can fix it right now:

    chmod a+x /homepages/35/d279464009/htdocs/wp-content/ewww/jpegtran

  15. polkade
    Member
    Posted 1 year ago #

    it does not seem to work ... typing this command in shell, nothing happens.

  16. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    There is no output from that command if you typed it right. If it works, the results of the ls -l command should then contain something like '-rwxr-wr-x' -- note the three x's, those mean executable.

  17. polkade
    Member
    Posted 1 year ago #

    Yes it works : I have the result '-rwxr-xr-x'. But the plugin always says "jpegtran : Update available" and I always have version 8b 16-May-2010 ... Why ?

  18. konehead
    Member
    Posted 1 year ago #

    I cannot seem to get the update to work. Any ideas?
    Otherwise I think it is working for JPEGs, right?

    Plugin Status

    If updated versions are available below, you may need to enable write permission on the wp-content/ewww folder to use the automatic installs.
    *Updates are optional, but may contain increased optimization or security patches
    jpegtran: UPDATE AVAILABLE* Install automatically | manually version: Independent JPEG Group's JPEGTRAN, version 6b 27-Mar-1998
    Graphics libraries (only used for conversion, not optimization): GD: OK   Imagemagick 'convert': OK
    safe mode: Off  exec(): OK  shell_exec(): OK  file command not found on your system
    Only need one of these: finfo: MISSING  getimagesize(): OK  mime_content_type(): MISSING

    Debug Info

    jpegtran path: jpegtran
    optipng path:
    gifsicle path:
    pngout path:
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0755
    user: mrkonehead
    Operating environment: Linux 2.6.18-238.19.1.el5PAE #1 SMP Fri Jul 15 08:15:44 EDT 2011 i686

  19. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    konehead:
    Yes, it is working. If all you are concerned about is JPGs, you should be just fine. It's entirely possible that your webhost has disabled the ability to run executables in your web folder. You may want to ask them that, it would be useful for me to know if webhosts are doing that on purpose.

  20. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    polkade, what do you get when you run this:

    /homepages/35/d279464009/htdocs/wp-content/ewww/jpegtran-custom -v

    also, then try this:
    whereis jpegtran

    which should tell you where 1and1 has installed jpegtran, then put that path in this command:
    ldd /path/to/jpegtran

    on my system, that would look like this, but yours may be different:
    ldd /usr/bin/jpegtran

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic