WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] Jpegtran Problem (19 posts)

  1. Lewebmaster
    Member
    Posted 1 year ago #

    Hi,

    First of all thank you for that great plugin !
    I'm having an issue with Jpegtran. Since the last update (2013-3-19), i'm getting this message :

    jpegtran: MISSING Copy executable from /homez.577/lesgoute/www/wp-content/plugins/ewww-image-optimizer/jpegtran-linux64 to /homez.577/lesgoute/www/wp-content/ewww/jpegtran or a system path (like /usr/local/bin), OR Download jpegtran source

    http://www.shanebishop.net/uploads/jpegtran-linux64

    I've downloaded your http://www.shanebishop.net/uploads/jpegtran-linux64 and put it in the wp-content/ewww/ folder, and name it jpegtran-custom and it didn't work. I've also changed the writing permission and still nothing.

    Debug Info

    jpegtran path:
    optipng path: /homez.577/lesgoute/www/wp-content/ewww/optipng
    gifsicle path: /homez.577/lesgoute/www/wp-content/ewww/gifsicle
    pngout path:
    disabled functions:
    jpegtran permissions: 0755
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0777
    user: lesgoute
    Operating environment: Linux 3.2.2-grsec-mutu-grs-ipv6-64 #1 SMP Thu Jan 26 14:55:34 UTC 2012 x86_64

    Thank you for your help.

    Kindly.

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    If you uploaded it via FTP, you need to make sure you are transferring it in binary (BIN) mode, or else the file will get corrupted. Everything else looks good, so that would be my suspicion, as it has happened to several other folks.

    Nearly forgot, I was going to ask if you have anyway to check the md5sum of the file you uploaded?

  3. Lewebmaster
    Member
    Posted 1 year ago #

    Hey !
    Thanks for the quick answer. I uploaded it in binary mode but still get the same message

    ebug Info
    
    jpegtran path:
    optipng path: /homez.577/lesgoute/www/wp-content/ewww/optipng
    gifsicle path: /homez.577/lesgoute/www/wp-content/ewww/gifsicle
    pngout path:
    disabled functions:
    jpegtran permissions: 0755
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0777
    user: lesgoute
    Operating environment: Linux 3.2.2-grsec-mutu-grs-ipv6-64 #1 SMP Thu Jan 26 14:55:34 UTC 2012 x86_64

    Also i cannot check the md5sum of the file.

    Any ideas ?

    Thanks

  4. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, just released 1.4.0 (finally) this morning. Give that a whirl, and then paste the debug info if it still isn't working.

  5. Lewebmaster
    Member
    Posted 1 year ago #

    Hi mate !
    I just did the update and still not working :p

    Debug Info
    
    jpegtran path:
    optipng path: /homez.577/lesgoute/www/wp-content/ewww/optipng
    gifsicle path: /homez.577/lesgoute/www/wp-content/ewww/gifsicle
    pngout path:
    disabled functions:
    bundled jpegtran permissions: 0755
    bundled gifsicle permissions: 0755
    bundled optipng permissions: 0755
    wp-content/ewww permissions: 0777
    jpegtran checksum: 4da4092708650ceb79df19d528e7956b
    gifsicle checksum: 44273fad7b3fd1145bfcf35189648f66
    optipng checksum: 4eb91937291ce5038d0c68f5f2edbcfd
    pngout checksum:
    user: lesgoute
    Operating environment: Linux 3.2.2-grsec-mutu-grs-ipv6-64 #1 SMP Thu Jan 26 14:55:34 UTC 2012 x86_64

    Here's a screen of my eww folder after the update :

    Cheers mate !

  6. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    If you copy the regular jpegtran-linux (non 64-bit) file over to the wp-content/ewww/ folder and name it jpegtran-custom, what does it do?

    And just so I'm clear, has jpegtran ever worked for you?

  7. Lewebmaster
    Member
    Posted 1 year ago #

    I just did and still missing on the debug.
    And yes, jpegtran was working right before your update (the one before).
    Any ideas ?

  8. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    The old version was here: http://jpegclub.org/droppatch.v9.tar.gz
    You'll need to extract that, and upload the jpegtran file to wp-content/ewww and name it jpegtran-custom (so it doesn't get overwritten).
    Let me know if that works, because I'll want to investigate what they are doing to get a 'better' binary than what I'm able to do (they should know, since they are the ones developing it).

  9. Lewebmaster
    Member
    Posted 1 year ago #

    Just did but still missing...

  10. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    so that points to something else in the code, you may need to revert to 1.3.8 for the time being, as I may not be able to work on the issue until next Monday.

  11. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    If you could try something else for me over the next couple days, that would be helpful also:

    Re-install 1.3.8 of the plugin, DON'T use the automatic jpegtran installer (if you already did, then delete jpegtran from the wp-content/ewww/ folder) Then download the 64-bit version of jpegtran from http://www.shanebishop.net/uploads/jpegtran-linux64 and upload it as jpegtran-custom like you did before, and see if it works.

  12. Lewebmaster
    Member
    Posted 1 year ago #

    Ok mate here's what i did :
    I uninstalled the 1.4 version and deleted all the eww folder in my directories and reinstalled the 1.3.8 version. I had this message :

    I did it automacally and it worked fine.

    I reuninstalled the 1.3.8 ver for the 1.4.0 vers (also deleted all the folder) but i didn't get this message anymore, it directly says that Jpegtran is missing.

  13. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, so 1.3.8 with the automatic install worked fine, that is good, at least we have a case that works properly.

    The one thing I didn't see from your last post is this:

    Can you install 1.3.8, and instead of doing the 'automatic' jpegtran install, download the 64-bit version of jpegtran from http://www.shanebishop.net/uploads/jpegtran-linux64 and upload it as jpegtran-custom like you did before, and see if it works with 1.3.8 of the plugin?

    Please show the full status and debug block in your screenshot if it does work, so I can confirm a couple things.

  14. Lewebmaster
    Member
    Posted 1 year ago #

    Ok,
    I did exactly as you asked but here's the problem : After i uploaded the jpegtran-custom file the eww folder (i used the 1.3.8 vers.), the plugin doesn't realise it... even if i click on the save button, or refresh the settings page, i still have the same message :

    jpegtran: MISSING Install automatically | manually
    optipng: OK version: OptiPNG version 0.7.4
    gifsicle: OK version: LCDF Gifsicle 1.68
    Graphics libraries (only used for conversion, not optimization): GD: OK   Imagemagick 'convert': OK
    safe mode: Off  exec(): OK  shell_exec(): OK  
    Only need one of these: finfo: MISSING  getimagesize(): OK  mime_content_type(): MISSING
    Debug Info
    
    jpegtran path:
    optipng path: /homez.577/lesgoute/www/wp-content/ewww/optipng
    gifsicle path: /homez.577/lesgoute/www/wp-content/ewww/gifsicle
    pngout path:
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0705
    user: lesgoute
    Operating environment: Linux 3.2.37-uid-limit2-mutu-grs-ipv6-64 #1 SMP Sun Jan 27 07:40:58 CET 2013 x86_64
  15. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, one last thing I need you to try. Install 1.4.0 again, and copy the bundled jpegtran-linux binary (not 64-bit) to wp-content/ewww/jpegtran-custom

    Make sure the permissions are set to 755 (world-executable and readable, owner-writable), and see what happens.

  16. Lewebmaster
    Member
    Posted 1 year ago #

    Hey mate,

    Just did EXACTLY as you said, but still missing the jpegtran :

    Plugin Status
    
    If updated versions are available below, you may need to enable write permission on the wp-content/ewww folder to use the automatic installs.
    *Updates are optional, but may contain increased optimization or security patches
    
    jpegtran: MISSING Copy executable from /homez.577/lesgoute/www/wp-content/plugins/ewww-image-optimizer/jpegtran-linux64 to /homez.577/lesgoute/www/wp-content/ewww/jpegtran or a system path (like /usr/local/bin), OR Download jpegtran source
    optipng: OK version: OptiPNG version 0.7.4
    gifsicle: OK version: LCDF Gifsicle 1.70
    Graphics libraries - only need one, used for conversion, not optimization: GD: OK   Imagemagick 'convert': OK
    safe mode: Off  exec(): OK  
    Only need one of these: finfo: MISSING  getimagesize(): OK  mime_content_type(): MISSING
    Debug Info
    
    jpegtran path:
    optipng path: /homez.577/lesgoute/www/wp-content/ewww/optipng
    gifsicle path: /homez.577/lesgoute/www/wp-content/ewww/gifsicle
    pngout path:
    disabled functions:
    bundled jpegtran permissions: 0755
    bundled gifsicle permissions: 0755
    bundled optipng permissions: 0755
    wp-content/ewww permissions: 0755
    jpegtran checksum: 4da4092708650ceb79df19d528e7956b
    gifsicle checksum: 44273fad7b3fd1145bfcf35189648f66
    optipng checksum: 4eb91937291ce5038d0c68f5f2edbcfd
    pngout checksum:
    user: lesgoute
    Operating environment: Linux 3.2.37-uid-limit2-mutu-grs-ipv6-64 #1 SMP Sun Jan 27 07:40:58 CET 2013 x86_64
  17. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    I went back to that screenshot you attached towards the beginning, and realized the permissions weren't set properly on the jpegtran-custom file when you uploaded it. I think we've pretty well established that your system doesn't like the 64-bit binary for some weird reason, since the plugin itself takes care of permissions when it auto-installs that one.

    And my instructions included the correct permisions when you tested the 32-bit bundled binary at wp-content/plugins/ewww-image-optimizer/jpegtran-linux

    So, it seems we need to re-check the original binary from http://jpegclub.org/droppatch.v9.tar.gz. Extract it, upload the file named 'jpegtran' in Binary mode as jpegtran-custom, and make sure permissions are set to 755. Please do this with version 1.4.0 of the plugin.

    If that still doesn't work, could you set me up with a test wordpress install on your host, and send the login details via my website: http://www.shanebishop.net/contact-me/

    That way I can attempt to pin-point what exactly is going wrong with your particular setup.

  18. Lewebmaster
    Member
    Posted 1 year ago #

    Hey Mate,

    Still not working after all these instructions.
    Sent you an email on your page.

    Cheers mate.

  19. Lewebmaster
    Member
    Posted 1 year ago #

    Can't send the email on your page, the captcha doesn't show :p

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic