WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack & WP Stats timezone issues (8 posts)

  1. Zhou
    Member
    Posted 3 years ago #

    Some weeks ago wordpress.com stats ceased to work all of a sudden, then some said that downloading jetpack (which got a WP stats included) will solve the problem. After a while the original WP.com stats was back again. Nevertheless I downloaded jetpack and sticked with it, coz I feel it's working fine and it has other features.

    But there is one problem with the timezone. I didn't have this problem with the old WP stats, I am in Singapore and my time zone is GMT +8, the stats in jetpack seems to adopt the US time zone and there is no way I could change it. So I only get the next day's stats long after passing 12 AM (I think I only get it in the afternoon). Any way to rectify this? Thanks.

  2. Please try changing your timezone in the Settings section of your Dashboard to something else, than change it back and let us know if that has improved the situation.

  3. ghep
    Member
    Posted 3 years ago #

    James is right! Here are some more specific instructions for those who might be reading this, wondering how to do it.

    1. Go to Settings > General in your blog’s Dashboard.
    2. Go to Timezone and set the time zone to another location. Click “Save Settings”.
    3. Go to Timezone and set the time zone back to your current location. Click “Save Settings”.

    For the full instructions with pictures visit my blog post about this issue at: http://dtacconelli.com/blog/wordpress-stats-timezone-fix/

  4. Byeka
    Member
    Posted 2 years ago #

    Hi, I'm having the same problem with my blog except my timezone IS configured correctly. I have it set to local Toronto time, but Jetpack's stats are 5 hours ahead! Any idea on how to fix?

  5. EatWatchRun
    Member
    Posted 2 years ago #

    Byeka - I had the same problem. I installed Jetpack when my timezone was incorrect, and I think it kept those settings. So, I deactivated and then reactivated Jetpack and that worked for me. Hope this helps!

  6. CmdrKeene
    Member
    Posted 2 years ago #

    Just wanted to give some feedback. My issue was apparently identical to EatWatchRun -- and de-activating/re-activating JetPack solved it perfectly for me as well. Thanks!

  7. Arilena
    Member
    Posted 2 years ago #

    More feedback

    I have the same issue althought I started recentrly with wordpress.org so I instaled directly jetpack. Since a few days ago I was having the problem and site stats were wrong (I'm at Madrid UCT +2 summer time and the site stats showed UCT time)

    I trided changing the timezone but It was correct. Then I did the same as shawn.keene and EatWatchRun and it worked.
    Thanks!

  8. Byeka
    Member
    Posted 2 years ago #

    Oops, I should have replied here a while back. EatWatchRun's solution did work for me as well! Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic