WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Jetpack WP 1.9 & WPSEO 1.2.8.7 Conflict (13 posts)

  1. SurveillanceTips
    Member
    Posted 1 year ago #

    I just installed WordPress 3.4.2 and WordPress SEO version 1.2.8.7.

    Suddenly every entry in the Title and Description of WordPress SEO became blank.

    After trying uninstall and install of my plugins, I found that Jetpack by WordPress.com version 1.9 conflict with WordPress SEO.

    See images.
    Jetpack + WPSEO Enabled:

    WPSEO Results:

    Jetpack Disabled:

    WPSEO + Other plugins:

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. martinremy
    Member
    Posted 1 year ago #

    @surveillancetips, thanks for the detailed report. Unfortunately, I can't reproduce the issue, I have the same versions of WordPress SEO and Jetpack installed as you and the WPSEO Titles & Metas page is working for me.

    Did you have previous versions of Jetpack and WordPress SEO installed?

    In spite of having the same version, the WordPress SEO Titles & Metas page looks slightly different here (no "WordPress SEO comes alive message" and no solid line underneath the tabs): http://cl.ly/image/2j12371m2j3C

  3. SurveillanceTips
    Member
    Posted 1 year ago #

    Martinremy, I'm sorry I should have mentioned it, I placed the red text on the images as annotations, the "come alive" and others.
    I have the 3 versions mentioned in my post. I'm not sure why it's happening but I've disabled Jetpack for now.

  4. memuso.com
    Member
    Posted 1 year ago #

    SurveillanceTips ist right.

    After I updated Jetpack to Version 1.9 the WordPress SEO plugin from Yoast (1.2.8.7) is not working anymore.

    I can't edit title and description in my articles.

    There is a conflict between SEO (1.2.8.7) and Jetpack 1.9.

    I run WordPress 3.4.2 if this helps.

  5. SurveillanceTips
    Member
    Posted 1 year ago #

    Good observation memuso. I was begining to think I did something wrong. I also run same WordPress version 3.4.2
    I'm beginning to think it's a bad idea to install updates as soon as it's available. Maybe 2 or 3 weeks after updates might make sense.

  6. martinremy
    Member
    Posted 1 year ago #

    @surveillancetips sorry, I thought that text was coming from the plugin, wanted to make sure we're using the same one. I confirmed I'm running the same versions, also on WP 3.4.2, and still not seeing the issue, but I've asked some others to test the same setup. Please stay tuned.

  7. Pedro
    Member
    Posted 1 year ago #

    Hey guys,

    I ran into the same issue and I confirm that disabling JetPack made WP SEO work. After digging a bit into this, I found out that resources from this kind of links are not loaded:

    https://s1.wordpress.com/wp-content/js/backbone.js?ver=201243
    https://s1.wordpress.com/wp-includes/js/jquery/jquery.spin.js?ver=201243
    https://s1.wordpress.com/wp-content/js/mustache.js?ver=201243
    https://s1.wordpress.com/wp-content/js/underscore.js?ver=201243

    causing the WP SEO plugin blank page. There seems to be some issue with the certificate used for serving these links as you get a certificate error while trying to access them.

    Another behavior I noticed is that on the post edit screens, the WP SEO menu is collapsed and cannot be expanded.

    My expertise regarding certificates is limited and I hope this helps in finding a fix for it.

  8. martinremy
    Member
    Posted 1 year ago #

    Thanks everyone who's reported this issue, we've found the cause and are working on an a new release for Monday to fix this. The reason I didn't see it on my site is that it occurs when using the admin over SSL. There are two possible workarounds if you would like to re-activate Jetpack right away to keep tracking stats:

    1) De-activating the Notifications module within Jetpack should get rid of this error. (Click on "Learn More" under Notifications, then deactivate).

    2) Use the admin over http:// instead of forcing SSL

  9. SurveillanceTips
    Member
    Posted 1 year ago #

    Yes Martinremy, disabling Jetpack notification solves the problem. Thanks

  10. Jeff Bowen
    Member
    Posted 1 year ago #

    Hi all:

    We've just released Jetpack 1.9.1 to address this issue. SurveillanceTips (and others affected), when you get a chance, can you please upgrade, reactivate the Notifications Module, & report back any successes / further issues?

    Thanks very much for your reports :)
    Best,
    ~Jeff

  11. charles_i
    Member
    Posted 1 year ago #

    I'm having the same problem with All In One SEO pack or Ultimate SEO - as soon as I activate either of these with Jetpack I get a blank Plugins screen. I have delete them via FTP. And, yes I just installed the Jetpack 1.9.2 release from Oct. 30th and deactivated Jetpack - it didn't make any difference.

    Charles

  12. charles_i
    Member
    Posted 1 year ago #

    Update. Having all kinds of problems with conflicts with other plugins. Attempts to activate jetpack with other plugins like google analytics, wordpress SEO, social-metrics, etc. creates a blank screen - very annoying. I've uploaded and deleted it countless times over the last 2 days.

    Charles

  13. charles_i
    Member
    Posted 1 year ago #

    I found the answer here:

    To summarize: j_simon said in the above post:

    older servers with ubuntu have a default of 16MB, newer of 32MB, and jetback seems to overrun that now. Usually setting the memory_limit variable to something higher should work...

    I sent his error log to my service and they responded:

    You are correct in your assumption, I am seeing similar php memory errors in your error_log: I have added a vhost.conf file for the blog subdomain to raise the memory limit to 64 MB.

    Charles

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags