WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Jetpack Subscriptions not working (10 posts)

  1. biblyotheke
    Member
    Posted 9 months ago #

    Hey there -

    Sometime last spring I moved from Dreamhost to another provider, in which I did a clean install of WordPress on the new provider and reconnected my Jetpack account to WordPress.com. Everything seems to be working peachy keen EXCEPT Jetpack Subscriptions and Jetpack Contact form. I could not find explicit documentation on configuring the backend (such as php mail or sendmail), but we have verified that php mail/sendmail IS working with another contact form (which is currently installed) or any of my domain generated emails like password resets/new user accounts and the like.

    For the Jetpac Subscriptions, if someone adds their email address, there is no confirmation page nor is a confirmation email sent. I've had myself and others test this and it's the same for everyone. Help?

    Thanks!
    Lisa

    http://wordpress.org/plugins/jetpack/

  2. biblyotheke
    Member
    Posted 9 months ago #

    Just realised i did NOT add my domain: http://exitpursuedbyabear.net

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    Everything seems to be working peachy keen EXCEPT Jetpack Subscriptions and Jetpack Contact form.

    When you submit a contact form, do you see it appear under the Feedback menu in your dashboard?
    If not, could you post a link to a test form so I can run some tests?

    For the Jetpack Subscriptions, if someone adds their email address, there is no confirmation page nor is a confirmation email sent.

    I also tested your subscription form, and I don't seem to be able to submit the form after entering my email address. Do you use any redirection plugins, or did you set up custom rules in your site's .htaccess that may break plugins adding extra parameters to URLs on your site? If so, could you try to disable such plugins, and try to subscribe to your site again?

    Thanks!

  4. biblyotheke
    Member
    Posted 9 months ago #

    When you submit a contact form, do you see it appear under the Feedback menu in your dashboard?

    No. I've tested this several times since the summer and just had a few people test it for me right now and nothing is showing up in the Feedback menu.

    If not, could you post a link to a test form so I can run some tests?

    https://exitpursuedbyabear.net/contact/

    Do you use any redirection plugins

    I'm running Redirection for 301s from when my site had a different domain many years ago, and this has now been deactivated. I also have SSL set up on my domain and have the WordPress HTTPS plugin. This plugin is apparently the only way to manage SSL via WordPress so I would like to try not to have to deactivate it but if need to for testing, I will.

    or did you set up custom rules in your site's .htaccess that may break plugins adding extra parameters to URLs on your site?

    Running on Nginx, so no .htaccess. There is nothing explicit for this specific domain to block plugin URL rewrites, but will say "possibly" until I exactly what the plugin needs to do for url rewrites.

    Thanks!

    Lisa

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    https://exitpursuedbyabear.net/contact/

    Thanks! I tried to submit a test form, and the problem seems to be similar to the Subscription widget: the forms don't get submitted properly.

    Could you post a list of all active plugins on your site at the moment?

    Thanks!

  6. biblyotheke
    Member
    Posted 9 months ago #

    Hi there!

    Could you post a list of all active plugins on your site at the moment?

    ACTIVE
    Akismet
    All In One SEO Pack
    Breadcrumb NavXT
    Broken Link Checker
    Disqus Comment System
    Google Analytics for WordPress
    Google XML Sitemaps
    iframe
    Jetpack by WordPress.com
    Link Manager
    List category posts
    LiveJournal Crossposter
    MediaElement.js - HTML5 Audio and Video
    Organize Series
    Smart Archives Reloaded
    TablePress
    WordPress HTTPS
    Word Stats

    The three newest plugins installed are Word Stats, Organize Series, and Smart Archives Reloaded which have all be loaded within the last four months, though to be fair the problem started beforehand. The others are ones I've used for years.

    INACTIVE

    Clean and Simple Contact Form [I've used this to replace the Jetpack Comment form and it works]
    Collapsing Archives
    Official StatCounter Plugin
    Perfect Quotes
    Redirection [Deactivated yesterday per your request]
    WordPress Importer
    WP-Print
    Zotpress

    With deactivated plugins, if I choose to stop using one, I usually hold on to it to make sure I no longer need it for say a month or so. Then I delete it. But I haven't done that in a few months so many of these have been hanging out for ages.

    Thanks!
    -lisa

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    I don't think any problematic plugin in that list. Do you think you could deactivate the HTTPS plugin for a few minutes and test the contact form again, just to make sure the problem is not linked to a conflict with that plugin?

    Thanks!

  8. biblyotheke
    Member
    Posted 9 months ago #

    Do you think you could deactivate the HTTPS plugin for a few minutes and test the contact form again, just to make sure the problem is not linked to a conflict with that plugin?

    I deactivated the plugin and the contact form AND email subscription now work!

    Can you also test please?

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    Yep, both forms work now. I was able to submit a test contact form (nothing interesting, you can delete it :) ), and I just subscribed to your site.

    I'll run some more tests to try to understand and fix this conflict between the 2 plugins. I'll get back to you as soon as I have some news.

  10. biblyotheke
    Member
    Posted 9 months ago #

    I'll run some more tests to try to understand and fix this conflict between the 2 plugins. I'll get back to you as soon as I have some news.

    Huzzah! I'm glad we at least figured out what the problem was, I was going insane!

    I'll leave the plugin deactivated since it doesn't seem to hamper my actual SSL access.

    Thanks so much!

    -lisa

Reply

You must log in to post.

About this Plugin

About this Topic