WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Jetpack Stats not working (42 posts)

  1. foodiebuddha
    Member
    Posted 2 years ago #

    I just upgraded to the latest jetpack. Since I upgraded, my stats option is gone. If I go to the jetpack dashboard, I see the configuration and can save changes, but that's it. The stats menu is gone, the stats box on the toolbar is gone, and I'm stumped. The url DOMAIN/wp-admin/admin.php?page=stats now gives me a "You do not have sufficient permissions to access this page." message.

    Any ideas?

  2. Lee
    Member
    Posted 2 years ago #

    You need to disable and re-enable the plugin then reconnect with WordPress. However, though the stats menu will again be visible, you might still suffer the permissions issue when trying to view stats. I know this because I'm suffering the same problem since today's update.

    If you have strong rewrite rules in your htaccess file you might need to whitelist the WordPress servers to permit the plugin to connect with wordpress.com for registration. I'll give you the details if you need them.

  3. foodiebuddha
    Member
    Posted 2 years ago #

    thanks, I had already tried disabling and that did not help.

    I would love some details on the whitelisting you mentioned! Thanks for the help!

  4. Lee
    Member
    Posted 2 years ago #

    I think we'll need an update before we can again view the stats page. The final bar in the little graph in my admin bar still seems to be growing so the plugin's probably working even though I can't view the admin page.

    Place these whitelist rules above your .htaccess rewrites to whitelist the wordpress.com servers:

    RewriteCond %{REMOTE_ADDR} !74\.200\.244\.
    RewriteCond %{REMOTE_ADDR} !76\.74\.248\.
    RewriteCond %{REMOTE_ADDR} !66\.135\.48\.
    RewriteCond %{REMOTE_ADDR} !69\.170\.134\.

    There might be other IP addresses too. If there are, I'd love to know.

  5. studio544
    Member
    Posted 2 years ago #

    I have had the same issue since yesterday with some of my sites after installing the latest Jetpack upgrade. I seem to be getting partial information on the site stats page but the bars and graphs are gone. It appears unable to connect properly. Since I manage multiple sites, I will NOT be upgrading this again until they have the issue resolved as I have no idea what you are referencing with the .htaccess rewrites. Where would I this within WordPress? Thanks. Hopefully enough people will complain about the issue to force them to fix the issue ASAP.

  6. rodtrent
    Member
    Posted 2 years ago #

    Same issue here, but this morning (after deactivating and activating), it will not connect to WordPress.com at all to enable the components.

  7. Lee
    Member
    Posted 2 years ago #

    The latest version released overnight has fixed the issue for me. The new version is 1.2.1.

    For those with connection/authentication issue, either whitelist the WordPress servers in your .htaccess file rewrite/firewall directives using the rules in my above post OR temporarily remove any directives in your .htaccess file that are not essential for WordPress to function e.g keep "DirectoryIndex index.php" at the top and keep "## BEGIN WORDPRESS", "## END WORDPRESS" and the bits between the WordPress block then authenticate then replace the bits removed from your .htaccess file (put them back where you found them).

  8. foodiebuddha
    Member
    Posted 2 years ago #

    Thanks for all the help everyone. The latest update did fix the problem.

  9. Lee
    Member
    Posted 2 years ago #

    You're welcome and I'm glad it's fixed for you too.

  10. studio544
    Member
    Posted 2 years ago #

    It's still not working for me. I installed the latest update of 1.2.1 but the stats are not working. Do I still need to screw around with the .htaccess file besides the update or should I disable/remove Jetpack and reinstall it? I thought the update would have fixed the issue on its own. Thanks.

  11. Tim Moore
    Moderator
    Posted 2 years ago #

    @studio544: could you provide more details on exactly what is going wrong for you? If you could also follow the guidelines here and provide some of the information requested, it would be very helpful.

    Thanks,

    Tim

  12. studio544
    Member
    Posted 2 years ago #

    Sorry, I just got back. I am using IE8 but also tested it in Firefox with same results. The site is hosted by Host Monster. Worpress version 3.2.1. Everything was working fine for me until I installed the Jetpack update as reported earlier. What's happening when I go to view the stats is that the WordPress animated "loading" logo spins and spins but never loads the usual bar graphs. I can see the other stats below like Referrers, Top Posts, Search Engine Terms, Clicks but it's all jumbled up like the CSS is no longer connected to it. Is everyone else still seeing the bar graphs?

  13. SJDankoSF
    Member
    Posted 2 years ago #

    I'm having pretty much the same problem. The WordPress animated "loading" logo spins and spins but the bar graphs never load. I can see the usual stats below.

  14. jschwartz63
    Member
    Posted 2 years ago #

    Site stats for 1.2.1 still not working. Using diffrent themes (Standard Theme) and (EVolve Theme) on two different self-hosting acounts at Bluehost. When 1.2 came out and did not work I rolled back to 1.1.3 wothout any problems. Dissapointing to say the least. Even with 1.2.1 the stats page shows but the bar chart does not appear. Only the revolving 'W' shows.

  15. Tonglil
    Member
    Posted 2 years ago #

    I also have an issue with Jetpack.
    For some reason the stats say: We were unable to get your stats just now. Please try again.
    It has been around for over 2 weeks now.

  16. yogarose
    Member
    Posted 2 years ago #

    I am new to WordPress.org Forums so I apologize if I'm being redundant or asking an obvious question. Like everyone here, I have updated the latest Jetpack and get this error message when I click on "blog subscriptions" on the site states page: "We were unable to get your stats just now. Please try again." Seems like the last post on this forum was a week ago. Is everyone still waiting for a resolution? Thanks so much!

  17. yogarose
    Member
    Posted 2 years ago #

    I tried it again this morning and it works. So is it spotty and I just have to put up with it, or was that a one-time glitch?

  18. yogarose
    Member
    Posted 2 years ago #

    Sorry, one last thing! The page now shows the emails of those who subscribe, but the option to download all as CSV is not appearing.

  19. Nalates
    Member
    Posted 2 years ago #

    I have 3.2.1 and Jetpack 1.2.2 - Vista 32 Chrome and hosted on GoDaddy.

    I installed Jetpack 2 may be 3 weeks ago. It worked for a week or so. For the last week it says: We were unable to get your stats just now. Please try again.

    It fails on the dashboard and Site Stats. It fails in Chrome and Firefox.

    I've deactivated, reactivated... no luck.

  20. jonto
    Member
    Posted 2 years ago #

    I updated WordPress to version 3.3. I'm not sure when my issues started, but now the Jetpack stats no longer render. I get the spinning W like a few others on this site. I deactivated and reactivated the plugin, but still have the issue.

  21. txauctionsinfo
    Member
    Posted 2 years ago #

    jonto
    I'm having a similar problem since upgrading to 3.3 (&Jetpack 1.2.2) and have also deactivated, reactivated, as well as deleted and reinstalled Jetpack. The only thing I'm getting is the "We were unable to get your stats just now. Please try again." as reported by others above.

    There's also another thread concerning this issue at:
    http://wordpress.org/support/topic/plugin-jetpack-by-wordpresscom-stats-no-longer-appearing?replies=7#post-2533069

    However, no one seems to be responding to that one, either. I hope someone figures out what's going on and let us know what the fix is for this problem.

  22. floking
    Member
    Posted 2 years ago #

    I rolled my version back to 1.2.1 and all seem well again.

    http://downloads.wordpress.org/plugin/jetpack.1.2.1.zip

  23. floking
    Member
    Posted 2 years ago #

    I rolled my version back to 1.2.1 and all seem well again.

    http://downloads.wordpress.org/plugin/jetpack.1.2.1.zip

  24. Dave333
    Member
    Posted 2 years ago #

    I keep getting told I don't have permission to view the stats, and I am the admin, I have the highest rights that a user can have.

    Then I was told I entered the wrong API, but it is the correct API. I even got them to email it to me to be sure. It won't even accept the API emailed to me by WordPress!

    Jetpack is such a pain.

    I think the best thing to do is delete the buggy, virus-like Jetpack and go with a 3rd Party plugin for statistics and any other features that Jetpack pretends to offer.

  25. bamajr
    Member
    Posted 2 years ago #

    I just got the "We were unable to get your stats just now. Please try again." error today. It just started.

    The JetPack plugin and stats have all been working just fine on http://bamajr.com, until just a few minutes ago. It is a self hosted web site and I haven't done anything except write new blog posts.

    I'm using Jetpack by WordPress.com, Version 1.2.2 on WordPress 3.3.1

    It has worked, without issue, since I initially installed it. I have updated WordPress and the Jetpack plugin, since the installation, and it continued to work. Then, all of a sudden, today, it quite.

    I tried the "Disconnect" option, to disconnect from WordPress.com, but now when I click the "Connect to WordPress.com" button, I get another error:

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. Could not open handle for fopen() to https://jetpack.wordpress.com/jetpack.register/1/

    I'm the host, and nothing has changed on the server, so I'm not sure what is going on.

  26. bamajr
    Member
    Posted 2 years ago #

    Oh... FYI, Akismet now also gives an error:

    The key below was previously validated but a connection to akismet.com can not be established at this time. Please check your server configuration.

    Again, as of just a few minutes ago, these were all working.

    No changes to server. No changes to WordPress installation.

    What the heck is going on?

  27. bamajr
    Member
    Posted 2 years ago #

    I tried to disable and delete the Jetpack plugin, so I could re-install it, but I can't get a connection, through my http://bamajr.com WordPress blog to the WordPress plugins now either.

  28. bamajr
    Member
    Posted 2 years ago #

    Okay... So I'm not sure what is going on...

    The issues in my last three posts, seem to have fixed themselves, with a hard reset of the server. I cannot explain why, as I said before, there was no configuration change to the servers.

    Oh well, for the time being, it is up and running.

  29. carolynfox33
    Member
    Posted 2 years ago #

    Jetpack reports 3 visits to my site today.
    My webhost reports 63.
    A slight difference there me thinks!
    What is going on???????

  30. Abhidinvader
    Member
    Posted 2 years ago #

    Please any one reply how to resolve this error.. When i click on connect button it shows following error
    site inaccessible
    Site url : http://www.newtweeks.com

Topic Closed

This topic has been closed to new replies.

About this Topic