WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack Stats Graph Not Appearing in Admin Bar (36 posts)

  1. mt_Suzette
    Member
    Posted 1 year ago #

    I'm not sure when this occurred, maybe with the last upgrade, but the last few days I have noticed that the 48 hour view of the stats graph in the admin bar is missing from all of my sites using Jetpack across different hosts. I asked others and they noticed it is not showing up on their sites either.

    In the WordPress.com Stats configuration, I have verified that the checkbox for "Put a chart showing 48 hours of views in the admin bar." is definitely checked, but it is not showing up.

    I am writing an article on using Jetpack, and I wanted to get a screenshot of what the stats in the admin bar looked like, but it seems to be missing!

    I couldn't find any documentation saying that the feature has been removed, but wondering if it had been removed in the last update of Jetpack because of the load on WordPress.com servers.

    Does anyone have an insight on this issue or is this a bug? Would be much appreciated!

    http://wordpress.org/extend/plugins/jetpack/

  2. mt_Suzette
    Member
    Posted 1 year ago #

    Someone suggested uninstalling and reinstalling Jetpack, so I tried this: deactivating Jetpack, deleted Jetpack, reinstalled Jetpack, reactivated it, reconnected it to WordPress.com did not work.

    But... when I took the checkmark off "Put a chart showing 48 hours of views in the admin bar." then saved it, clicked on Learn more, then deactivate, then reactivated it, clicked on the checkmark to enable the graph, and now it seems to be working after a few minutes.

    Very strange indeed! So is this a bug or just a weird anomaly?

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    That seems like a temporary glitch; I tried to reproduce, but the Graph seems to working on my end at the moment.

    Could you post here if it happens again in the future?

    Could you also let me know if you installed any other plugin in the past few days? That may help me understand the issue.

    Thanks!

  4. Greg
    Happiness Engineer
    Posted 1 year ago #

    I'm having the same issue that mt_Suzette has. WP version is 3.5.1 with Jetpack 2.2.

    I've tried on several browsers, Safari and Chrome show a broken image for the word "Stats" and do not display the 48-hour graph, where FireFox will honor the "alt" text and display the text "Stats" but no graph.

    I've checked the error and access logs to no avail. I've also checked from two other networks with different hardware to rule out any sort of web filtering causing issues. I've also gone through the same troubleshooting steps, disabling plugins, checking and unchecking the box for stats as well as disabling/enabling the Jetpack plugin.

    Any ideas on what I could look for? FF reports the broken image as a invalid when I try to view it directly.

    Thanks.

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @jgs Could you deactivate all other plugins, one at a time, to make sure the problem is not caused by a plugin conflict?

    If you find a conflicting plugin let me know!

  6. Greg
    Happiness Engineer
    Posted 1 year ago #

    Hi Jeremy,

    I went through the plugins and one at a time disabled each, until I was left with only the Jetpack plugin active. No change unfortunately, the image is still broken.

    Is there any way to "call" the image directly from wordpress.com to make sure it's actually being generated? It's my understanding, that for the jetpack stats, each WP makes callouts to WP.com to pull that data.

    I'm willing to try anything else you can think of.

    Thanks.

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    If you are logged in, you can try loading the image in a new tab, with this URL:
    http://yoursite.com/wp-admin/admin.php?page=stats&noheader&proxy&chart=admin-bar-hours-scale

    If the image cannot be loaded, you should see an error in your server's error logs. That could help us understand the issue.

  8. Greg
    Happiness Engineer
    Posted 1 year ago #

    Ok, when I go to that URL (modified for my site) it opens the admin control panel. In the pane to the right it just shows the wordpress logo with the lines spinning around it.

    I checked both the access_logs and error_logs on the server, nothing catches my eye in the access logs. No new entries in the error logs at all.

    Last night I briefly turned on debug in the wp-config.php file to look for any other errors and came up empty.

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Would you mind letting me know your site URL, so I can have a look at your jetpack settings?

    If you want it to remain private, you can also contact us via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  10. Greg
    Happiness Engineer
    Posted 1 year ago #

    Thanks Jeremy, I sent the URL through the contact form.

  11. Greg
    Happiness Engineer
    Posted 1 year ago #

    A quick update, in case someone else runs across a similar issue.

    I've been working with Jeremy offline to try and figure out where the problem was, and we were able to narrow it down to the version of the theme I'm running.

    By visiting http://mysite.xyz/xmlrpc.php, the following text is returned: "XML-RPC server accepts POST requests only."

    This is a normal response, but in my case, there was an empty line above the text and apparently this sends Jetpack over the edge, it doesn't like the whitespace. This pointed to either the wp-config.php file or the functions.php file (inside the themes directory) having some whitespace between the php closing tags and php opening tags.

    The number of files that the functions.php file called made searching for this bit of code challenging, and eventually I decided it was easier to just update the theme, which solved the problem.

    Thanks for your help with this Jeremy, it's much appreciated.

  12. MrFent37
    Member
    Posted 11 months ago #

    jgs & Jeremy, thank you very much. You helped me with the same problem. I will add that for me, the issue wasn't inside wp-config.php or functions.php, but it was actually one of my plugins that had a single line of white space after the closing ?> tag. I deleted that whitespace, the line on http://mysite.xyz/xmlrpc.php disappeared, and the jetpack stats plugin started working again!

  13. pazzaglia
    Member
    Posted 11 months ago #

    Same problem here. I looked in my wp-config file as suggested by jgs, above. I had never touched it manually so I was surprised to see an opening PHP tagat the top and no closing anywhere in the file.

    SHOULD there be a closing tag there?

    I don't want to risk bringing my site down as I just sent out the newsletter to my entire readership.

    http://www.hippressurecooking.com

    Thanks,

    L

  14. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    @pazzaglia1 You do not need to edit your wp-config.php file, as your XML-RPC file doesn't include any whitespace:
    http://www.hippressurecooking.com/xmlrpc.php

    Something else must be tampering with the Toolbar Notifications on your site.

    Could you try to deactivate all other plugins on your site, one at a time, and let me know if you find a conflicting plugin?

    Thank you.

  15. pazzaglia
    Member
    Posted 11 months ago #

    Jeremy,

    I have 17 plug-ins and I de-activated and refreshed the dashboard for each one with the exception of one (BBPress) - which I will test in the wee hours of the morning when there is less traffic.

    So far, no hourly stats on the admin tool bar. Will write again to confirm 100% plug-in testing tomorrow morning.

    I have some customizations in my functions.php file, to remove the WP logo and the "site name" from the admin bar - but I added that AFTER I already didn't see the hourly stats.

    Ciao,

    L

  16. pazzaglia
    Member
    Posted 11 months ago #

    Ok, de-activated bbpress, still not stats graph. : (

    Ciao,

    L

  17. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    I'm sorry that didn't help.

    When logged in, could you try open your browser's Javascript console, and let me know if you see any error? You can follow the instructions here to open your browser's Javascript console:
    http://webmasters.stackexchange.com/questions/8525/how-to-open-the-javascript-console-in-different-browsers

    It would also be useful if you could send me a screenshot of the issue. You can use http://snag.gy/ to post it here.

    Thanks!

  18. EdwardMartinIII
    Member
    Posted 10 months ago #

    Experiencing a similar thing at my website. Stats seem to be working when I look at them, but the tiny little sparkline at the top shows a broken image.

    Went to:
    http://sitename/wp-admin/admin.php?page=stats&noheader&proxy&chart=admin-bar-hours-scale

    ...still showed a broken image.

    Checked the JS console, but no error listed.

    Visiting http://sitename/xmlrpc.php returns the following text: "XML-RPC server accepts POST requests only."

    What changed: I transferred the site to a different domain.

    Open to suggestions.

  19. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    @EdwardMartinIII Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

  20. EdwardMartinIII
    Member
    Posted 10 months ago #

    "Could you post your site URL here, so I can have a look?"

    Sure -- sorry I forgot to do that earlier.

    The URL is http://www.hellbendermedia.com/

  21. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    I do not see any errors on your site at the moment. Could you try to deactivate all plugins, one at a time, and let me know if one of them conflicts with Jetpack?

    If that doesn't help, could you switch to a different theme for a few minutes, and see if that helps?

  22. pazzaglia
    Member
    Posted 10 months ago #

    Any more things for me to try to get the hourly stat graphic back?

    Thanks,

    L

  23. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    @pazzaglia1 Could you check your browser's Javascript console, as I suggested above?
    http://wordpress.org/support/topic/jetpack-stats-graph-not-appearing-in-admin-bar?replies=22#post-4239549

    Let me know if you get an error!

  24. pazzaglia
    Member
    Posted 10 months ago #

    Wow.. there are whole bunch of errors. Any particular that you are looking for, or should I paste the whole thing here?

    Ciao,

    L

  25. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    @pazzaglia1 You might want to send them to me via this contact form, if it's too much for the forums.

  26. EdwardMartinIII
    Member
    Posted 10 months ago #

    "I do not see any errors on your site at the moment."

    Well, I've already checked for errors, so I would be surprised if you had. ;)

    "...could you switch to a different theme for a few minutes, and see if that helps?"

    This was the easiest thing to try at the moment, so I did that first.

    1. Installed "twenty-twelve" theme (I only have one theme installed to reduce my vulnerability profile)
    2. Activated "twenty-twelve" theme.
    3. Reviewed site.
    4. Sparkline appears!
    5. Switched back to "Sliding Door" theme.
    6. Sparkline disappears.

    So, seems like it may be associated with the theme...?

  27. EdwardMartinIII
    Member
    Posted 10 months ago #

    "Could you try to deactivate all plugins, one at a time, and let me know if one of them conflicts with Jetpack?"

    Okay, plugins I have:

    Akismet
    Bulletproof Security
    Custom Permalinks
    Jetpack by WordPress.com
    Marketpress
    Membership Premium
    Page-list
    Page Links To
    Pay Per View
    Secure HTML 5 Video Player
    WP-CopyProtect
    WP Editor
    WPMU DEV Dashboard

    One at a time, I deactivated each one, then refreshed the site.

    At no point in time did the sparkline reappear -- the link always appeared broken.

  28. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    Since the problem disappears when switching themes, something might be off with your theme indeed.

    I tried installing Sliding Door on a test blog of mine, played with the theme options, checked a few pages on my site, in different browsers, but the sparkline always appeared.

    Have you made some changes to the original Sliding Door theme? If you've added custom functions, could you try deactivating them, and let me know if you find the source of the problem?

    If none of this helps, could you check your site's .htaccess file for any custom rules, maybe added by the Bulletproof security plugin? What happens when you remove these custom rules?

  29. EdwardMartinIII
    Member
    Posted 10 months ago #

    "Since the problem disappears when switching themes, something might be off with your theme indeed."

    It worked with Sliding Door at the previous installation.

    However, I thought of a thing to try this morning and it worked:

    1. Copied to a separate file my Custom CSS (because that was a lot of work!)
    2. Assigned the site to the theme Twenty-Twelve.
    3. DELETED (not deactivated, but deleted) the Sliding Doors theme.
    4. Reinstalled Sliding Doors.
    5. Activated Sliding Doors.
    6. Pasted my Custom CSS back.
    7. Success!

    So, for whatever reason, some interconnection between the theme and the plug-in got busted during the server move. Deleting and reinstalling the theme solved the problem immediately!

    Thank you for helping me stumble in the right direction -- I would not have been able to do it without your good questions!

  30. Adrià López
    Member
    Posted 9 months ago #

    Same problem here...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic