WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack Sharing: More dropdown hidden (5 posts)

  1. jamesmdrakemedia
    Member
    Posted 2 months ago #

    I have a few icons in my More dropdown. When I hover over More, all of the buttons are hidden under the div for my tags.

    You can see this behavior on any post at http://storiesbehindtheimages.com

    Is there any way to bump a z-index anywhere to prevent this? If so, what class or id should it be applied to?

    https://wordpress.org/plugins/jetpack/

  2. Carolyn
    Happiness Engineer
    Plugin Author

    Posted 2 months ago #

    Can you clarify what you want the hover to do?

    Also, I visited your site today and it seems to be displaying properly: http://d.pr/i/AtaM

    Let me know if you still have this problem and I'll be happy to take a closer look.

  3. jamesmdrakemedia
    Member
    Posted 2 months ago #

    Hi Carolyn,

    Your screenshot is from the top of the post. It is the bottom of the post where this doesn't work. Even with all other plugins disabled and the Sharing set to bottom only, it gives me the same result.

    I have tested in multiple browsers and get this result:
    Screenshot

    If you scroll to the bottom of any post (ie: This Post) and hover over more, the pull out/drop down menu is under the 'tags' field.

    (P.S.: Any way to get the plugin to natively show at the top and bottom? Some users never go beyond the fold, whereas others don't like to scroll back up to the top to share.)

  4. Carolyn
    Happiness Engineer
    Plugin Author

    Posted 2 months ago #

    Thanks for clarifying. I wasn't aware you were using the sharing features in two places.

    The culprit is that your theme is setting CSS of:

    media="all" .content .post, .content .page { overflow:hidden; }

    Which hides the "more" overlay because it's overflowing the container of the <article>. If you remove that from your theme's CSS, it'll work just fine.

    I hope that helps!

  5. jamesmdrakemedia
    Member
    Posted 2 months ago #

    Thanks Carolyn! That did it!

Reply

You must log in to post.

About this Plugin

About this Topic