WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack "Share" button not working. (28 posts)

  1. NealFox
    Member
    Posted 1 year ago #

    I've been using the Share button from Jetpack on another site with no problem. On http://www.TheRealNealFox.com every time I hit the share button it just takes me to the top of the page.

    I have it configured right in the settings but can't figure out why this is happening.
    Any clues?

    http://wordpress.org/extend/plugins/jetpack/

  2. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    This seems to work fine for me in the Chrome browser. What browser are you using?

  3. NealFox
    Member
    Posted 1 year ago #

    I've tried it with Firefox - the latest - and Safari.

    Funny thing is, it works on my other site and I don't see any differences in the settings.

  4. Scott Jones
    Member
    Posted 1 year ago #

    I'm having this exact problem right now. Have you managed to find a solution for it yet?

  5. NealFox
    Member
    Posted 1 year ago #

    Nope.

    Can't figure it out. I was hoping upgrading the plugin would fix it but it didn't.

    I even tried deleting the setting and starting over. Still no cigar.

    Hope someone comes up with an answer. Seems like it should be an easy fix.

  6. Scott Jones
    Member
    Posted 1 year ago #

    Ah.

    I've just removed them all from the drop-down as a messier, temporary fix. Just allowing my patience to take over in someone smarter than me figuring this out!

    It does seem like an easy fix.

  7. Tim Moore
    Moderator
    Plugin Author

    Posted 1 year ago #

    Are either of you using a Minify plugin, like W3 Total Cache?

  8. NealFox
    Member
    Posted 1 year ago #

    Not me.

  9. gupster
    Member
    Posted 1 year ago #

    I have the same issue. I click the share button and it opens the pop up window, but is just the same blog page. It's not taking the user to the corresponding social site.

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @gupster Could you post your site URL so I can have a look?

  11. gupster
    Member
    Posted 1 year ago #

    Http://www.tootech.co.uk

  12. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks.

    Do you use any security plugin, or did you make any changes to your .htaccess file that may affect the way new windows open on your site?

    As reported here, some changes to your .htaccess file might cause issues with Javascript.

  13. gupster
    Member
    Posted 1 year ago #

    Hi Jeremy,

    No, the .htaccess is as was when I set this up. Also the only changes have been upgrading to WP3.5 and the latest Jetpack plugin. One or the other I suspect has caused this as it was working.

    We run on Windows Server 2003.

    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?p=$1 [NC,L]

    Thanks,

  14. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks for checking. Unfortunately, I do not see what could cause this issue at the moment.

    Would you mind trying to install another sharing plugin, and see if you experience similar issues with other buttons opening a pop-up on your site?

  15. gupster
    Member
    Posted 1 year ago #

    Just installed one and it works perfectly. Sorry... :-)

  16. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Good. We're making progress, narrowing down the issue. Thank you! :)

    Could you go to Settings > Sharing in your dashboard, and change the button settings to "Official buttons"?

  17. gupster
    Member
    Posted 1 year ago #

    Ah, that seems to make it work. :-)

  18. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    It does seem to work, indeed. Unfortunately, I am afraid I have no idea why the other setting failed.

  19. gupster
    Member
    Posted 1 year ago #

    Not to worry, the graphics are okay I think so I'll stick with that. Thanks for your help.

  20. TonyScutella
    Member
    Posted 1 year ago #

    Tried setting to official buttons and all other options but I still do not get any share buttons showing. Just goes back to top of the page.
    http://www.shiftingmindsets.ca

  21. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @TonyScutella Your theme uses an old version of jQuery (1.4.2) instead of the version that comes bundled with WordPress.

    You'll want to remove this old version of jQuery to fix any conflicts you may have with WordPress and plugins like Jetpack.

    You can read more about it here:
    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4#post-3547424

  22. bluepoppy
    Member
    Posted 1 year ago #

    It is also not working on my site as well. I today installed Jetpack on my site and now the sharing links are not working. Trekforall.com Please help

  23. TonyScutella
    Member
    Posted 1 year ago #

    Jeremy,

    Thanks for the insight. As a novice to WordPress I do not know how to remove jQuery and the support links are quite confusing to me. I switched for an html site to make life easier but this is frustrating. Any other suggestions are appreciated. Thanks.

  24. NealF2
    Member
    Posted 1 year ago #

    I tried everything and it still doesn't work.
    But the funny thing is, it's working on my other sites and I can't see any difference in the way they are set up.

  25. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @TonyScutella If you're not comfortable editing PHP files, I would suggest that you contact the theme author, and ask them if they can fix the issue.

    @bluepoppy Could you try to disable the Lightbox Gallery plugin on your site? It creates Javascript errors, and that may be what's causing the problem:
    http://i.wpne.ws/MQFp

    @NealF2 Could you post your site URL, so I can have a look? You can also check for old versions of jQuery on your site, as I explained above.

  26. jcoleman
    Member
    Posted 1 year ago #

    I'm having a similar issue. I notice in the returned HTML code using "inspect element" that the "Sharedaddy" social sharing anchor hrefs "#". I know this is a link to nowhere, but I'm not sure where to fix it.

    Here is an example post that has two sets of social buttons, but the one I like, the sharedaddy one, doesn't work like it works in the dashboard preview.

    Any help in this regard is appreciated.

    http://extrememeasurescreative.com/2013/01/modern-hiring-practices-good-marketing/

  27. jcoleman
    Member
    Posted 1 year ago #

    I figured out I just had to take them out of the nesting box. Seems it just didn't want to work properly. I'm using just icons now and it seems to work fine. However I'd rather prefer to use the nesting box or the official set. The nesting box links to # and the official buttons Pinterest icon is missing. :(

  28. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @jcoleman I had a look at your site, and your theme seems to be loading an old version of jQuery (1.3.2) instead of using the version that comes bundled with WordPress (1.8.3 at the moment).

    It can create multiple conflicts with WordPress and with other plugins like Jetpack. You can read more about it here:
    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4#post-3547424

    The problems with the sharing buttons and the Pinterest button are caused by this old library.

    You'll want to look for the function loading jQuery in your theme's header.php file, or in the functions.php file. Once you find that function, you can remove it and enqueue the proper version of jQuery as explained here:
    http://codex.wordpress.org/Function_Reference/wp_enqueue_script

    If you do not feel comfortable editing PHP files, you can also contact the theme or plugin author and ask them to solve the issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic