WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack register_http_request_failed (17 posts)

  1. Jenamriss
    Member
    Posted 10 months ago #

    I just installed Jetpack on my blog today and got the error:

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. SSL read: error:00000000:lib(0):func(0):reason(0), errno 0

    url: http://jenniferamriss.com/
    Webhost: Network Solutions (a web.com company)
    WP Version: 3.7

    Compatibility Test:

    Site info

    SITE_URL: http://jenniferamriss.com
    HOME_URL: http://jenniferamriss.com

    TEST: HTTP Connection
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Sun, 27 Oct 2013 04:39:42 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [vary] => Cookie
    [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => OK
    [response] => Array
    (
    [code] => 200
    [message] => OK
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    TEST: HTTPS Connection
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Sun, 27 Oct 2013 04:39:42 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [vary] => Cookie
    [x-pingback] => https://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => OK
    [response] => Array
    (
    [code] => 200
    [message] => OK
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    TEST: Self Connection
    Array
    (
    [headers] => Array
    (
    [date] => Sun, 27 Oct 2013 04:39:42 GMT
    [server] => Apache/2.2.22 (Unix) FrontPage/5.0.2.2635
    [x-powered-by] => PHP/5.4.17-pl0-gentoo
    [expires] => Thu, 19 Nov 1981 08:52:00 GMT
    [cache-control] => no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    [pragma] => no-cache
    [set-cookie] => PHPSESSID=62a1f891cf8aedfd3d9a6a05a18ea909; path=/
    [connection] => close
    [content-type] => text/plain
    )

    [body] => XML-RPC server accepts POST requests only.
    [response] => Array
    (
    [code] => 200
    [message] => OK
    )

    [cookies] => Array
    (
    [0] => WP_Http_Cookie Object
    (
    [name] => PHPSESSID
    [value] => 62a1f891cf8aedfd3d9a6a05a18ea909
    [expires] =>
    [path] => /
    [domain] => jenniferamriss.com
    )

    )

    [filename] =>
    )

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    Could you contact your hosting provider, and ask them to activate the openssl extension in your server configuration? It might explain why your site is unable to connect with WordPress.com.

    Let me know if it helps.

  3. EditorObserved
    Member
    Posted 10 months ago #

    I am having this problem too. Network Solutions won't do anything unless I pay $60.00 for additional support -- since they say this is an issue with the third party plug-in. I am more than willing to switch to a new host, but it will take time. In the meantime, I can't get my posts out to my subscribers, which is an issue. Not sure what to do at this point....

  4. EditorObserved
    Member
    Posted 10 months ago #

    p.s. NS says they will only do "global updates" -- or something like that....

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    I'm not familiar with Network Solutions, but some users seem to say you can create your own custom php.ini file yourself:
    http://forums.networksolutions.com/script-help-perl-php-asp-net-f50-change-php-ini-file-t1505.html

  6. Jenamriss
    Member
    Posted 10 months ago #

    They told me the same thing. Pay $60 to do that. So, I canceled my hosting account with NS, and got Verve hosting for $5.95 (as a heads up to EditorObserved if he needs reliable hosting who HAS the openssl extension already activated). I'll smack this thread again if I have issues with the new hosting, but I doubt I will. I've used them with wordpress before.

  7. EditorObserved
    Member
    Posted 10 months ago #

    Yes, I am in the process of switching hosts. I don't have the technical skills to do what Jeremy suggests and, in any case, I am totally sick of NS. Once you switched hosts were you able to access the subscribers signed up with Jetpack?

  8. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    Once you switched hosts were you able to access the subscribers signed up with Jetpack?

    Once Jetpack is connected to your WordPress.com account, and if you've added the Subscription widget to your sidebar, your readers should be able to sign up and receive updates from your site without any issues.

    It's worth noting that if you moved from a WordPress.com blog to a self-hosted version of WordPress, your subscribers won't be transferred automattically. I'll need to make that transfer for you. Just let me know your old WordPress.com site address and the new Jetpack site URL and I'll run the transfer.
    If you want your site to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

  9. Jenamriss
    Member
    Posted 10 months ago #

    It can take up to 48 hours for the nameservers to show the new hosting. I'll update once I have wordpress set up and Jetpack installed.

  10. EditorObserved
    Member
    Posted 10 months ago #

    BTW -- here is the information I've received about why my particular problem is happening --

    ... this one is definitely an error that only Network Solutions can fix. It indicates that they've updated part of the software on their servers to a recent version that has this known bug in it: http://sourceforge.net/p/curl/bugs/1249/

    Does this change any suggested fixes?

    Looks like I'll need to be back in touch once I've switched hosts to get help getting my subscribers back on line.

    Thanks.

  11. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    Does this change any suggested fixes?

    It could mean that you won't be able to make the fix yourself by making changes to a custom php.ini file. You would definitely need to contact Network Solutions.

    But if you're currently switching to a new site you shouldn't experience any more issues. Do not hesitate to post again here or send me an email once you've made the switch if you want me to transfer your subscribers.

  12. Jenamriss
    Member
    Posted 10 months ago #

    I just installed jetpack on my new verve hosting with complete success. No problems whatsoever. So, verve hosting works as intended without any fuss. As I have no stalkers (subscribers), there's no need for Jeremy to help me further. I hope things go well for you, Editor!

  13. kuper boi
    Member
    Posted 4 months ago #

    i love jetpack features, so i was very frustated when it was couldnt connect.. now, with these tips u could solve jetpack error like i did

    u must have and install :
    1. core control
    2. jetpack (latest, i am using jetpack 2.9.3)
    3. jetpack lite (not official, with limited feature)

    procedure :
    1. activate jetpack (official version)
    note : till this step, u get error about connection

    2. activate core control
    3. setting core control, tools>core control>external http access>disable CURL
    note : till this step, if u still couldnt connect, go next step below

    4. activate jetpack lite (and jetpack official must active too)
    note : after click connect, u will go to authorizing page, maybe u could some error, but u could repeat authorizing, and then.. success
    note : your jetpack connected, but just has two features

    5. u could deactivate jetpack lite
    note : so ur jetpack still connected and has complete feature

    regard :)

  14. Albertowordpress
    Member
    Posted 3 weeks ago #

    good morning

    i have installed my wordpress sdite in godaddy deluxe hostin

    i have installed in this host 2 wordpress application connectet 2 doiain

    the first wordpress can register and use jetpack
    in the second i can t use jatpack
    with core control plugin
    i obtain a different error

    Your website needs to be publicly accessible to use Jetpack: site_inaccessible
    Error Details: The Jetpack server was unable to communicate with your site http://albertobettini.info [IXR -32300: transport error: http_request_failed Operation timed out after 15001 milliseconds with 0 bytes received]

    i have active the post control loggingig
    and when i try to connect jatpack in wordpres.com
    report this log
    POST http://jetpack.wordpress.com/jetpack.register/1/ 400badrequest

    how can i try ?

    thanks Alberto

  15. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 3 weeks ago #

    @Albertowordpress I see you also contacted us via email. I replied there!

  16. sinsay
    Member
    Posted 2 weeks ago #

    I have the same problem in http://www.sinsay.cl
    Try deactivate all plugins but nothing.

    Jetpack 3.1.1
    WP 3.9.2

  17. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 weeks ago #

    @sinsay Could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

Reply

You must log in to post.

About this Plugin

About this Topic