WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] JetPack Publicize uses wrong URL for Twitter (57 posts)

  1. swaroopch
    Member
    Posted 1 year ago #

    The Publicize feature posted the correct URL to Facebook and Linkedin ( http://www.swaroopch.com/blog/anu-aunty-book/ ) but posted a wrong URL, which I haven't figured out how it came up with it in the first place, for Twitter : http://swaroopch.wpengine.com/?p=4462 ( https://twitter.com/swaroopch/status/267512801336123392 ) - how do I fix this?

    http://wordpress.org/extend/plugins/jetpack/

  2. lollypopstar
    Member
    Posted 1 year ago #

    Yes I'm having the same problem too. The url is correctly set for the Facebook post - but the Twitter one seems to be using an old (cached?) version of the site address...

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you go to Settings > General in your dashboard, and check your Site and WordPress address?

    If they both show the correct domain, could you click on "Save Changes" at the bottom of the page, and see if that helps next time you publish a post?

  4. swaroopch
    Member
    Posted 1 year ago #

    The first thing I did when I observed the issue was to check the site and wordpress address - they are both correct, I will let you know what happens the next time after 'save changes'.

  5. lollypopstar
    Member
    Posted 1 year ago #

    I checked the settings on my WordPress site, and resaved them, to no avail.
    I even tried "disconnecting" from WordPress.com within Jetpack & reconnecting to see if that would recognise the new settings, again to no avail.
    Also tested deleting the link to my Twitter account in the Sharing section and using an alternate account - still it shares with links to old address.

    Any suggestions what to try next?

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @lollypopstar Could you let me know your site URL?

  7. lollypopstar
    Member
    Posted 1 year ago #

  8. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thank you! I had a look at your site settings, and everything seems to be set up properly. However, I noticed that your site is not connected to Twitter anymore.

    Could you try to reconnect, and let us know if the problem happens again?

  9. lollypopstar
    Member
    Posted 1 year ago #

    Hi Jeremy, I just tested it with another Twitter account and it works now, thank you.

    Any guidance as to what I did wrong? I think in future when I set up a WordPress site I won't connect it to Jetpack until its on a live URL. Hopefully that will stop any of these caching issues

    Thanks again.

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I think in future when I set up a WordPress site I won't connect it to Jetpack until its on a live URL.

    That seems like a good solution, yes. Hitting "Save changes" in Settings > General should also solve any problems you may have in the future, since it updates your site settings as well as your Jetpack settings.

    If you still experience issues, you can also contact us via our contact form here:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  11. majones
    Member
    Posted 1 year ago #

    Hi,

    I'm getting the same problem on one of my wordpress installs - it's calling the original dreamhoster.com url that the install was set up on but that hasn't been an active url for a good couple months. Publicizer was only activated yesterday on our install.

    Site settings have the correct domain (sla-europe.org) in place in both fields and I've tried removing and replacing them and saving it again but it still picks up the now inactive dreamhoster url.

    Thanks.

  12. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @majones I have made a change to your Jetpack site settings. Could you try publishing a new post? It should use the proper URL now.

  13. majones
    Member
    Posted 1 year ago #

    @jeremy - Hooray, it worked! Out of curiosity, what exactly needed to be changed?

  14. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @majones Your Jetpack site settings still used your old dreamhoster URL. It seems they were not updated when you changed your site address in Settings > General in your dashboard. I just changed it manually for you :)

  15. liff75
    Member
    Posted 1 year ago #

    Is this something we'll be able to do for ourselves at some stage? Like most others here, I'm assuming, I first did my WordPress site on a separate development URL, and then copied everything to a production server and gave it a production URL. Today I posted my first post, and LinkedIn + FaceBook used the development URL, however, Twitter used the bit.ly shortened URL which did go to the write server.

    I've logged into wordpress.com but can't find any Jetpack settings. Site settings here all look right, and I've even just tried to nuke and re-attach the three social accounts, but they don't want to play nice.

  16. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Such problems can happen when copying the whole database of your test site (including the Jetpack options) over to a new URL.

    Disconnecting / reconnecting to WordPress.com should update your site settings. If it doesn't, please let me know your site URL, and I'll be happy to have a look!

  17. MRA_Andy
    Member
    Posted 1 year ago #

    Hello,

    I don´t use jetpack on wordpress.com but I think I have some kind of the same problem.
    I use a subdirectory called "wordpress" for my installation but the links pushed to facebook ignore that. I saved the general settings to http://www.example.com/wordpress/, reconnected to the wordpress-app on facebook but every time I click on "add new facebook connection" the link ignores that my installation is in a subcategory and redirects to http://www.example.com/wp_admin/options-general.php... this should be http://www.example.com/wordpress/wp_admin/options-general.php. It works when I manually insert the right url but still results in wrong links on facebook.

    Thanks for any help

  18. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @MRA_Andy You mentioned that you don't use Jetpack. If you experience issues with links to your site on Facebook, I would suggest that you ask the author of the plugin you use to post on Facebook; they might be able to help!

  19. MRA_Andy
    Member
    Posted 1 year ago #

    Sorry for the misunderstanding but I use jetpack in my own WordPress-installation not on wordpress.com, so there´s no other plugin.

  20. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you give me your site URL, so I can have a look?

    If you want the URL to remain private, you can also contact us via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  21. MRA_Andy
    Member
    Posted 1 year ago #

    I sent my URL and details via contact form

    Thank you

  22. liff75
    Member
    Posted 1 year ago #

    Thanks for the response. I'll let you know how it goes next time I post something. Did all the disconnect/reconnect things and also saved the general settings all over again just to overwrite everything.

    I figured my replication scripts would cause some headaches. Basically to swipe a copy of production to development or visa versa to test any major changes prior to making them live, I use rsync to copy the entire site folder between servers, then mysqldump | mysql to pipe the database between both machines, and then just run a script on the database to change the option_value in wp_options for 'home' and 'siteurl' to reflect the right URL for one or the other.

    Didn't count on Jetpack to get confused by the change. Might leave the URL as the production URL and change the hosts file on my desktop to point at one or the other when I want to start messing around with things.

    Alex.

  23. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @liff75 You can keep the same workflow, but I would suggest one more change to the database to avoid any Jetpack confusion: once you have changed home and siteurl, also make sure you delete all Jetpack options (jetpack_options) from wp_options. This way, your development and your production sites will have two different site IDs.

  24. liff75
    Member
    Posted 1 year ago #

    Just delete them? That won't create new site IDs each and every time? Obviously I don't want to lose any configuration (such as connected Facebook/Twitter/LinkedIn accounts) each time I shove the site forward or backward.

    If you could quickly take a look, the proper production URL for my site is whatsbroken.com.au (not the dev.* variation).

    Cheers.

    Alex.

  25. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks for the URL. That helps a lot, since you won't need to delete your Jetpack Options to recreate them on your dev site. You'll want to use the following site IDs:

    • whatsbroken.com.au: 44448605
    • dev.whatsbroken.com.au: 44448478

    You shouldn't need to change anything else.

  26. dwilbur78
    Member
    Posted 1 year ago #

    @jeremy herve i am having the same problem but can't figure out how to fix it please help

  27. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @dwilbur78 Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  28. dwilbur78
    Member
    Posted 1 year ago #

    @ jeremy herve the site is http://www.davedoom.com

  29. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @dwilbur78 I fixed the issue earlier today. Check your inbox! :-)

  30. tedp58
    Member
    Posted 1 year ago #

    Jeremy, I'm having the same issues as several of those above, posting to both LinkedIn and my facebook fan page. Can you help me with it?

    Old: goingreenpromos.com

    New: ted4promos.com

    Ted

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic