WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack Publicize to Facebook Not Working Correctly (10 posts)

  1. Hany05
    Member
    Posted 5 months ago #

    The publicize to Facebook option for two different blogs is not working properly. It only shows the post title with no link back to the post on our WordPress blog. (For example if I wrote an article called 10 Best Business Computing Tricks, that title alone is all that would show in the Facebook feed, just as if I typed it in the status box on Facebook) The posts to Twitter and to LinkedIn work just fine, and it has worked on Facebook perfectly in the past)

    I have tried disconnecting and reconnecting Jetpack from WordPress, uninstalling and re-installing the WordPress App through my Facebook page, and removing access to Facebook in the Jetpack settings.

    This is now happening on two separate WordPress installs that we have. So I am not sure if this is site specific or more of an integration issue with my account.

    The one other bit of information I have is that I installed a Facebook Thumbnail plugin on one of the WordPress installs (site a) and then uninstalled it after looking at it and determining I didn't like it. The problem seemed to have started after I did that, but I did not install that plugin on the second WordPress page (site b) and it still has the same issue with posting to Facebook as the first site (site a).

    Any information you could provide would be appreciated. Thanks for your time.

    http://wordpress.org/plugins/jetpack/

  2. SyndicatedNews
    Member
    Posted 5 months ago #

    I am having a similar problem. My posts are showing up with only the title in the link area, and a snippet that is badly formatted in the text box. I have to go back in and edit the post to make it show up correctly, but there is still no snippet in in link area.

    I've disconnected and reconnected several times and am considering dropping publicize for another third party multi-platform sharing program.

  3. Hany05
    Member
    Posted 5 months ago #

    What program are you leaning towards?

  4. W-P-Zar
    Member
    Posted 5 months ago #

    Only public the title and short url
    Is wrong.
    I have not made changes

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    Could you all post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

  6. Hany05
    Member
    Posted 5 months ago #

  7. rmonton
    Member
    Posted 5 months ago #

    Same problem here.. The Jetpack Facebook widget it's empty..

    http://www.webxprs.com/amigamania/web/

  8. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    It only shows the post title with no link back to the post on our WordPress blog.
    http://www.TheLocalCircuit.com

    When you share a post on Facebook, or when Jetpack Publicize publishes a post to your Facebook page, Facebook crawls the page and looks for Open Graph meta tags in the head to build a complete post preview (with an image, title, description, ...).

    Jetpack automatically adds these meta tags to your posts for you, unless you already use another plugin to do so. On your site, you're using WordPress SEO to manage your Open Graph meta tags, so you might want to post in the WordPress SEO support forums for help.

    @rmonton I'm not sure what you mean by empty Facebook widget. Your problem seems different from the ones mentioned in this thread.
    The Facebook Like Box you've added to your sidebar appears to be displayed properly:
    https://cloudup.com/c4Gd9Hym93P

    If you still experience issues, could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

  9. W-P-Zar
    Member
    Posted 5 months ago #

    hello!
    I add information.
    My Open Graph tags are OK.
    Facebook Debugger shows all ok. always

    some time ago
    jetpack (publicize) worked ok

    published

    Title
    image
    Title (url)
    description

    then stopped working properly

    now posted on facebook this:

    Title + Short url

    nothing more

    (Similar to twitter)

    jetkpak is a problem

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    @W-P-Zar Could you please start your own thread and let me know your site URL, please?

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic