WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Jetpack publicize sjows no picture on Facebook (36 posts)

  1. foxalert
    Member
    Posted 1 year ago #

    I've been looking around the forum but can't find the answer to my problem / question.

    I activated the publicize option in WordPress.

    Now when i'm ready with my post and publish it, it shows on Facebook but without picture / image / thumnail. So the space is blank where the picture shoud be.

    When i post the post manually it does show the picture.

    When i make a post the image is added outside the post as a Thumbnail Image.

    The image is also set as features image. That should do the trick according to the faq.

    Can someone tell me what to do to solve this problem?

    For example see the post: "Promes scoort voor de Eagles" at my FB page https://www.facebook.com/twenteinsite

    URL website is http://www.fctwente.nu

    Thank you!

  2. sondon
    Member
    Posted 1 year ago #

    I have the same problem.

  3. bobransom
    Member
    Posted 1 year ago #

    Same issue here. Featured image is set and there's a gallery of 20 more images attached to the post but no image appears on Facebook.

  4. ejb5oh
    Member
    Posted 1 year ago #

    Same Problem here too. Anyone able to help yet??

  5. designsimply
    Member
    Posted 1 year ago #

    For anyone having trouble with Publicize images not appearing in Facebook, here is some information you can collect and post that will be helpful:

    • Screenshot showing the problem
    • HTML source of the image at Facebook
    • Link to the post from your blog
    • Link to the image from the blog post
    • Link to an image from an image on FB you published manually and that IS working

    As an example, I found this info for foxalert's report:

    @foxalert, in your case, it looks like whatever auto-processing of thumbnail files you're doing could be the source of the problem. Interestingly, if you open the image link used by FB for the "Promes scoort voor de Eagles" post, it works! It kind of looks to me like Facebook isn't figuring out the image sizing because of the stuff like this at the end of the image link "&h=250&w=250&zc=1". Can you try temporarily turning off whatever is adding that "&h=250&w=250&zc=1" stuff and try it again?

  6. designsimply
    Member
    Posted 1 year ago #

    @foxalert, actually, can you reply back with an example of a post that you made on FB manually where the image worked? I just noticed the example I picked has a different image on your blog than the one showing in Facebook:

    Why are those images different?

    How exactly does it work when you add a post manually on FB? Do you enter the image separately or does FB figure it out just based on a link like http://www.fctwente.nu/fotos/fc-twente-nieuws/joshua-john-wederom-belangerijk-voor-fc-nordsjaelland.html ?

  7. designsimply
    Member
    Posted 1 year ago #

    Couple more questions:

    • For the blank images, Is it possible you user added the image after hitting Publish?
    • Can you try turning timthumb off and testing again?
  8. bobransom
    Member
    Posted 1 year ago #

    Hi,

    Maybe this will help. Here's a screen capture of Facebook showing one of my post minus the image: http://www.bobransom.com/blog/wp-content/uploads/2012/11/Screen-Shot-2012-11-30-at-11.08.45-AM.png

    Here's the link Facebook is using to reach my blog: http://www.bobransom.com/blog/?p=2229&fb_source=pubv1

    Here is the blog post itself: http://www.bobransom.com/blog/?p=2229

    This blog post contains 26 images with one marked as "featured." Images are roughly 800 x 533 pixels.

    Thanks for looking into this...

  9. designsimply
    Member
    Posted 1 year ago #

    @bobransom, thanks, this is close. The missing pieces are the actual image links. Can you right-click on the empty space in Facebook and copy the image URL or send the link to the Facebook page where I can see it? For the post itself, I checked it and it looks like the og:image picked is http://www.bobransom.com/blog/wp-content/uploads/2012/11/Thanksgiving2012__9570_800px.jpg which seems to match with the featured image at the top of the post.

    P.S. I think Thanksgiving looks quite nice in B&W. :)

  10. bobransom
    Member
    Posted 1 year ago #

    Oddly, when I click the empty space, I get exactly the same URL as for anywhere else in that Facebook box:

    http://www.bobransom.com/blog/?p=2229&fb_source=pubv1

    I'm not sure how to share the Facebook link with you without us being Facebook friends? My timeline may be publicly visible at: http://www.facebook.com/bob.ransom
    ...or maybe not. I can't remember if I left that open or not.

  11. ejb5oh
    Member
    Posted 1 year ago #

    Any fix yet for this??

  12. kpopremix
    Member
    Posted 1 year ago #

    I have the same issue, No image is shown on wither Facebook nor Twitter. Any hints?
    Thanks

  13. sondon
    Member
    Posted 1 year ago #

    I retried this using Featured Image correctly and it worked. Problem solved.

  14. foxalert
    Member
    Posted 1 year ago #

    @ designsimply

    There is no automatic thumbnail processing.

    I select a featured picture and he uses that one when i post a link on Facebook.

    That's why i dont understand why it doesnt show the picture.

  15. ejb5oh
    Member
    Posted 1 year ago #

    How do you "correctly" use the featured image feature?

  16. sondon
    Member
    Posted 1 year ago #

    Sorry, I misspoke. It worked once, but on the next post it didn't work. So I'm back to being as confused as ever.

  17. designsimply
    Member
    Posted 1 year ago #

    For anyone having trouble with Publicize images not appearing in Facebook, you need to post relevant details such as:

    • Link to an example post
    • Link to the FB page where we can see the problem happening
    • Image link from the post
    • Image link from FB

    To figure out an image link, right-click where the image should be and select the option that says something like "Copy Image URL."

  18. ejb5oh
    Member
    Posted 1 year ago #

  19. ejb5oh
    Member
    Posted 1 year ago #

    I provided two examples above.

    The first one, uses the featured image but has it selected to not show it in the post, rather only on the blotter listing.

    The second one has the image used as the featured image on the post and for the blotter listing.

    ***Just an idea, but it would be nice if we could define a default image to use when no image is picked up in the post.

    Thank you!

  20. ejb5oh
    Member
    Posted 1 year ago #

    A fix is coming. Got the email today from Jetpack support!!

  21. elsmoon
    Member
    Posted 1 year ago #

    I am facing the same issue here. Below are the information for the post that I’m having trouble with.
    1. Screenshot on FB: http://screencast.com/t/9hSn8XPh5
    The blue image is not the image I have on my blog and whenever I publicize a post on facebook through jetpack, it will show this blue image…I have no idea where does the image come from.
    2. HTML: <img class="img" src="https://fbexternal-a.akamaihd.net/safe_image.php?d=AQDc2pXg-Uzig8iU&w=155&h=114&url=https%3A%2F%2F1.gravatar.com%2Favatar%2F10467cac4cbd4b17210b775a3989e89e%3Fs%3D96%26amp%253Bd%3Dhttps%253A%252F%252F1.gravatar.com%252Favatar%252Fad516503a11cd5ca435acc9bb6523536%253Fs%253D96%26amp%253Br%3DG" alt="">
    3. Blog post: http://www.moonrisedesign.com/blog/2012/12/11/making-your-typography-optimal-for-your-site-a-few-things-to-consider/

    4. Direct image link from the blog post: http://www.moonrisedesign.com/blog/wp-content/uploads/2012/12/Typography.jpg
    5. Direct image link from a different post that appears to be working properly in FB: No such a thing, never got a image successfully appeared in FB ever since I start using jetpack 2.0.

  22. atmasphere
    Member
    Posted 1 year ago #

    Is there any way to suppress the gravatar image? I like the post to Facebook, but don't need or want to see my own picture in my own post.

  23. TimeDoctor
    Member
    Posted 1 year ago #

    I have the same issue with the gravatar image being used on my posts when publicized to facebook using jetpack. Please use the og:image for the page or give us an option.

  24. gcgrann
    Member
    Posted 1 year ago #

    I would appreciate some help as well. For the first few days of using the Jetpack FB plugin everything worked great! My images were posted and the links and content looked great. For the past 3 days the image is NO LONGER being populated on FB. Instead an UGLY glyph (like an upturned "G") is littering my entire page. I can't get rid of it. I would be ok with NO PIC showing rather than that awful, meaningless UGLY glyph.

    I don't know what to do to get rid of it or to get pictures to show on my FB page again.

    Go see for yourself how UGLY this is.

    http://www.facebook.com/ShiftFrequency

    Please assist.

    Thank you.

    Gillian

  25. atmasphere
    Member
    Posted 1 year ago #

    Looks like you don't have a gravatar for the page. There
    really
    just should be an option to toggle images.

    It does pull a preview but only if you've hosted the image yourself. If you link an image from another site it defaults back to the avatar.

  26. gcgrann
    Member
    Posted 1 year ago #

    Thank you, atmasphere. So, how do I create an avatar that it will default to? Blessings, Gillian

  27. atmasphere
    Member
    Posted 1 year ago #

    I'm not entirely sure, but you need to associate your wordpress install with a page.

  28. gcgrann
    Member
    Posted 1 year ago #

    Hello again, Atmasphere, I have associated my wordpress install with the Shift Frequency page. I have 2 FB pages - my personal page and my blog page. To set up Jetpack you have to allow the blog to post to FB. Jetpack goes out and locates all pages associated with the FB user (my real profile plus any additional profiles). Jetpack then populates both my personal page and my blog page and gives me the option to select either or both pages to post to. I select the blog page and that is where it posts.

    I very much appreciate the way you have attempted to assist me.

    Blessings, Gillian

  29. purkleturkle
    Member
    Posted 1 year ago #

    I also have this problem of using Jetpack 2.2 and using the Publicize feature to Facebook it keeps using this image:

    http://1.gravatar.com/avatar/3c37792db0ce671809b94f5365aba2b7?s=80&d=&r=G

    I want it to display either the authors avatar or images within the blog, if I paste the URL manually into Facebook it works fine and I can select either the author avatar or images within the post.

    Why is Facebook grabbing this default avatar?

  30. gcgrann
    Member
    Posted 1 year ago #

    Hello purkelturkle, I got my blog fixed by asking for assistance from the wordpress.COM site. If you have signed up with your blog you can access the thread here:

    http://en.forums.wordpress.com/topic/how-to-populate-images-associated-with-posts-to-facebook-page?replies=3#post-1150931

    All the best,
    Gillian

Topic Closed

This topic has been closed to new replies.

About this Topic