WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] [closed] Jetpack Publicize - No Facebook *Page* (116 posts)

  1. evilcrusher
    Member
    Posted 1 year ago #

    Posting because I need updates as well. I'm going to have to check to see if there is a thread about another issue that occurred the same exact time this issue did. My connection to Tumblr is showing up in the settings, but the posts don't make it to the blog. :(

  2. cdostie
    Member
    Posted 1 year ago #

    Okay Jetpack developers - what's it going to take to solve this problem? This is a MAJOR issue and I'm sure that everyone who has posted plus several hundred others who are simply frustrated would be willing to chip in a few bucks to make a solution appear yesterday. We know this stuff takes time, and the time invested should be rewarded. So give us a way to help you to help us.

  3. iteisaburo
    Member
    Posted 1 year ago #

    A friend of mine is using a different social connection plugin in his website, and he's having the same problem regarding Facebook connection.

    I must be the Facebook API.

  4. glueckschromosom
    Member
    Posted 1 year ago #

    same Problem on my self-hostet@strato wp 3.5.2 and jetback 2.3.1

    hopefully there will be a solution as soon as possible

  5. jgentes
    Member
    Posted 1 year ago #

    +1, I've got this problem on 10 sites. Please Fix!!

  6. evilcrusher
    Member
    Posted 1 year ago #

    I forgot myself that this past weekend, Facebook implemented developers changes. One of the big ones was to use absolute hrefs if I recall correctly. So this really boils down to not paying attention to what Facebook put out over 2 months ago. There is probably lots of code that needs to be changed to get this to work with how Facebook changed, but really - everyone had plenty of time to prepare for this. It was not like Facebook said "Hey we are gonna do this, and it starts tomorrow!" I guess I will sit and wait patiently to hear about an update cause that is what I really believe is going to fix this issue.

  7. wkeving
    Member
    Posted 1 year ago #

    +1 Posting for updates.

  8. srgmmss
    Member
    Posted 1 year ago #

    me too, +1 Posting for updates.

  9. segacom
    Member
    Posted 1 year ago #

    This whole thing reflects poorly on WordPress. It's sad to see such a wonderful name tarnished.

  10. T.T.Tassel
    Member
    Posted 1 year ago #

    Well being honest it reflects badly on Facebook since it seems to have been caused by them.
    Facebook has at least 3 different pc versions, my partners Facebook is different to mine, and a friend has a different version to both of us, theirs looks more like the mobile version, so it is hard for designers to keep up with changes.

  11. jgentes
    Member
    Posted 1 year ago #

    This is the developer API - there's only one version.

    This isn't a problem with Facebook, it's the WordPress implementation of the Publicize plugin and they need to fix a bug that should have been caught prior to release.

  12. philfry
    Member
    Posted 1 year ago #

    Oy!

  13. evilcrusher
    Member
    Posted 1 year ago #

    From what I'm finding, no one got ready for this. Not even other big social media sites such as twitter. I put my twitter settings to post to my facebook page to try to work around this and it can't even do it. Jgentes is right about this.

  14. Art Project Group
    Member
    Posted 1 year ago #

    On Wordbooker plugin everything is working fine :-(.

  15. ecaconcordia
    Member
    Posted 1 year ago #

    On Wordbooker plugin everything is working fine :-(.

    So why the sad face? lol

    And yeah, no one got ready for these changes.

  16. Art Project Group
    Member
    Posted 1 year ago #

    ;-)

  17. UFHH
    Member
    Posted 1 year ago #

    @ Jeremy Herve: Even if you have "good news" or not, pls. give us an update. The publicize feature is very essential for a lot of your users!

  18. T.T.Tassel
    Member
    Posted 1 year ago #

    people keep saying FB made changes, but the fault is down to wordpress....sorry you cant have it both ways. Yes FB do keep making changes, but whoever is at fault let the guys fix the problem and stop blaming them, you think that will make them want to work any harder?
    Oh and if those of you are so clever and know the problem, is the API write them the fixed version, oh wait you don't know if that really is the problem or you are just being a sheep...
    Be constructive or let them do it.

  19. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @UFHH You can follow our progress in the Trac ticket I mentioned earlier:
    http://plugins.trac.wordpress.org/ticket/1809

    As you can see, we committed a fix to the development version of Jetpack not that long ago, but we still have some testing to do before we can release an update including that fix.

    If you have a test blog, feel free to apply the fix and let us know in the ticket or here if the fix worked for you.

    Thanks!

  20. UFHH
    Member
    Posted 1 year ago #

    @ Jeremy Herve: You are my hero for today! ^^

    Fix is working fine. Implemented in a testing site, then a single blog and then into a multi-blog... all functions are "back to normal". :)

    Thank you!

  21. Binnet
    Member
    Posted 1 year ago #

    I am an utter novice and I manages to get it working by carefully copy pasting the code from the "ticket". I applied the fix to my bike blog if that's on any help to you.

    Then came the next challenge when I realized that I can't publicize to both my personal FB page and my "page" at the same time... (however that has been solved too).

    Thank you for all the help! =D

  22. hodyshoran
    Member
    Posted 12 months ago #

    Same issue here, I have three pages under my personal FB account, but Jetpack PUB will only see my personal FB account - not working!

  23. Ben
    Member
    Posted 12 months ago #

    I updated some codes according to "the fix" and its working now thxs

  24. Art Project Group
    Member
    Posted 12 months ago #

    The fix is working fine. Well job!

  25. ufojacky
    Member
    Posted 12 months ago #

    looking forward find some good news

  26. cdostie
    Member
    Posted 12 months ago #

    Thank you for the link to a FIX. A point of clarification though, please!?

    On the link to the code changes, should I interpret the green lines as lines to add and the red as lines to delete? I am unclear on the convention or meaning of the background color on the code. That's my guess but I'd like to be clear and I'm sure others would appreciate the info too.

    And thank you again for the fix.

  27. asantb
    Member
    Posted 12 months ago #

    Will someone please help me with the fix?? I am a complete newbie at coding and I am so lost at trying to fix this, but I would really like to be able to post to my FB page again.

  28. mark3738
    Member
    Posted 12 months ago #

    On the link to the code changes, should I interpret the green lines as lines to add and the red as lines to delete?

    At the top of the page it has a legend with a green box that says 'added' and a pink box that says 'removed'. So yes if you do this in the appropriate places it should work.

    I have applied the fix and currently it has worked on a demo site and a live site. I found I had to remove the existing FB links and redo them, so that may help others, but after that no problems at all and no neverending popup boxes asking me to make the connection available.

    Thanks.

  29. 1hundredworks
    Member
    Posted 12 months ago #

    Done and done, hope this fix comes out as an official patch soon

  30. cdostie
    Member
    Posted 12 months ago #

    @mark3738

    I knew there would be an obvious answer, but for us code newbies the obvious things are NOT! Thank you for the clarification.

    @Jeremy Herve. Hero of the week, or for as long as this fix works. ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic