WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin : Jetpack] - Site Inaccessable (7 posts)

  1. overcheckin
    Member
    Posted 2 years ago #

    Hi

    Having a problem activating Jetpack, My site is inaccessible.

    I run my own site from home under ubuntu so i have full access to shell

    My site runs under https with an unverified SSL certificate

    some debug info

    command:

    curl -i -L --data 'test' 'https://jetpack.wordpress.com/jetpack.register/1'

    output:

    HTTP/1.1 400 Bad Request
    Server: nginx
    Date: Fri, 26 Aug 2011 22:30:45 GMT
    Content-Type: application/json
    Transfer-Encoding: chunked
    Connection: close
    Vary: Cookie
    X-hacker: If you're reading this, you should visit automattic.com/jobs and apply to join the fun, mention this header.
    X-Pingback: http://jetpack.wordpress.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Fri, 26 Aug 2011 22:30:45 GMT
    Cache-Control: no-cache, must-revalidate, max-age=60
    Pragma: no-cache
    
    {"error":"home_missing","error_description":"The required \"home\" parameter is missing."}

    Thanks

  2. xcannabis
    Member
    Posted 2 years ago #

    I have the exact same error.

    HTTP/1.1 400 Bad Request
    Server: nginx
    Date: Sat, 27 Aug 2011 05:14:47 GMT
    Content-Type: application/json
    Transfer-Encoding: chunked
    Connection: close
    Vary: Cookie
    X-hacker: If you're reading this, you should visit automattic.com/jobs and apply to join the fun, mention this header.
    X-Pingback: http://jetpack.wordpress.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Sat, 27 Aug 2011 05:14:47 GMT
    Cache-Control: no-cache, must-revalidate, max-age=60
    Pragma: no-cache
    
    {"error":"home_missing","error_description":"The required \"home\" parameter is missing."}root@tophost
  3. designsimply
    Member
    Posted 2 years ago #

    What plugins are you running on your sites?

    What do you have listed for WordPress Address (URL) and Site Address (URL) on the main settings page in your blog dashboard?

  4. Michael Adams (mdawaffe)
    Member
    Posted 2 years ago #

    overcheckin,

    That error response is actually the expected response given that cURL command. What error is displayed in the actual plugin when you try to connect?

    xcannabis,

    I'm not sure what you used to generated that error message. The same cURL command as overcheckin? If so, see above.

  5. andylockran
    Member
    Posted 2 years ago #

    I also have this exact same issue, and run my site under a self-signed certificate - though it's also accessible when unsigned.

  6. WebmasterSAM
    Member
    Posted 2 years ago #

    I'm having this same problem, It worked for a while then I diactivated it because I was getting messed up stats and then I could never reactivate it. I was already installed and running when i used my hosting providers WordPress auto install. the error im getting is...

    Error Details: The Jetpack server was unable to communicate with your site [HTTP 400]. If you are hosted with Go Daddy, they are aware of this issue, and we at WordPress.com are working with them to fix it. If your site is hosted elsewhere, please contact Jetpack Support: http://jetpack.me/support/

    Please someone help fix this I tried going to jetpack support and to my hosting provider for help and they both keep saying "its the other guy"

  7. designsimply
    Member
    Posted 2 years ago #

    It would help to have a bit more detail. Here are a few things to check first:

    1. Is the xmlrpc.php file working properly?
    2. Is your web hosting provider GoDaddy or another host?
    3. What is the URL for the blog you're working on?

Topic Closed

This topic has been closed to new replies.

About this Topic