WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack (Photon?) will not show images properly (19 posts)

  1. mcschaffer
    Member
    Posted 11 months ago #

    I have a problem that started recently. Images on my posts have stopped showing up properly. Here is an example but many other post on my site are affected:
    http://www.mobileedgeonline.com/honda-accord-audio/

    I cannot isolate when it started, but I know it is not long ago.

    It is probably important to note that if you click on any of the malfunctioning images, the correct full sized image appears.

    I suspected Genesis Framework update was the culprit so i rolled it back to 1.9.2... Still had the issue. I have not tried to roll back WordPress. Saving that as a last resort.

    Here are the other steps I have already taken:

    Deactivated ALL plugins and issue went away (all image thumbnails loaded), but of course Tiled galleries, etc were not working because Jetpack was inactive.

    Reactivated ONLY Jetpack and the issue returned.

    Turning Photon on and off did not effect issue (as expected)

    Disconnect and reconnected Jetpack to WordPress.com. No luck

    Completely Deleted Jetpack and reinstalled. No luck

    Contacted Host (Synthesis by Copyblogger).. While helpful, they indicated that the issue is not at their end and I need to post a request here.

    So here I am. Please help as the site in looking pretty bad right now.

    FYI. I maintain about a dozen other Genesis sites and this is the only one with an issue.

    Thanks!

    http://wordpress.org/plugins/jetpack/

  2. mcschaffer
    Member
    Posted 11 months ago #

    As a note, I also looked through all of the relevant posts that I could find relating to issues with Photon, etc. and was not able to solve my issue.

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    I had a look at your site, and the galleries seem to be displayed properly on my end at the moment:
    http://i.wpne.ws/R6Ch

    Could you try to activate the Tiled Galleries module in the Jetpack menu, and update the gallery to use one of the Tiled gallery styles? What happens then? Is the gallery displayed properly, or are the images broken?

    If you find that the images are broken, could you copy one of the image URLs, and paste it here?

    Thanks!

  4. xodigoguy
    Member
    Posted 11 months ago #

    I also am experiencing problems with the normal display of images but I cannot seem to isolate the problem. All my sites are based on Genesis framework but using different themes. With Photon activated, often images will be either scaled-down (very small) or sometimes only partly showing, but not always. Often the sites work just fine!?!

    At first I thought it was just a slow connection issue at my end. But now I see it is intermittently happening on most of my sites. Deactivating the Photon module immediately "fixes" the problem.

    Perhaps something at the Genesis framework end?

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    @xodigoguy Could you post a link to one of your galleries, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

  6. mcschaffer
    Member
    Posted 11 months ago #

    Jeremy, Thanks for your response... I temporarily turned off Photon and Tiled galleries so that they would display all the images.... I will turn that back on now so that you can take a look at it.... Here are some posts that experience the issue:

    http://www.mobileedgeonline.com/classic-car-audio/
    http://www.mobileedgeonline.com/honda-accord-audio/
    http://www.mobileedgeonline.com/mercedes-window-tint/

    I don't want to leave it this way for long... While turning off tiled galleries is not a good solution, it does allow the pages to look ok.. Thanks for your help!!!

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    @mcschaffer Thanks! Could you try to disable Google Pagespeed and your other caching plugins, and let me know if it helps?

  8. mcschaffer
    Member
    Posted 11 months ago #

    Disabling W3 Total Cache (and all other plugins aside from Jetpack) did not solve the problem. I never thought of Google Pagespeed... I'm not sure how to disable that... Let me see what I can do.

  9. mcschaffer
    Member
    Posted 11 months ago #

    The way it looks, I just had to change the CNAME "www" to @ from pagespeed.googlehosted.com

    If that is the case, I did that and it said it could take up to 48 hours.

  10. mcschaffer
    Member
    Posted 11 months ago #

    I'm impatient so I checked to see if anything changed... It seems like it is working better with pagespeed disabled... but far from correctly. The tiled galleries are no longer side by side but stacked on top of each other with full sized photos...

    Also not the standalone images on the Honda Accord post.. it is full size even though it's container is sized correctly with the caption below it.

    is this just a case where I should be more patient and let things take their course for a few hours (or days) and see what the results are???? I just hate having my site looking like it does right now... Thanks for helping to "engineer my happiness" Jeremy!

  11. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    The Galleries look fine for me now; you might indeed have to wait a bit longer for the changes to propagate. It seems Google Pagespeed did some really aggressive caching. If you want to add it back, you might want to see if you can configure it to ignore some of the Javascript libraries on your site, like jQuery and the Jetpack Tiled Galleries libraries.

    It's worth noting that the Tiled Galleries don't take up the whole space in your content area at the moment:
    http://i.wpne.ws/R7LM

    To solve this issue, you'll have to define a $content_width variable in your theme, as explained here:
    http://codex.wordpress.org/Content_Width

    In your case, you should set the content_width variable to 600px

    if ( ! isset( $content_width ) )
    	$content_width = 600;

    If you don't want to make changes to your theme, you can also use this plugin:
    http://wordpress.org/plugins/custom-content-width/

    I hope this helps.

  12. mcschaffer
    Member
    Posted 11 months ago #

    Jeremy, Thank you so much! I believe that it is starting to look "more correct" each time I check it... So it appears that Pagespeed was the culprit.

    I felt that Pagespeed Did make a difference for my site so i will explore modifying the configuration... Would you mind offering your opinion as to whether I should invest the time on a site like mine... Or should I let good enough alone?

    And thanks for the observation on the content width... I've made the correction and it looks much better!

    Very glad you spent the time to help me.

  13. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    Would you mind offering your opinion as to whether I should invest the time on a site like mine... Or should I let good enough alone?

    To be honest I'm not familiar enough with Google Pagespeed to tell you if it's worth the effort or not. I tend to think that a good caching plugin like W3 Total Cache or WP Super Cache is usually good enough, but then again I don't know enough about Google Pagespeed to be able to give you good advice.

    You might want to start a new thread in the Feedback forums, maybe someone else will have enough experience to give you some good recommendations, and maybe tips to optimize Google Pagespeed for WordPress.

    Good luck!

  14. xodigoguy
    Member
    Posted 11 months ago #

    @jeremy, the link is here:
    http://www.ronis-schluessel.de/schloss/ronis-schlosser/

    Unlike @mcschaffer I am not using Google Pagespeed but I had deactivated and deleted wp-supercache cached files a couple of times.

    I have reactivated Photon and immediately the images don't show on my Android phone or show incorrectly on Firefox.

    (I was just thinking that the one site [www.30-days.net] which does work fine with Photon is actually on a different host ... and as I mentioned above, uses a different Genesis theme ...)

  15. mcschaffer
    Member
    Posted 11 months ago #

    Jeremy,

    Thanks again for your support. I have decided that I am not going to reactivate PageSpeed at this time. My site is really fast and responsive without it and I don't want to run the risk of future issues. Perhaps I'll revisit it at a later date.

    You have been a tremendous help. I wish I could say that I will return the favor sometime, but my skill set with this sort of thing is lacking! So a sincere "THANK YOU" is all I've got!

  16. designsimply
    Member
    Plugin Contributor

    Posted 10 months ago #

    @mcschaffer, I agree that Jeremy is awesome. :)

    @xodigoguy, would you mind please starting a new help request at http://wordpress.org/support/plugin/jetpack#postform and include a link to a page where the problem with the galleries is happening so I can take a closer look? Can you also mention the version of Genesis you are using?

    Thank you!

  17. xodigoguy
    Member
    Posted 10 months ago #

    @designsimply, thank you I will. I will have to schedule it a bit so I can reactivate Photon but I will do that on the new request. Thank you!

  18. iSaumya
    Member
    Posted 9 months ago #

    I'm also having some issue with pagespeed when I activate phone. looks like pagespeed & phton are clashing some how, After activating photon, some images are showing as broken image.

  19. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    @iSaumya Could you please start your own thread, as @designsimply mentioned above?

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic